LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-29-2003, 01:10 PM   #1
scarsmonkey
LQ Newbie
 
Registered: Jul 2003
Posts: 7

Rep: Reputation: 0
Question cdrom issues


any ideas on how to mount a cdrom drive while logged in under another user. call me stupid i know you want to. please don't just tell me to log-in with su, i'm not that stupid. while i'm at it anyone have any ideas on cd burning and where to get the packages.
 
Old 07-29-2003, 01:18 PM   #2
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 57
No! I don't want to call you names that may not be true!

# Managing drives
LNAG - Accessing my drives
Rute - Device Mounting

You probably have the cd burning stuff installed.
# CD burning info
Is it configured and what is the device? Command this to find out:
cdrecord -scanbus
Adding an IDE CD-Writer to Linux
CD Writing HOWTO
Burning CDs on Linux

# Burn an ISO to disk
cdrecord -v speed=<burning speed> dev=<your device> /path/to/foo.iso
# Burn from disk to disk
cdrecord -v dev=<your device> speed=<burning speed> -isosize /dev/cdrom
# Generate an ISO from a directory.
mkisofs -Jr -o foo.iso /path/to/directory
mkisofs -vrTJUV "Label" -o foo.iso /path/to/directory
# Generate an ISO from a CD
dd if=/dev/cdrom of=foo.iso
Linux MP3 CD Burning mini-HOWTO
# Convert mp3 to wav with lame
for i in *.mp3; do lame --decode $i `basename $i .mp3`.wav; done
# Burn a CD from wav files
cdrecord -v -audio -pad speed=<burning speed> dev=<your device> /path/to/*.wav
# Erase a CDRW
cdrecord -v dev=<your device> speed=<burning speed> blank=fast
 
Old 07-29-2003, 04:32 PM   #3
scarsmonkey
LQ Newbie
 
Registered: Jul 2003
Posts: 7

Original Poster
Rep: Reputation: 0
thank you

i just read some of what you told me. i'm going to try to change my /etc/fstab to look something like this

/dev/sda /mnt/cdrom iso9660 noauto,ro,user 0 0

then i'm going to start looking at the burning software
 
Old 07-30-2003, 09:39 AM   #4
tipaul
Member
 
Registered: Apr 2003
Location: Laval, Quebec, Canada
Distribution: Ubuntu
Posts: 121

Rep: Reputation: 15
Exclamation sda...

> /dev/sda /mnt/cdrom iso9660 noauto,ro,user 0 0

That means you have a SCSI cdrom...

Hope you have a real SCSI cdrom... If not, you must use /dev/hdx (x=b, c or d ... depending if it is the D:, E: or F: drive for Windows) instead of /dev/sda

By the way, if you have an IDE CDBurner, you must use ide-scsi emulation (hdx=ide-scsi) to use it... And I normally use the scsi emulation on my CDROM drive also to be able to use it under cdburning application under X (like K3b)....
 
Old 07-30-2003, 10:01 AM   #5
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Re: thank you

Quote:
Originally posted by scarsmonkey
i just read some of what you told me. i'm going to try to change my /etc/fstab to look something like this

/dev/sda /mnt/cdrom iso9660 noauto,ro,user 0 0

then i'm going to start looking at the burning software
Something like that but not exactly - you probably need to make sure it says users. That screwed me up for the longest time and it's one of those things that, once you've modified it, you think "Well, I've already done that" and you're lucky if you ever catch it.
 
Old 07-30-2003, 10:12 AM   #6
reclusivemonkey
Member
 
Registered: May 2003
Location: Halifax, WY, UK
Distribution: Slackware 9
Posts: 167

Rep: Reputation: 30
Try /dev/sr0, thats usually the device number when using ide-scsi for the cd-burner. My slackware always prompts this to me if I forget. You must make sure you have this line in /etc/lilo.conf:-

append = "hd[X]=ide-scsi"

(be sure to type 'lilo' if you are adding this line to refresh lilo)

Where [X] is the letter of your drive. If you have your hard drive on your primary IDE, and your cd burner on your secondary ide, it will be 'hdc' for the master and 'hdd' for the slave.
 
Old 07-31-2003, 07:38 PM   #7
scarsmonkey
LQ Newbie
 
Registered: Jul 2003
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks everyone. My users can now access the cdrom drive. All I did was change "owner" to "users" in my /etc/fstab
 
Old 08-01-2003, 04:23 PM   #8
scarsmonkey
LQ Newbie
 
Registered: Jul 2003
Posts: 7

Original Poster
Rep: Reputation: 0
new problem i can't umount my cdrom it gives me one of three error even under root

umount failed

/mnt/cdrom busy

inproper filesystem

what is going on?
 
Old 08-01-2003, 04:38 PM   #9
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
You'll get a 'busy' if you are in the directory or some app is using something in the directory. Not sure about the 'improper filesystem' - that usually occurs on mount when you don't have the type in fstab, rather than on unmount. I think.

So as far as the first, make sure no activity is going on and cd out of the /mnt/cdrom directory, close any apps using it, etc.
 
Old 08-01-2003, 06:21 PM   #10
scarsmonkey
LQ Newbie
 
Registered: Jul 2003
Posts: 7

Original Poster
Rep: Reputation: 0
as for the busy part, nothing i open when it occurs. it happens in KDE if i use a desktop icon to mount and umount the cdrom device. if i use the prompt i can mount and umount all i want and nothing happens. sorry maybe that extra info will help.
 
Old 08-01-2003, 09:38 PM   #11
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Hm. Yeah, it narrows it down to something wiggy with KDE but I don't use KDE, so I'm not sure what it is. I *have* used KDE but never had that problem. With me, it's always because I've got an xterm or term up somewhere that I left in that directory. *g*

I don't really know what to say - I guess just check the properties of the icon - maybe it's pointing to the wrong device or has the wrong permissions or something of that nature? Also check that, if it points to /dev/cdrom that that symlink, in turn points to the right device. If you've changed stuff regarding ide/scsi/emulation/etc you may have broken shortcuts and links and config files here and there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cdrom issues hobgoblin Slackware 8 07-05-2005 10:04 AM
cdrom issues cs-cam Linux - Hardware 6 01-08-2005 01:06 PM
cdrom issues talkinggoat Linux - Hardware 9 07-12-2004 01:27 PM
CDRom issues.... penguinz Linux - Hardware 0 03-12-2003 09:23 AM
CDROM issues kkempter Linux - Hardware 1 12-13-2002 01:58 PM


All times are GMT -5. The time now is 07:40 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration