LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-23-2006, 11:03 AM   #1
angryfirelord
Member
 
Registered: Dec 2005
Posts: 491

Rep: Reputation: 57
cdrom and usb drive not detected


I got a fresh install of Slack 10.2 on my computer but it does not seem to have detected my cd burner on the slave channel or my usb drive in KDE. I watched the scrolling text while it was booting and it did pick up the slave drive (master cdrom hda, slave cdrom hdb, and hard drive hdc). However, KDE does not seem to see it and there was nothing in the /etc/fstab file that said anything about a second cdrom drive.

Also, the USB drive did not seem to have been detected under KDE as well. Running the lsusb command revealed the following:
Code:
BUS 001 Device 002: ID05dc:a410 Lexar Media, Inc.
I also tried the mount usbfs command and it didn't work:
Code:
mount: usbfs already mounted or /proc/bus/usb busy
mount: according to mtab, usbfs is already mounted on /proc/bus/usb
Any idea on how to fix this?

I guess this where my Slackware journey begins.
 
Old 07-23-2006, 01:41 PM   #2
simcox1
Member
 
Registered: Mar 2005
Location: UK
Distribution: Slackware
Posts: 794
Blog Entries: 2

Rep: Reputation: 30
Slackware doesn't pick up my second cdrom either. You need to add an entry to fstab manually, and maybe make a new directory or two. Shilos guide at the top of this forum "This is how I do it all" might help.
 
Old 07-24-2006, 10:22 PM   #3
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
Make sure you have usb modules loaded:
$ lsmod
ehci_hcd
usb_storage

Then try this:
dmesg|grep sd[a-z]

You should be able to locate your usb drive by the size.

Quote:
I also tried the mount usbfs command and it didn't work:
Thats because usbfs is already mounted, probably you have it listed in /etc/fstab. Try lsusb to verify an you should see something like this:
$ lsusb
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 004: ID 0781:0621 SanDisk Corp. SDDR-86 Imagemate 6-in-1 Reader
Bus 002 Device 003: ID 05e3:0604 Genesys Logic, Inc.
Bus 002 Device 002: ID 046d:0870 Logitech, Inc. QuickCam Express
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 04f1:0008 Victor Company of Japan, Ltd
Bus 001 Device 001: ID 0000:0000
 
Old 07-25-2006, 05:12 AM   #4
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
Quote:
KDE does not seem to see it and there was nothing in the /etc/fstab file that said anything about a second cdrom drive.
so do edit the fstab, that is the solution here i wil show u how to edit it

first do a "dmesg |grep CD " or dmesg |more and scroll down and see what device is assigned.
Quote:
(master cdrom hda, slave cdrom hdb, and hard drive hdc)....
are u sure?? i dont think so!!! anyway scroll the dmesg out and find the devices

master cdrom is taken, so no problem

if u found that ur slave cdrom is "/dev/hdb" we wil edit the fstab like this
[CODE]/dev/hdb /mnt/cd-rw auto noauto,user,ro 0 0[\CODE]for this u must need a dir called "/mnt/cd-rw"

still some more issues may come according to wether u are using 2.4 or 2.6 kernel, regarding cd writting if u are using 2.4 please reply
----
do a "dmesg |grep usb " or dmesg |more and scroll down and see what device is assigned.
if u dont have a scsi or sata disk most of the time the usb will be /dev/sda1, i hope ue usb will be vfat and u have a /mnt/usb dir. with all these im mind i will edit the fstab as
Code:
/dev/sda1 /mnt/usb vfat noauto,rw,umask=000 1 0
now plug the usb in and do a mount command (mount /mnt/usb)or click on the relevent icon in "mycomputer" in ur fav. KDE.
note: if /dev/sda1 is not the device then /dev/sda2 or /dev/sdb1 may be, then edit fstab like that

edit:before doing all this, see wether hotpugging is enabled! happy slacking
 
Old 07-25-2006, 09:33 AM   #5
angryfirelord
Member
 
Registered: Dec 2005
Posts: 491

Original Poster
Rep: Reputation: 57
after thinking about it for a day (sry rkrishna i wish i had seen your post before i solved it) i added the following line to my fstab file and made a folder for mnt:
Code:
/dev/hdb         /mnt/cdrw        iso9660     noauto,owner,ro  0   0
this got the slave drive running (when i built the computer i didn't realize that the hard drive cable was in the 2nd ide port instead of the first. That's why my slave drive is hdb.)

to get the usb drive running i ran the dmesg and searched through the miles of text until i saw Lexar Media, Inc. on sda1 . I created a folder lexar_media in mnt and added another line to fstab:
Code:
/dev/sda1        /mnt/lexar_media vfat        ro               0   0
Boom! The lexar drive is now working (although it sees it as a hard drive instead of a memory stick but i don't care, as long as it works )

I couldn't believe how simple that was. I feel like hitting myself.

Thanks to everyone who responded! I felt a point get knocked off my newb rating (i'm a 99% newb instead of a 100% newb).
 
Old 07-26-2006, 04:04 AM   #6
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
Quote:
/dev/hdb /mnt/cdrw iso9660 noauto,owner,ro 0 0
i hope u can change iso9660 --> auto hi
Quote:
/dev/sda1 /mnt/lexar_media vfat ro 0 0
can u able to mount as $user, and write on it??

now onwards u can configure usb problems in any linux flavours like Ubuntu, Fedora,.... being a slacker seems to be nice
 
Old 07-26-2006, 05:00 AM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
If you want to be able to mount as a normal user, add "users" (or "user") to the options list for the relevant line in fstab. As for writing to it as a regular user, I think you may need to use umask because FAT partitions don't use permissions. It may be "umask=000" that you need to add to the options list, but I'm not sure.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can boot from MEPIS CD, but CDROM drive not detected geniusiknowit Linux - Laptop and Netbook 4 03-16-2006 02:23 PM
mouse wheel not working and cdrom drive not detected anindyanuri Slackware 19 06-19-2005 02:33 PM
USB thumb drive detected by usb but not by scsi ashlock Linux - Hardware 6 06-02-2005 02:58 PM
cdrom drive not detected dkgilbey Linux - Hardware 9 05-05-2005 03:07 AM
USB drive not detected AmarAPatel Linux - Hardware 8 01-03-2005 05:26 AM


All times are GMT -5. The time now is 03:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration