LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-27-2003, 11:46 PM   #1
thundersnows
Member
 
Registered: Jul 2003
Location: Jakarta
Distribution: Slackware, Fedora Core 2
Posts: 83

Rep: Reputation: 15
CDROM and FLOPPY problem


Hi,
I've got problem with my devices.
CDROM
- I can't mount my cd audio with any accounts (root and my users)
- I can play my cd audio with KsCD using root account but can not using my users
- I can mount other cd with all users
- error message when I tried to mount cdrom :
Called : mount /dev/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems
- error message when I tried play cd with KsCD using my users :
CDROM read or access error (or no audio cd in drive).
Please make sure you have access permissions to: /dev/cdrom

FLOPPY
- I can't mount my floppy with any users
- error message :
Called: mount /dev/fd0
mount: I could not determine the filesystem type, and none was specified

My fstab :
/dev/hda1 / ext2 defaults 1 1
/dev/hda2 /mnt/hda2 ext2 defaults 1 2
/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,users 0 0
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0

Can someone help me about this ?
Thanks.
 
Old 08-28-2003, 12:28 AM   #2
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Re: CDROM and FLOPPY problem

Quote:
Originally posted by thundersnows
Hi,
I've got problem with my devices.
CDROM
- I can't mount my cd audio with any accounts (root and my users)
- I can play my cd audio with KsCD using root account but can not using my users
- I can mount other cd with all users
- error message when I tried to mount cdrom :
Called : mount /dev/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems
- error message when I tried play cd with KsCD using my users :
CDROM read or access error (or no audio cd in drive).
Please make sure you have access permissions to: /dev/cdrom

FLOPPY
- I can't mount my floppy with any users
- error message :
Called: mount /dev/fd0
mount: I could not determine the filesystem type, and none was specified

My fstab :
/dev/hda1 / ext2 defaults 1 1
/dev/hda2 /mnt/hda2 ext2 defaults 1 2
/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,users 0 0
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0

Can someone help me about this ?
Thanks.
Firstly, music CDs are not meant to be mounted.
Secondly, you should mount your (data) CDs by typing: mount /mnt/cdrom
For your floppy, I think you should set the fs type to: fat
 
Old 08-28-2003, 12:54 AM   #3
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
hey, i'm having the same problem with audio cd's. i get a driver error from CD Player, and kscd says the same thing: no media in the drive and make sure you have permission to access this device.

unfortunately i have no idea what's causing it let me know if you figure it out
 
Old 08-28-2003, 03:34 AM   #4
thundersnows
Member
 
Registered: Jul 2003
Location: Jakarta
Distribution: Slackware, Fedora Core 2
Posts: 83

Original Poster
Rep: Reputation: 15
Ok, I can play audio cd now.I run KsCD as root account.
I think the problem is KsCD is own by root so other users can't use it. How to change file permission ?
 
Old 08-28-2003, 04:16 AM   #5
zsejk
Member
 
Registered: Apr 2003
Distribution: Slackware
Posts: 345
Blog Entries: 5

Rep: Reputation: 30
By typing "chmod".

chmod 777 sets read, write, and execute permissions for everyone
chmod 666 sets read and write permissions for everyone
chmod 555 sets read and execute permissions for everyone

Ah well.... a short explanation:

If you do "ls -l" you will see a directory listing of whatever directory your in. You will see something like -rwxr-xr-x in front of every single one. Now that bit has 10 positions, as you can see. The first position indicates what kind of file it is (d for directory, for instance). The second, third, and fourth deal with root's permissions: r stand for read, w stand for write, and x stands for executable. So for instance:

-rwx------

would be a file over which root has all permission, but all other users none.

The fifth, sixth, and seventh position deal with permissions for user groups; the eight, ninth, and tenth positions deal with permissions for users.

Each block of three from right to left (so the first block is the tenth, ninth, and eigth position) is a binary number of three digits (hence it is a block of three positions). Binary digits being converted into regular number as:

... 4 2 1

reading from right to left, you can see how a three position block (say the one for root) can be indicated by a regular number. So for instance with

- rwx --- ---

you see that only the root block of three positions has all positions filled. Writing that in binary blocks of three digits you would have:

0 111 000 000

Discounting the first position, you see that the regular number value of the root block is 7 (1 + 2 + 4), and the regular number value for the users group and the user are 0. Setting a permission like

- rwx --- ---

would be accomplished by typing "chmod 700".

...

Ok, I am *sure* I have not made things cleared for anyone, but I'm sure as hell not gonna delete this post.



-zsejk
 
Old 08-28-2003, 07:29 AM   #6
thundersnows
Member
 
Registered: Jul 2003
Location: Jakarta
Distribution: Slackware, Fedora Core 2
Posts: 83

Original Poster
Rep: Reputation: 15
hi zsejk, thanks for the explanation it really helpful.
btw, i've tried to chmod 555 kscd, but unsuccessfull. it seem i can't find the location of the file.
chmod : getting attributes of 'kscd' : No such file or directory.

and for my floppy, i've change fstab :
/dev/fd0 /mnt/floppy auto noauto,users 0 0
-> /dev/fd0 /mnt/floppy fat noauto,users 0 0
-> /dev/fd0 /mnt/floppy vfat noauto,users 0 0
but still not success. what is the parameter i should change ?
 
Old 08-28-2003, 10:26 AM   #7
Azmeen
Senior Member
 
Registered: May 2003
Location: Malaysia
Distribution: Slackware, LFS, CentOS
Posts: 1,307

Rep: Reputation: 46
Floppy prob... try:
Code:
/dev/fd0         /mnt/floppy      auto        noauto,user,rw      0   0
Changing attributes of kscd:
To find kscd: whereis kscd
Set kscd exec permission for others: chmod o+x opt/kde/bin/kscd

Cheers!
 
Old 08-28-2003, 12:50 PM   #8
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
i just figured out the solution, you need to su root, then run

chmod 444 /dev/cdrom <--- or whatever your cdrom dev is

this sets read-only permission for all users. i was having the same problem and just fixed it.

hope that helps!
 
Old 08-28-2003, 11:44 PM   #9
thundersnows
Member
 
Registered: Jul 2003
Location: Jakarta
Distribution: Slackware, Fedora Core 2
Posts: 83

Original Poster
Rep: Reputation: 15
cheers mcd, it worked now

now, my last problem, i can't mount my floppy.
it seem my box can't recognize the filesystem.
error message :
mount: fs type vfat not supported by kernel
how to fix this ? thanks
 
Old 09-06-2003, 03:34 PM   #10
joesbox
Member
 
Registered: Feb 2003
Location: hampton va
Distribution: ubuntu
Posts: 502

Rep: Reputation: 30
you may need to recompile you kernel to allow for reading vfat
 
Old 09-06-2003, 06:16 PM   #11
nutronix
Member
 
Registered: Jan 2003
Location: montreal
Distribution: Slackware and XUbuntu
Posts: 110
Blog Entries: 1

Rep: Reputation: 17
I am no expert but here goes; i had the same problem with mounting my floppies ;i did chmod a+rw /dev/fd0u1440 and except for replacing owner with user i did not change anything else in /fstab;

eutron@legros:~$ cat /etc/fstab
/dev/hda4 swap swap defaults 0 0
/dev/hda3 / ext3 defaults 1 1
/dev/hda1 /fat-c vfat defaults 1 0
/dev/hda5 /fat-d vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,user 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

hope this helps (no recompiling necessary in my case)..:-) nuttron

p.s.= did this as root (su - )...without the ( )..

Last edited by nutronix; 09-06-2003 at 10:59 PM.
 
Old 09-06-2003, 11:55 PM   #12
eric.r.turner
Member
 
Registered: Aug 2003
Location: Planet Earth
Distribution: Linux Mint Debian Edition (LMDE)
Posts: 215

Rep: Reputation: 31
Quote:
Originally posted by joesbox
you may need to recompile you kernel to allow for reading vfat
You DON'T need to recompile your kernel to get vfat support! This is what loadable kernel modules are for.

Edit /etc/rc.d/rc.modules and uncomment the line that says "/sbin/modprobe vfat". Uncomment the lines for any other filesystem types you want to support.

Now, you can either reboot or just run the /sbin/modprobe command from the command line. The next time you boot you will automaticall get these modules loaded for you.

Use the lsmod command if you're interested in seeing which modules are loaded.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/etc/mtab problem = can't mount anything--cdrom,floppy,etc. theo444 Slackware 11 08-23-2005 02:57 AM
cdrom and floppy drive auto mount problem shams Fedora 1 02-27-2005 08:43 AM
Floppy and CDRom subaruwrx Slackware 1 06-15-2004 06:43 AM
floppy/cdrom mount problem thar Linux - General 6 10-15-2003 07:05 PM
/auto - mounting floppy/cdrom problem islandkid Linux - General 3 03-18-2002 03:16 AM


All times are GMT -5. The time now is 01:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration