LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-29-2004, 02:12 AM   #1
Vindane
Member
 
Registered: Jan 2004
Location: Indiana
Distribution: Fedora
Posts: 117

Rep: Reputation: 15
cdrom acting weird


I guess this is the first time that I've used my cdrom drive since installing Slackware and I can't get it to read any data cd's or when I put in a regular music cd, it plays in all the programs but I don't hear any sound. I've made sure that my CD volume is up on my system audio mixer. Any ideas?
 
Old 05-29-2004, 03:02 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,986
Blog Entries: 11

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
I hope you're not insulted with this question,
but you DID mount the CD before trying to
access it?

As for the audio: the vast majority of Linux
CD-Player kind of apps does NOT support
digital audio transfer, that is, if your CD isn't
hooked up to the soundcard via analog cable
you won't hear anything.




Cheers,
Tink
 
Old 05-29-2004, 08:38 AM   #3
Vindane
Member
 
Registered: Jan 2004
Location: Indiana
Distribution: Fedora
Posts: 117

Original Poster
Rep: Reputation: 15
No not at all. It wasn't that long ago that I was being offended when someone DID tell me to "go mount your cdrom". But I was offended because I thought someone was trying to be crude to me.

Yep, it is mounted and I can read AND listen off of audio cd's. I got XMMS to play the audio, after going to preferences and adjusting "CD" to retrieve digital or something or other. But I can't get other CD playing programs to play the audio yet.

However, I don't have the audio cable connecting the sound card to the cdrom. I've never had any problem with it before but I guess I'll try that next.
 
Old 05-29-2004, 05:40 PM   #4
urka58
Member
 
Registered: Nov 2003
Distribution: slackware 14
Posts: 532

Rep: Reputation: 30
Does your device works fine when logged as root? If yes it could be a permission problem on your device.
Try editing your /etc/group file including yourself as normal user into the disk group.
This should fix the problem.
Ciao
 
Old 05-29-2004, 08:51 PM   #5
Vindane
Member
 
Registered: Jan 2004
Location: Indiana
Distribution: Fedora
Posts: 117

Original Poster
Rep: Reputation: 15
nope, it happens even as root
 
Old 05-30-2004, 12:53 AM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,986
Blog Entries: 11

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Hmmmm ... can you please post the output of the
following here?

dmesg
cat /etc/fstab

and also what you get when you
mount /mnt/cdrom
on a command line?



Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache acting weird Red Squirrel Linux - Software 2 08-19-2005 08:47 PM
Networkcard is acting weird Rolby Linux - Hardware 2 06-26-2004 01:45 PM
Vi Editor acting weird thom Fedora 1 06-19-2004 01:15 PM
Radeon acting weird... r_jensen11 Linux - Hardware 9 05-09-2004 01:41 AM
IPCHAINS is acting weird Snabber Linux - Networking 11 08-08-2003 10:07 AM


All times are GMT -5. The time now is 01:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration