LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 09-23-2003, 11:44 AM   #1
ghambis
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Rep: Reputation: 0
Angry cdrecord not working - "cannot open /dev/pg1"


Hi All,

i have Slackware 9.0 installed. i don't use LILO or anything like that. i have a boot diskette (got WinXP on another partition).

obviously this makes the boot process quite slow, and i'm a bit scared the diskette might get ruined some day. i decided to build a startup CD-ROM. got the images ready and all, but can't write to CD.

first when i go "cdrecord -scanbus" at the CLI, i get a message that says cannot open "/dev/pg*".

i tried "cdrecord dev=ATAPI -scanbus" i discovered that my CDRW device is listed as device 0,1,0.

Help please. thanks.
 
Old 09-23-2003, 07:15 PM   #2
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
You probably need to pass hdd=ide-scsi (change hdd to where ever you have your burner hooked up) to the kernel in your bootloader.

# CD burning copying ripping info
Is it configured and what is the device? Command this to find out:
cdrecord -scanbus
Adding an IDE CD-Writer to Linux
CD Writing HOWTO
Burning CDs on Linux
# Burn an ISO to disk
cdrecord -v speed=<burning speed> dev=<your device> /path/to/foo.iso
# Burn from disk to disk
cdrecord -v dev=<your device> speed=<burning speed> -isosize /dev/cdrom
# Generate an ISO from a directory.
mkisofs -Jr -o foo.iso /path/to/directory
mkisofs -vrTJUV "Label" -o foo.iso /path/to/directory
# Generate an ISO from a CD
dd if=/dev/cdrom of=foo.iso
# cdparanoia - search for a drive with reporting of autosense:
cdparanoia -vsQ
# Rip a complete audio CD with cdparanoia
cdparanoia -B "1-"
Linux MP3 CD Burning mini-HOWTO
# Convert mp3 to wav with lame
for i in *.mp3; do lame --decode $i `basename $i .mp3`.wav; done
# Burn a CD from wav files
cdrecord -v -audio -pad speed=<burning speed> dev=<your device> /path/to/*.wav
# Erase a CDRW
cdrecord -v dev=<your device> speed=<burning speed> blank=fast
 
Old 09-23-2003, 09:43 PM   #3
wallison
Member
 
Registered: Jul 2003
Location: MD USA
Distribution: Slackware
Posts: 136

Rep: Reputation: 18
Thanks fancypiper, lots of good info.
 
Old 09-24-2003, 05:34 AM   #4
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
You may or may not have to pass hdd=ide-scsi. Since cdrecord dev=ATAPI -scanbus finds your burner, and shows it as 0,1,0; you may be able to burn with a command similar to this:

cdrecord -v speed=[speed of burner] dev=ATAPI:1,0 -data [name of iso image]

On my system, cdrecord dev=ATAPI -scanbus shows that my burner is 0,0,0 and so this is the exact command I use to burn iso images to disk:

cdrecord -v speed=16 -overburn driveropts=burnfree dev=ATAPI:0,0 -pad -data [name of iso image]

Enjoy!
--- Cerbere
 
Old 09-30-2003, 02:04 AM   #5
ghambis
LQ Newbie
 
Registered: Sep 2003
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks Cerbere, your method actually worked.

cheers all!!
 
Old 09-30-2003, 02:55 AM   #6
Cerbere
Member
 
Registered: Dec 2002
Location: California
Distribution: Slackware & LFS
Posts: 799

Rep: Reputation: 33
Actually ?!!??!! You doubted me? ;-)

Glad I could help.

Enjoy!
--- Cerbere
 
Old 10-24-2003, 06:30 PM   #7
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Rep: Reputation: 30
does anyone know what the format is to burn over a network?

I had to put my CD-R in my Linux box so when I have to burn, I can either copy it over or find out how to burn over a network.

I have tried

cdrecord -v dev=0,0,0 hamish@172.24.15.228:/home/hamish/data2/burn/dream.iso

that Ip address is that of my desktop where the file is.

thanks, hope someone has an answer

hamish

ps: go linux! hehe
 
Old 10-26-2003, 06:21 AM   #8
hamish
Member
 
Registered: Aug 2003
Location: Edinburgh
Distribution: Server: Gentoo2004; Desktop: Ubuntu
Posts: 720

Rep: Reputation: 30
OK,

I now figure that I can do this with NFS, which I'm in the process of setting up.

I will get back to you all

Hamish
 
Old 10-26-2003, 04:09 PM   #9
anadyr
Member
 
Registered: Mar 2003
Distribution: archlinux
Posts: 40

Rep: Reputation: 15
I had that problem, and just adding this line to the bootloader didn.t work. because I have a scsi cdwriter... I recompiled the kernel again, and after that -scanbus read it properly. still it is very strange that it stopped working... cause I didn.t do anything... very windows-like...
 
Old 02-12-2004, 06:08 PM   #10
smaruntiel
LQ Newbie
 
Registered: Feb 2004
Location: Montreal
Distribution: slackware
Posts: 2

Rep: Reputation: 0
Well, the solution is quite simple! This should apply to all distros not just slackware(the one I am using and the one in question here).

first, if you modified/updated the original kernel, the cdrecord would not see your ATAPI disks anymore, therefore, you need to complile kernel as follow:

- go to the IDE/ATAPI section and disable complitly the CDROM support.
- enable SCSI emulation as built in (as module might work as well)
- in SCSI section make sure SCSI support is enabled (not module) and the generic SCSI support also enabled (not module).

Compile/install/reboot with new kernel and you will see the generic scsi finding your ATAPI cdroms... at that point, the issue is fixed.

Enjoy,
Sebastian
smaruntiel@home.ro
 
Old 02-12-2004, 06:11 PM   #11
smaruntiel
LQ Newbie
 
Registered: Feb 2004
Location: Montreal
Distribution: slackware
Posts: 2

Rep: Reputation: 0
PS to the original posting:

don't forget to specify in lilo the append option for your /dev/hdwahtever your cdrom/writer is and load the ide-scsi module (which in slackware is loaded by default trough /etc/rc.d/rc.modules ). Nevertheless double-check to make sure the module is loaded @ boot-time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Could not open device "/dev/dsp" for writing bhomass Debian 7 11-16-2005 04:04 PM
eject -v says "unable to open /dev/hdc" Simon Bridge Slackware 2 11-05-2005 02:55 AM
CD burner problems: "cannot open /dev/sg*" beebop Fedora 10 09-25-2004 03:31 PM
help: cdrecord does not work due to "Cannot open SCSI driver" parv Linux - Software 2 09-21-2004 09:54 PM
USB external CD-RW: cdrecord "cannot open SCSI driver" Avatar Linux - Hardware 10 04-07-2004 12:00 PM


All times are GMT -5. The time now is 11:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration