LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-08-2003, 02:58 AM   #1
ic3
LQ Newbie
 
Registered: Oct 2003
Location: los angeles
Distribution: Slackware 9.1*
Posts: 16

Rep: Reputation: 0
CD rom drive not working....


Ok when I try to mount my cdrom I keep getting this message:

$ mount /mnt/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems

and slackware doesn't even notice my CDRW drive .... my cdrom drive is acer 56x and my CDRW is lite-on 16x10x40x any1 know how I can install these to make them work? im using GNOME as my GUI...

Any help is appreciated

Much thanks

Ic3
 
Old 11-08-2003, 03:12 AM   #2
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware 13.37
Posts: 785

Rep: Reputation: 31
Could you post your fstab and lilo.conf
 
Old 11-08-2003, 03:17 AM   #3
ic3
LQ Newbie
 
Registered: Oct 2003
Location: los angeles
Distribution: Slackware 9.1*
Posts: 16

Original Poster
Rep: Reputation: 0
etc/fstab:

dev/hda5 swap swap defaults 0 0
/dev/hda2 / ext3 defaults 1 1
/dev/hda3 /usr/local ext3 defaults 1 2
/dev/hda1 /windows vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,user,ro 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0


lilo.conf:

# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 800x600x32k
vga = 787
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# DOS bootable partition config begins
other = /dev/hda1
label = DOS
table = /dev/hda
# DOS bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda2
label = Linux
read-only
# Linux bootable partition config ends
 
Old 11-08-2003, 03:47 AM   #4
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware 13.37
Posts: 785

Rep: Reputation: 31
Quote:
$ mount /mnt/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems
What 'type' of cdrom was this(music or data)?

You have to edit your fstab file to add an entry for your cd-rw. Something like this:
/dev/cdrw /mnt/cdrw iso9660 noauto,user,ro 0 0
Add this line to your lilo.conf just under #Start Lilo global section:
append="hdx=ide-scsi" replace the x in hdx with the appropriate drive letter(c or d, depends on it's position on the cable).
Next create a mount point for your cdrw:
mkdir /mnt/cdrw
Then create a soft link between /dev/hdx and /dev/cdrw:
ln -s /dev/hdx /dev/cdrw
And finally, either add the user to the cdrw group or change it's permissions so that anyone can use it.

Last edited by quietguy47; 11-08-2003 at 03:52 AM.
 
Old 11-08-2003, 04:45 AM   #5
ic3
LQ Newbie
 
Registered: Oct 2003
Location: los angeles
Distribution: Slackware 9.1*
Posts: 16

Original Poster
Rep: Reputation: 0
it was music... a problem?
 
Old 11-08-2003, 04:54 AM   #6
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware 13.37
Posts: 785

Rep: Reputation: 31
You don't mount a music cd.
 
Old 11-08-2003, 05:32 AM   #7
ic3
LQ Newbie
 
Registered: Oct 2003
Location: los angeles
Distribution: Slackware 9.1*
Posts: 16

Original Poster
Rep: Reputation: 0
Note taken. however when I use my cd player program i get a drive error on it.... and the device is /dev/cdrom on my preferences, you know how to fix that?
 
Old 11-08-2003, 08:18 AM   #8
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware 13.37
Posts: 785

Rep: Reputation: 31
What's the error message?
 
Old 11-08-2003, 08:36 AM   #9
glennardo
Member
 
Registered: Oct 2003
Location: Jakarta, Indonesia
Distribution: Slackware 13.37
Posts: 50

Rep: Reputation: 15
Re: CD rom drive not working....

Quote:
Originally posted by ic3
Ok when I try to mount my cdrom I keep getting this message:

$ mount /mnt/cdrom
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems

and slackware doesn't even notice my CDRW drive .... my cdrom drive is acer 56x and my CDRW is lite-on 16x10x40x any1 know how I can install these to make them work? im using GNOME as my GUI...

Any help is appreciated

Much thanks

Ic3
this is mine :

/dev/hda5 swap swap defaults 0 0
/dev/hda3 / reiserfs defaults 1 1
/dev/hda2 /boot ext3 defaults 1 2
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,user,exec,ro 0 0
/dev/scd0 /mnt/cdrom1 udf,iso9660 noauto,user,exec,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
 
Old 11-08-2003, 08:42 AM   #10
ic3
LQ Newbie
 
Registered: Oct 2003
Location: los angeles
Distribution: Slackware 9.1*
Posts: 16

Original Poster
Rep: Reputation: 0
it just says "drive error" on the cdplayer application that came with gnome....
 
Old 11-08-2003, 09:00 AM   #11
quietguy47
Member
 
Registered: Mar 2003
Location: Everett
Distribution: Slackware 13.37
Posts: 785

Rep: Reputation: 31
xmms?
Right click on xmms, scroll down to options, select preferences.
Under input plugins, choose CD Audio Player.
Make sure that 'enable plugin' is checked then click on configure.

Make sure the correct drive is selected.
Under 'Play mode'
select either 'analog' or digital audio extraction'(analog works for me).
Then click on 'check drive'. It will tell you if it passes or fails.
Click 'ok', and then click 'apply' and try and play a cd.

If it doesn't play, click on 'pl' (playlist), click 'add'.
A new window should open up. Make sure the path in the new window is pointing to /mnt/cdrom. Then click 'add all files in directory'.
 
Old 11-08-2003, 11:06 AM   #12
glennardo
Member
 
Registered: Oct 2003
Location: Jakarta, Indonesia
Distribution: Slackware 13.37
Posts: 50

Rep: Reputation: 15
Quote:
Originally posted by ic3
it just says "drive error" on the cdplayer application that came with gnome....
As root edit with text editor /etc/group, add your name at disk (group) :

disk::6:root,adm,!!TYPE UR NAME HERE!!

Log out and then log in again, now try the cdplayer !!


hope it helps !!

Last edited by glennardo; 11-08-2003 at 11:10 AM.
 
Old 11-13-2003, 01:54 PM   #13
ybbob
LQ Newbie
 
Registered: May 2002
Location: Alabama, USA
Distribution: Redhat 7.2
Posts: 2

Rep: Reputation: 0
Unhappy Heeeeellllllllpppppp!!!!!!!!!

I am getting the sam error but it is with a data cd. the error is:

wrong fs type, bad option, bad superblock on /dev/cdrom
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

this is what my fstab looks like:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/trk /trk ext3 defaults 1 2
LABEL=/usr /usr ext3 defaults 1 2
LABEL=/var /var ext3 defaults 1 2
/dev/sda7 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

please help...................
 
Old 11-15-2003, 07:03 PM   #14
Tino27
Member
 
Registered: Aug 2003
Location: Akron, OH
Distribution: SuSE 8.2, Slackware current, OpenBSD 3.5-3.8, Fedora Core 2
Posts: 400

Rep: Reputation: 30
ybbob --

instead of

mount /dev/cdrom /mnt/cdrom

use

mount /dev/sr0 /mnt/cdrom

I had the same problem with my laptop because my DVD/CDRW runs under scsi emulation.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No more CD-ROM drive C-monkey Linux - Hardware 2 09-19-2005 03:55 PM
Second cd-rom not working:P Danielallan Slackware 2 10-25-2004 08:53 PM
cd-rom drive working in knoppix Hard drive installation dj_dubbbz Linux - Newbie 5 03-02-2004 10:58 AM
Clean Hard Drive-CD-ROM not working pumperdave Linux - Newbie 1 01-27-2004 02:35 PM
Cd Rom DRIVE Longinus Linux - Newbie 2 09-13-2003 05:05 AM


All times are GMT -5. The time now is 08:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration