LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 08-27-2002, 10:51 PM   #1
wickdgin
Member
 
Registered: Apr 2002
Distribution: Gentoo, Slackware
Posts: 63

Rep: Reputation: 15
CD Burning - SCSII Emulation ???


I am having a little bit of trouble with the CD-R configuration.

When I start up xcdroast under root it gives me the following error
"Failed to scan the SCSI-bus. Either no permission to access the
generic scsi devices or no SCSI support enabled in the kernel. For
ATAPI devices you have to install the SCSI-emulation first. Pleast see
the CD-Writing-HOWTO how to do that"

I trying to read the how-to to find out how to do SCSI-emulation,
but my head was left spinning. So if anyone could point me in the
right direction, it would be appreciated. Thanks


BTW, I am using a Dell Inspiron 8000 laptop, with a Sony CD-RW

Last edited by wickdgin; 08-27-2002 at 10:53 PM.
 
Old 08-28-2002, 12:23 AM   #2
wickdgin
Member
 
Registered: Apr 2002
Distribution: Gentoo, Slackware
Posts: 63

Original Poster
Rep: Reputation: 15
Well, I'm stumped.... I saw a message during boot up that mention SCSII Emulation (so I guess that it is quite possibly already set up. And the ide-scsi module is loaded at boot time.

The output of cdrecord -scanbus is:

Cdrecord 1.11a24 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
cdrecord: No such file or directory. Cannot open '/dev/pg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'. Make sure you are root.

And yes I ran it as root, and permissions to /dev/pg* files are fine.

 
Old 08-28-2002, 01:03 AM   #3
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Sounds like you may need to add an append line in your /etc/lilo.conf.

append = "hdd=ide-scsi"

I believe it is. Change the "hdd" to whatever (hdb, hdc, hdd) you need for your CDRW. It is normally added on the line after the "Label = Linux" line.

After it is edited, type the command "lilo" to update the lilo boot record. Then reboot. cdrecord should then see a generic IDE scsi bus. Also, you would need to check the /dev/cdrom link. If it is pointing to something like /dev/hdd. It should be changed to point to /dev/scd0 because the normal IDE drivers won't work anymore.
 
Old 08-28-2002, 04:26 AM   #4
mrGee
Member
 
Registered: Dec 2001
Location: Netherlands
Distribution: redhat suse mandrake freebsd
Posts: 344

Rep: Reputation: 30
Hi
and other things to do just for checking

dmesg|less ; should show your ide_setup: hdc= ide-scsi
cat /proc/scsi/scsi ; that should return your burner
do lsmod; see what shows up
maybe need to do; modprobe ide-scsi

good luck
 
Old 08-28-2002, 12:31 PM   #5
Syncrm
Member
 
Registered: Aug 2001
Location: Lansing, Michigan
Distribution: slackware8+
Posts: 472

Rep: Reputation: 30
hi,
i'm having the same problem. i added the append entry to my lilo.conf file, but still nothing.

cat /proc/scsi/scsi shows this:
Attached devices: none

i have scsi cd-rom support compiled into my kernel. should it be as a module?
 
Old 08-28-2002, 12:34 PM   #6
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Does dmesg|less provide any info to you?
 
Old 08-28-2002, 03:04 PM   #7
Syncrm
Member
 
Registered: Aug 2001
Location: Lansing, Michigan
Distribution: slackware8+
Posts: 472

Rep: Reputation: 30
Quote:
Originally posted by MasterC
Does dmesg|less provide any info to you?
here's what i get upon boot:

PIIX4: IDE controller on PCI bus 00 dev 21
PIIX4: chipset revision 1
PIIX4: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda:DMA, hdb:DMA
ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc:pio, hdd:DMA
hda: MAXTOR 6L040J2, ATA DISK drive
hdb: CREATIVE CD5230E, ATAPI CD/DVD-ROM drive
hdd: YAMAHA CRW2200E, ATAPI CD/DVD-ROM drive
ide2: ports already in use, skipping probe
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: setmax LBA 78177792, native 66055248
hda: 66055248 sectors (33820 MB) w/1818KiB Cache, CHS=4111/255/63, UDMA(33)
hdb: ATAPI 52X CD-ROM drive, 128kB Cache, DMA
Uniform CD-ROM driver Revision: 3.12


most notable is the mention of my Yamaha burner being hdd. my lilo.conf file has append = "hdd=ide-scsi" in it, however i still receive the same errors when trying to run "cdrecord -scanbus". perhaps i need scsi emulation as a module and not compiled directly into my kernel?
 
Old 08-28-2002, 05:44 PM   #8
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Hey nice burner...

My dmesg around the same area:
Code:
hda: QUANTUM FIREBALLP AS40.0, ATA DISK drive
hdb: QUANTUM FIREBALLP LM20.5, ATA DISK drive
hdc: TOSHIBA DVD-ROM SD-M1402, ATAPI CD/DVD-ROM drive
hdd: YAMAHA CRW2100E, ATAPI CD/DVD-ROM drive
but a little further down you may see this:
Code:
SCSI subsystem driver Revision: 1.00
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
  Vendor: YAMAHA    Model: CRW2100E          Rev: 1.0H
  Type:   CD-ROM                             ANSI SCSI revision: 02
Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0
sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray
which would be the important part.

Cool
 
Old 08-28-2002, 07:12 PM   #9
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Not sure here about the module support because I only use integrated kernel support. But an earlier post suggested using

modprobe ide-scsi

If it loads without any messages, then look at the end of dmesg and see if it added the drive to the generic scsi and try cdrecord -scanbus again.

Also, SCSI CD ROM support and generic SCSI support are not the same thing. For full builtin kernel support I think there are three options required to be enabled. 1) IDE -> SCSI Emulation Support, 2) SCSI -> CDROM Support, and 3) SCSI -> Generic SCSI Support.

Wickdgin, Did you get your problem solved?
 
Old 08-28-2002, 10:00 PM   #10
wickdgin
Member
 
Registered: Apr 2002
Distribution: Gentoo, Slackware
Posts: 63

Original Poster
Rep: Reputation: 15
append = "hdb=ide-scsi" in my lilo.conf is all I needed, thanks a lot!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IDE CD burning in kernel 2.6, hold the SCSI emulation. meldroc Linux - Hardware 1 12-01-2003 10:55 PM
Burning without SCSI-emulation? r_jensen11 Linux - General 5 11-24-2003 09:55 PM
audiocd burning problem, whole system hangs while burning ichbinesderelch Linux - Software 1 11-14-2003 02:30 PM
Tar from SCSII drive bsengland Linux - Newbie 3 10-30-2002 04:09 PM
emulation Citizen Bleys Linux - General 3 10-23-2001 11:31 AM


All times are GMT -5. The time now is 07:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration