LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Catalyst 12.6 - Slackware current (http://www.linuxquestions.org/questions/slackware-14/catalyst-12-6-slackware-current-4175418112/)

AlexSlack 07-22-2012 02:18 PM

Catalyst 12.6 - Slackware current
 
Hello!

This is my first post at LQ and I want to thank you for your help in advance. :)

I recently bought an ATI HD-5450 video card and installed the Catalyst 12.6 driver since I'm using Slackware current; however, the OpenGL applications don't run well.

If I run glxgears or fgl_glxgears it just show a black window but when I move the window it shows the gears moving and when I stop moving the window the gears stop too. I also have this issue if I try to use blender, openarena, quakeforge and alienarena and I don't get any error or warning message. However, I can run yamagi-quake2 with no problem.

I have checked the X.Org log and dmesg. I had tried reinstalling the driver as an Slackware package and also directly with the .run file with no luck. I don't know where or what to check to find the issue.

I have a MSI-GF615-P33 motherboard, an AMD Phenom X6 2.8GHz and 4 GB RAM.

AlexSlack 07-22-2012 05:48 PM

Hello again :D

I found out that if I disable the KDE Desktop Effects everything will work fine. So I checked the KDE settings and KDE had XRender as the Composite type so I changed it to OpenGL and everything works fine now :D.

I hope this helps someone else since I passed the last 3 days trying to find the issue.

Mercury305 07-22-2012 08:52 PM

Did you only install the Fglrx.tgz from the 12.6? or did you add more extra non proprietary stuff too?

AlexSlack 07-23-2012 05:56 PM

I have slackware64-current (pure 64 bits - not multilib) and I just did

Code:

amd-driver-installer-12-6-x86.x86_64.run --buildpkg
Then:

Code:

upgradepkg --install-new fglrx-8.98-x86_64-1.tgz
I went to KDE System Settings -> Desktop Effects -> Advanced tab and I chose OpenGL as the composite type. I clicked apply and it works fine.

Mercury305 07-23-2012 09:04 PM

Quote:

Originally Posted by AlexSlack (Post 4736256)
I have slackware64-current (pure 64 bits - not multilib) and I just did

Code:

amd-driver-installer-12-6-x86.x86_64.run --buildpkg
Then:

Code:

upgradepkg --install-new fglrx-8.98-x86_64-1.tgz
I went to KDE System Settings -> Desktop Effects -> Advanced tab and I chose OpenGL as the composite type. I clicked apply and it works fine.

OK thanks. the problem with me is that I had the 13.37 not the current. I will just wait for the 14 that should come out soon...

AlexSlack 07-24-2012 09:12 PM

@Mercury305:
If you are using Slackware 13.37 you can do the same but using the driver version 12.4 it will work fine for you.

AMD Catalyst Proprietary Display Driver - Linux x86 & Linux x86_64

Mercury305 07-24-2012 09:48 PM

Quote:

Originally Posted by AlexSlack (Post 4737220)
@Mercury305:
If you are using Slackware 13.37 you can do the same but using the driver version 12.4 it will work fine for you.

AMD Catalyst Proprietary Display Driver - Linux x86 & Linux x86_64

Oh really? Thanks man. Now I can install it on my acer too. So its the same process right? Just install the *.tgz output and nothing else?

AlexSlack 07-25-2012 06:21 PM

That's right!
You just have to do:

Code:

amd-driver-installer-12-4-x86.x86_64.run --buildpkg
and then:

Code:

upgradepkg --install-new fglrx-8.961-x86_64-1.tgz
The package doesn't need any other dependency. However in order to use the Proprietary driver with your X you need to do:

Code:

aticonfig --initial --output=/etc/X11/xorg.conf.d/ati.conf
cp /etc/ati/amdpcsdb.default /etc/ati/amdpcsdb

Then to avoid any issue with the other driver do:

Code:

echo "blacklist radeon" > /etc/modprobe.d/blacklist-ati.conf
echo "blacklist ati" >> /etc/modprobe.d/blacklist-ati.conf

then reboot and you will have the fglrx driver loaded :D

Mercury305 07-25-2012 06:39 PM

Quote:

Originally Posted by AlexSlack (Post 4738010)
That's right!
You just have to do:

Code:

amd-driver-installer-12-4-x86.x86_64.run --buildpkg
and then:

Code:

upgradepkg --install-new fglrx-8.961-x86_64-1.tgz
The package doesn't need any other dependency. However in order to use the Proprietary driver with your X you need to do:

Code:

aticonfig --initial --output=/etc/X11/xorg.conf.d/ati.conf
cp /etc/ati/amdpcsdb.default /etc/ati/amdpcsdb

Then to avoid any issue with the other driver do:

Code:

echo "blacklist radeon" > /etc/modprobe.d/blacklist-ati.conf
echo "blacklist ati" >> /etc/modprobe.d/blacklist-ati.conf

then reboot and you will have the fglrx driver loaded :D

Last time I tried with the 12.6 the aticonfig didn't work. thanks.


All times are GMT -5. The time now is 01:14 PM.