LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Can't switch among virtual terminals with Ctrl+Alt+F* in Slack11 (http://www.linuxquestions.org/questions/slackware-14/cant-switch-among-virtual-terminals-with-ctrl-alt-f%2A-in-slack11-494374/)

kornerr 10-21-2006 10:54 AM

X-6.9.0 problems in Slack11 (like switching to virtual terminals, language change)
 
After I booted to X I can't switch back to virtual terminals.
Thanks.

uselpa 10-21-2006 11:27 AM

I had the same issue when upgrading from 10.2 to 11. It turned out to be a X.org change; I am using a swiss-french keyboard, and in /etc/X11/xorg.conf, I now have to use:
Code:

Option    "XkbLayout"    "ch"
Option    "XkbVariant"    "fr"

whereas in the previous version it was simply
Code:

Option    "XkbLayout"    "fr_CH"
.
So I'd suggest you look at that part of xorg.conf.
What keyboard layout are you using?

kornerr 10-21-2006 11:43 AM

I had:
Code:

    Option "XkbRules"  "xorg"
    Option "XkbModel"  "geniuscomfy2"
    Option "XkbLayout"  "en_US,ru(winkeys)"
    Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"

I modified it according to how you did it:
Code:

    Option "XkbRules"  "xorg"
    Option "XkbModel"  "geniuscomfy2"
    Option "XkbLayout"  "en"
    Option "XkbVariant" "ru(winkeys)"
    Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"

but I still can't switch to VTs.
And moreover, I can't switch layout!!!
Thanks.

kornerr 10-21-2006 12:48 PM

Ok, the problem was in "en_US", now it must be "us".


All times are GMT -5. The time now is 06:08 PM.