LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   can't suspend, hibernate or switch-user from xfce4 panel (http://www.linuxquestions.org/questions/slackware-14/cant-suspend-hibernate-or-switch-user-from-xfce4-panel-4175469935/)

johnpuppa 07-17-2013 08:57 AM

can't suspend, hibernate or switch-user from xfce4 panel
 
Hello guys, as the name of the topic says, I have this problem and I can't figure out where the problem lies. The three button are completely grey and I have no access to them. pm-suspend and pm-hibernate from command line work fine.
upower,ConsoleKit, and polkit are present:

Here is the output for xfce4-power-manager
Quote:

xfce4-power-manager --dump
---------------------------------------------------
Xfce power manager version 1.2.0
With policykit support
With network manager support
With DPMS support
---------------------------------------------------
Can suspend: True
Can hibernate: True
Can spin down hard disks: True
Authorized to suspend: True
Authorized to hibernate: True
Authorized to shutdown: True
Authorized to spin down hard disks: False
Has battery: True
Has brightness panel: True
Has power button: True
Has hibernate button: True
Has sleep button: True
Has LID: True
The Authorized option were all false before I modified the file:
Quote:

/etc/polkit-1/localauthority/50-local.d/20-plugdev-group-mount-override.pkla
adding, and starting rc.consolekit:
Quote:

[Re-enable hibernate by default]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes
On Xfce4 panel, as I said before the buttons keep to be grey and not accessible.
OS:Slack 14.0
Any Idea?

STDOUBT 07-18-2013 12:54 AM

Haven't used XFCE much since 4.10 came to Slackware, but are you sure you haven't "played around" with the Panel settings? Each "Launcher" or "Item" on the Panel has it's own preferences settings.

titopoquito 07-18-2013 09:26 AM

Is your user member of the "power" group? Not sure if "plugdev" is required, too.

johnpuppa 07-18-2013 10:12 AM

Hello guys, and thanks for replying.
Quote:

Originally Posted by titopoquito (Post 4992573)
Is your user member of the "power" group? Not sure if "plugdev" is required, too.

Yes my user is in the power group. I also tried to add it to the "plugdev". No luck..

TommyC7 07-18-2013 10:22 AM

I found this on a Gentoo forum, but I'm wondering if it helps:

In your sudoers:
Code:

root ALL=(ALL) ALL
%users ALL=(ALL) NOPASSWD: /usr/lib64/xfce4/session/xfsm-shutdown-helper

In /etc/polkit-1/localauthority/50-local.d/power.pkla (if it doesn't exist, feel free to make it but if it does exist, append):

Code:

[Local restart]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.restart
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local shutdown]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.stop
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local restart - multiple]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.restart-multiple-users
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local shutdown - multiple]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.stop-multiple-users
ResultAny=yes
ResultInactive=no
ResultActive=yes


johnpuppa 07-20-2013 05:23 AM

Quote:

Originally Posted by TommyC7 (Post 4992606)
I found this on a Gentoo forum, but I'm wondering if it helps:

In your sudoers:
Code:

root ALL=(ALL) ALL
%users ALL=(ALL) NOPASSWD: /usr/lib64/xfce4/session/xfsm-shutdown-helper

In /etc/polkit-1/localauthority/50-local.d/power.pkla (if it doesn't exist, feel free to make it but if it does exist, append):

Code:

[Local restart]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.restart
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local shutdown]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.stop
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local restart - multiple]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.restart-multiple-users
ResultAny=yes
ResultInactive=no
ResultActive=yes

[Local shutdown - multiple]
Identity=unix-group:power
Action=org.freedesktop.consolekit.system.stop-multiple-users
ResultAny=yes
ResultInactive=no
ResultActive=yes


Thanks for the post Tommy. I had tried this previously too, and nothing worked out for me.
On this thread seems that the guy had some package that was missing. Maybe it's the same problem for me too. I'm trying to figure out which could be...
https://bbs.archlinux.org/viewtopic.php?pid=1014130


All times are GMT -5. The time now is 01:51 PM.