LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Can't print documents in landscape format (http://www.linuxquestions.org/questions/slackware-14/cant-print-documents-in-landscape-format-901356/)

kikinovak 09-06-2011 02:18 AM

Can't print documents in landscape format
 
Hi,

I have Slackware 13.37, LibreOffice 3.4.2 (Alien packages) and a Brother HL-2030. For some obscure reasons, I can't print in landscape format. It always comes out "upright" formatted (don't know the exact word) and cut at the edges. I don't even know where the problem comes from: LibreOffice? CUPS? Anyone else got a similar problem and knows how to solve it?

beder 09-06-2011 06:53 PM

Hi

I've had similar problems but with PDF
I solved it by properly configuring CUPS, using http://localhost:631

Also, it took some try-error on the configurations from the printing itself

kingbeowulf 09-07-2011 07:14 PM

I ran into this after upgrading to the Libreoffice office package from SlackBuilds.org. The Fix is here: https://bbs.archlinux.org/viewtopic.php?id=120368

Essentially: "File - Printer Settings - Properties - Device" and change "Printer Language type" from "PDF" to "Postscript (Level from driver)" or the appropriate choice for your printer.

This setting changes back to PDF whenever you start LO and I haven't found the config locate for this yet.

Edit: If you select "Post Script Level 2" that setting sticks and allows landscape mode. You can set this via the "Printer Administration" utility as well. On my system, "Post Script Level 3" reverts to "Post Script Level 2"

kikinovak 09-08-2011 06:07 AM

Quote:

Originally Posted by kingbeowulf (Post 4464414)
I ran into this after upgrading to the Libreoffice office package from SlackBuilds.org. The Fix is here: https://bbs.archlinux.org/viewtopic.php?id=120368

Essentially: "File - Printer Settings - Properties - Device" and change "Printer Language type" from "PDF" to "Postscript (Level from driver)" or the appropriate choice for your printer.

This setting changes back to PDF whenever you start LO and I haven't found the config locate for this yet.

Edit: If you select "Post Script Level 2" that setting sticks and allows landscape mode. You can set this via the "Printer Administration" utility as well. On my system, "Post Script Level 3" reverts to "Post Script Level 2"

After a few hours of searching and experimenting, I guess I solved the problem.

1) The printer only seems to work OK with the drivers provided by Brother.

2) Drivers are 32bit only, so I had to install some basic multilib packages (thanks Eric) to make them work.

3) LibreOffice documents print OK with the workaround detailed above (thanks Kingbeowulf).

Phew.

herman.smartlion 04-24-2012 03:55 AM

I can do it in my fedora, i just download foxit reader in rpm package, it can print in landscape format.

kikinovak 04-24-2012 04:27 AM

Unfortunately this single bug unnerved pretty much everyone - about fifty users in the network - so I replaced Slackware by Debian, where everything works OK, and some other pestering bugs - blank screen on logout in KDM, etc. - got solved also. Pity, because I preferred Slackware for purely sentimental reasons.

mki 02-16-2016 03:49 PM

In OpenOffice, you can de-select pdf in the Options --> print form.

kikinovak 02-16-2016 04:59 PM

Quote:

Originally Posted by mki (Post 5501249)
In OpenOffice, you can de-select pdf in the Options --> print form.

You do notice that this thread is five years old? In the meantime, we're running Slackware 14.1 everywhere again. Occasional stints on Debian, CentOS and Ubuntu LTS were just that: stints. Everything works perfectly, and the landscape printing problem was due to Brother's crappy Linux driver. Printer was eventually replaced by a HP Laserjet, which works fine.

Cheers,

Niki

MarcT 02-17-2016 05:59 AM

Interesting! I've never been able to print PDFs in landscape properly via "okular" in Slackware 14.x to either a HP LaserJet 5 or a Xerox Phaser 8400.
I was led to believe it was a KDE bug:
https://bugs.kde.org/show_bug.cgi?id=181290


I'll have to try the "Printer Language Type" change suggested above.

Marc

bassmadrigal 02-17-2016 02:19 PM

Quote:

Originally Posted by MarcT (Post 5501547)
I was led to believe it was a KDE bug:
https://bugs.kde.org/show_bug.cgi?id=181290

It still could be, I believe most, if not all, of Niki's clients are running XFCE without KDE installed.


All times are GMT -5. The time now is 08:41 PM.