LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Can't play songs with foreign text in clementine (http://www.linuxquestions.org/questions/slackware-14/cant-play-songs-with-foreign-text-in-clementine-4175454133/)

Spongmonkey 03-14-2013 10:34 PM

Can't play songs with foreign text in clementine
 
I use clementine music player in Slackware and I was just curious if anyone knows how to play songs with foreign text in the song name. By default it just passes the song.

SwiftTimber-Z80 03-14-2013 11:09 PM

Can you post an image?
What is your locale?

Spongmonkey 03-15-2013 12:04 AM

1 Attachment(s)
Attachment 12059

locale is LANG=en_US

The skipped songs are greyed out cause of the foreign characters. I know I can just change the song info into English and it works but that seems kind of a ghetto way of doing it.

SwiftTimber-Z80 03-15-2013 01:20 AM

Try setting your locale to en_US.UTF-8.

solarfields 03-15-2013 03:12 AM

i have had problems with this, too

what I did was, I run liloconfig and select UTF-8 for the text consoles. Then edit /etc/profile.d/lang.sh to use export LANG=en_US.UTF-8, as mentioned above by SwiftTimber-Z80. However, some programs did not like to use UTF8. For example XMMS menus had huge fonts. In this case, I opened the /usr/share/applications/xmms.desktop file and made it start the program like this:

Exec=env LANG=en_US xmms %U


All times are GMT -5. The time now is 08:52 AM.