LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Can't install from DVD with AHCI enabled, only IDE (http://www.linuxquestions.org/questions/slackware-14/cant-install-from-dvd-with-ahci-enabled-only-ide-880341/)

quiescere 05-12-2011 11:27 AM

Can't install from DVD with AHCI enabled, only IDE
 
I'm doing a clean install on a new machine, and when I tried to boot the install DVD, ISOLinux gave me the following error:
Code:

Could not find kernel image: linux
After some experimentation, I found that switching the SATA mode in the BIOS from AHCI to Native IDE solved the problem and installation is proceeding normally.

However, I want AHCI enabled. (I think, unless someone has a compelling reason why I shouldn't.) My web-searching suggests that if the system is installed in IDE mode, it won't boot if I switch to AHCI afterwards.

Is this a common problem? Is there a workaround? Is it a motherboard issue?

Thanks in advance for any insight you can give.

H_TeXMeX_H 05-12-2011 12:24 PM

What version of slackware is this and what SATA controller do you have for the DVD drive ?

You can probably find out by running 'lspci -k', it will also show what driver it is using.

It is odd that it would not work with ahci, because the ahci module supports all AHCI compatible controllers, and if there's an option in the BIOS for AHCI, then it should be compatible. However, achi MUST be build-in to the kernel or in initrd, because otherwise the kernel won't be able to find controllers in AHCI mode.

TobiSGD 05-12-2011 12:27 PM

Quote:

Originally Posted by quiescere (Post 4354465)
My web-searching suggests that if the system is installed in IDE mode, it won't boot if I switch to AHCI afterwards.

This is only true for Windows. With a somewhat recent kernel with AHCI enabled (either built-in or as module in an initrd) you should have no problems. I never had problems with that.

quiescere 05-12-2011 02:36 PM

Slackware 13.37 with AMD SB850 SATA.

Installing in legacy IDE mode then switching to AHCI once I had slack on the hard drive has worked just fine. Odd that the DVD wouldn't boot under AHCI, but maybe ISOLinux hasn't caught up yet.

Thanks for the responses.


All times are GMT -5. The time now is 10:39 AM.