LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Can't compile tolua++ in slackware64-current (http://www.linuxquestions.org/questions/slackware-14/cant-compile-tolua-in-slackware64-current-797138/)

Daedra 03-22-2010 05:54 PM

Can't compile tolua++ in slackware64-current
 
I'm trying to compile tolua++ so that i can use lua in conky 1.7.2, however I am running into a problem. tolua++ defaults to looking for lua 5.0 libraries and I have lua 5.1 installed since that is what conky requires. According to the README tolua++ can use lua-5.1 but I not sure how to configure tulua++ to use those libraries since it uses scons. Here is a what the README says...

Compiling for lua 5.1
---------------------

Starting from version 1.0.8pre1, tolua++ can be compiled with both lua 5.0 and
5.1. Both versions will output the same code, and the C API (tolua++.h) is the
same.

The build system is not yet ready to detect/decide when to compile for 5.1,
the easiest way right now is to add a file called 'custom.py' on the root of
the package, with the following:

## BEGIN custom.py

CCFLAGS = ['-I/usr/local/include/lua5.1', '-O2', '-ansi']
LIBPATH = ['/usr/local/lib']
LIBS = ['lua5.1', 'dl', 'm']
tolua_bin = 'tolua++5.1'
tolua_lib = 'tolua++5.1'
TOLUAPP = 'tolua++5.1'

## END custom.py

This will build the binary as 'tolua++5.1' and the library as 'libtolua++5.1.a'
(taken from tolua_bin and tolua_lib), and take the lua headers and libraries
from /usr/local/include/lua5.1 and /usr/local/lib. It will also link with
'-llua5.1'. Modify the parameters acording to your system.

I have custom.py ready but I still get this error during compile.

cc -o bin/tolua++_bootstrap src/bin/tolua.o src/bin/toluabind_default.o lib/libtolua++_static.a -Llib -llua50 -llualib50 -ldl -lm
/usr/lib64/gcc/x86_64-slackware-linux/4.4.3/../../../../x86_64-slackware-linux/bin/ld: cannot find -llua50
collect2: ld returned 1 exit status


Any help us appreciated thanks.

knudfl 03-23-2010 08:04 AM

cd tolua++-1.0.93/
grep -n lua50 ./*
> > config_linux.py , line 7, 8, 21
Line 7 is not the important one, but can be edited,
if the headers have an unusual location.
Line 8 : not used.

Line 21 : Please edit to ..
LIBS = ['lua', 'dl', 'm']

Will work, when your library name is : liblua.so ( liblua.a ? )
e.g. http://www.slacky.eu/ > >
http://repository.slacky.eu/slackwar...4-i486-5as.txz

'lualib' is not present in Lua version 5.1.x .
.....

There may be some hints in this thread, for compiling
Conky 1.7.2 with lua
http://www.linuxquestions.org/questi...-found-795139/
.....


All times are GMT -5. The time now is 08:13 AM.