LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Can't compile Qt4 when using QT_NO_TOOLTIP (http://www.linuxquestions.org/questions/slackware-14/cant-compile-qt4-when-using-qt_no_tooltip-4175456754/)

Woodsman 04-03-2013 04:30 PM

Can't compile Qt4 when using QT_NO_TOOLTIP
 
I am trying to build Qt 4.8.4 using the QT_NO_TOOLTIP build option. Refer to this thread for background.

First I tried adding -DQT_NO_TOOLTIP to the configure options. That failed.

Then I tried patching qt-everywhere-opensource-src-$VERSION/src/corelib/global/qfeatures.h:

sed -i 's|^//#define QT_NO_TOOLTIP|#define QT_NO_TOOLTIP|'

Same failure.

Then I tried NUMJOBS=-j1. Same failure.

Possibly this needs to be reported upstream, but I wanted to query here first in case this is unique to the Slackware build scripts.

Here is the failure:

Code:

make[1]: Entering directory `/dev/shm/qt-everywhere-opensource-src-4.8.4/src/gui'
g++ -c -O2 -march=i486 -mtune=i686 -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng14 -O2 -march=i486 -mtune=i686 -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -I/usr/include/freetype2 -fPIC -DQT_SHARED -DQT_BUILD_GUI_LIB -DQT_NO_USING_NAMESPACE -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT3_SUPPORT -DQT_MOC_COMPAT -DQT_USE_QSTRINGBUILDER -DQT_NO_OPENTYPE -DQT_NO_STYLE_MAC -DQT_NO_STYLE_WINDOWSVISTA -DQT_NO_STYLE_WINDOWSXP -DQT_NO_STYLE_WINDOWSCE -DQT_NO_STYLE_WINDOWSMOBILE -DQT_NO_STYLE_S60 -DQ_INTERNAL_QAPP_SRC -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_HAVE_MMX -DQT_HAVE_3DNOW -DQT_HAVE_SSE -DQT_HAVE_MMXEXT -DQT_HAVE_SSE2 -DQT_HAVE_SSE3 -DQT_HAVE_SSSE3 -DQT_HAVE_SSE4_1 -DQT_HAVE_SSE4_2 -DQT_HAVE_AVX -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I../../mkspecs/linux-g++ -I. -I../../include/QtCore -I../../include -I../../include/QtGui -I.rcc/release-shared -I../3rdparty/xorg -Iimage -I/usr/include/freetype2 -I/usr/include/freetype2 -I../3rdparty/harfbuzz/src -Idialogs -I.moc/release-shared -I/usr/include -I.uic/release-shared -o .obj/release-shared/qguiplatformplugin.o kernel/qguiplatformplugin.cpp
In file included from ../../include/QtGui/private/qgtkstyle_p.h:1:0,
                from kernel/qguiplatformplugin.cpp:63:
../../include/QtGui/private/../../../src/gui/styles/qgtkstyle_p.h:266:120: error: 'QFileDialog::Options' has not been declared
../../include/QtGui/private/../../../src/gui/styles/qgtkstyle_p.h:268:120: error: 'QFileDialog::Options' has not been declared
../../include/QtGui/private/../../../src/gui/styles/qgtkstyle_p.h:270:120: error: 'QFileDialog::Options' has not been declared
../../include/QtGui/private/../../../src/gui/styles/qgtkstyle_p.h:272:72: error: 'QFileDialog::Options' has not been declared
../../include/QtGui/private/../../../src/gui/styles/qgtkstyle_p.h:346:26: error: 'QFileDialog::Options' has not been declared
../../include/QtGui/private/../../../src/gui/styles/qgtkstyle_p.h:350:71: error: 'QFileDialog::Options' has not been declared
../../include/QtGui/private/../../../src/gui/styles/qgtkstyle_p.h:352:71: error: 'QFileDialog::Options' has not been declared
../../include/QtGui/private/../../../src/gui/styles/qgtkstyle_p.h:353:108: error: 'QFileDialog::Options' has not been declared
../../include/QtGui/private/../../../src/gui/styles/qgtkstyle_p.h:355:75: error: 'QFileDialog::Options' has not been declared
make[1]: *** [.obj/release-shared/qguiplatformplugin.o] Error 1
make[1]: Leaving directory `/dev/shm/qt-everywhere-opensource-src-4.8.4/src/gui'
make: *** [sub-gui-make_default-ordered] Error 2

I'm not a C++ guru (at all) but I notice -I/usr/include/gtk-2.0 is part of the make options.

I would appreciate if somebody else would duplicate the failure. More so if somebody has a patch. I've looked around the web and haven't found anything obvious.

On my dual core system using NUMJOBS=-j1, the failure occurs in about 18 minutes, about 14 minutes using the defaults in the build script. Thus confirming the failure should not take a long time (building Qt4 takes a couple of hours.)

Thanks. :)

Edit: Slackware 14.0, fully patched.

Woodsman 04-07-2013 06:10 PM

Look here for a solution.


All times are GMT -5. The time now is 03:10 PM.