LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Can't compile a Xen compatible glibc (http://www.linuxquestions.org/questions/slackware-14/cant-compile-a-xen-compatible-glibc-603820/)

lanart 12-01-2007 07:21 PM

Can't compile a Xen compatible glibc
 
Hi,

the problem is very strange. I'm trying to compile glibc-2.5 without NPTL like it is described here: http://www.pervasive.jku.at/About_Us...irtualization/

But after installation of compiled package I still get:
# getconf GNU_LIBPTHREAD_VERSION
NPTL 2.5

What's wrong?

Andrei

jong357 12-02-2007 10:35 AM

I think I specifically remember seeing a similar thread on the Slackware forums about this. Have you done a search here? If I recall, the poster got it sorted out and is now running a Xen kernel on Slack.

lanart 12-02-2007 01:54 PM

Thank you for your reply. It's seems I'm the only to have such stupid problem.

I find only one thread about compiling glibc and missing kernel sources. My problem is different. Everything compiles and installs without problems (I also tried to compile on another PC, but result was the same).
Then when I do:
# getconf GNU_LIBPTHREAD_VERSION
I got:
NPTL 2.5
instead of linuxthreads :-(

ubaldo 12-06-2007 02:06 PM

Ciao Lanart,

if after compiling and installing the new glibc, Xen is still asking you to disable tls and you are using an initrd image, don't forget that you have also to recompile mkinitrd to avoid that message...

It took me a whole day to sort it out! :)

lanart 12-07-2007 02:26 AM

It works!

I was fooled by "getconf GNU_LIBPTHREAD_VERSION" test. I thought it should change after recompile which seems to be absolutely wrong.

For many years I avoided using initrd...

Thank you very much for your help.


All times are GMT -5. The time now is 05:34 AM.