LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Can't boot into Slackware 13.37 on my Dell XPS 15 (http://www.linuxquestions.org/questions/slackware-14/cant-boot-into-slackware-13-37-on-my-dell-xps-15-a-883192/)

sudeepkulkarni 05-28-2011 09:17 AM

Can't boot into Slackware 13.37 on my Dell XPS 15
 
When I installed Slackware 13.37 for the first time, there was no problem. Everything worked very well - as expected from this great distro.

But, the LILO won't detect Windows installation correctly. So I tried to edit it using liliconfig, where I wrongly entered the entry for Linux. So without further messing around with the system, I went for reinstalling the whole system.

Now when I chose 'Linux' in LILO menu, Some initial startup scripts ran correctly - like detecting and mounting the root and non-root file systems.

But then the suddenly screen went black. It happened so fast, then and again, that I couldn't take a look at what's wrong.

My best guess is that there's a problem with video driver. (The laptop has nVidia GeForce graphics card)

adamk75 05-28-2011 10:49 AM

Sounds like KMS is kicking in and has issues with your video card or monitor. If you pass 'nomodeset' to the kernel, does the machine continue to come up?

allend 05-28-2011 10:56 AM

Does this Dell XPS 15 have Optimus technology and can you disable it in the BIOS?

[Edit] There is a thread at Ubuntu that may be applicable. http://ubuntuforums.org/showthread.php?t=1763271 [/Edit]

psionl0 05-28-2011 10:26 PM

How do you "pass 'nomodeset' to the kernel"?

sudeepkulkarni 05-29-2011 01:05 AM

Quote:

Originally Posted by allend (Post 4369516)
Does this Dell XPS 15 have Optimus technology and can you disable it in the BIOS?

[Edit] There is a thread at Ubuntu that may be applicable. http://ubuntuforums.org/showthread.php?t=1763271 [/Edit]


Yes, it does have Optimus technology. I don't want to disable it however. Isn't there any other way around? Because as I mentioned, everything worked smoothly for the first time.

I read the thread you posted. The problem is that those steps are to be done in terminal and need Internet connection. I am not reaching the login stage while booting, and even if I do, I won't be able to connect to Internet as I have USB modem that has to be configured later on using an installation script.

sudeepkulkarni 05-29-2011 01:07 AM

Quote:

Originally Posted by adamk75 (Post 4369513)
Sounds like KMS is kicking in and has issues with your video card or monitor. If you pass 'nomodeset' to the kernel, does the machine continue to come up?

Do I have to do it while installing - at the point where the set-up asks whether you want to pass extra parameters while booting?:confused:

tommcd 05-29-2011 03:49 AM

Quote:

Originally Posted by sudeepkulkarni (Post 4369881)
Do I have to do it while installing - at the point where the set-up asks whether you want to pass extra parameters while booting?:confused:

You can add nomodeset to the append line in /etc/lilo.conf. Then rerun lilo. You should be able to boot from the Slackware install DVD to do this if you can not boot the instaled system.

xj25vm 05-29-2011 05:56 AM

To use nomodeset during boot, I believe you press TAB when you see the lilo screen (there is a message on the screen actually), type in (or leave in, if it is already there) the name of the boot option you want (normally called Linux, unless you changed it in lilo.conf), type a space, then the word nomodeset. This is equivalent to going in lilo.conf and adding nomodeset to the append parameter - but as you can't even boot, you can pass nomodeset during boot.

It looks like I have the same problem, with an Intel integrated video chip, and at the moment I've switched to using nomodeset and the vesa Xorg driver - until I get to try a newer kernel. Here is the thread:

http://www.linuxquestions.org/questi...3-37-a-882680/

Sebastian

P.S. If you are using nomodeset, you will have to use the vesa driver in XOrg as well, until you get things sorted.

tommcd 05-29-2011 06:04 AM

Quote:

Originally Posted by xj25vm (Post 4370019)
To use nomodeset during boot, I believe you press TAB when you see the lilo screen ...

Thanks for postting that. I could not exactly remember how to pass options to lilo 'on the fly' like that using the TAB key.
Although I have been using Slackware for several years, I have been booting Slckware from Ubuntu's grub. So I have very little experience with lilo.

sudeepkulkarni 05-30-2011 03:32 AM

I tried using 'nomodeset' as described by xj25vm. It also doesn't work.

Now I see KDE initialization screen. But as soon as it completes, KDE crashes. there were many error messages. I believe following was important:

xprop: can't find display 0

As far as I know, this probably means my monitor is not recognized.

And what is the root of the problem anyway? nouveau should be working fine.

adamk75 05-30-2011 04:38 AM

KDE is likely crashing because it is trying to enable compositing. Does xfce4 work? If so, start up xfce4, launch KDE's systemsettings, and then disable compositing in KDE (under desktop effects).

Adam

xj25vm 05-31-2011 03:12 AM

Well - if you get all the way to KDE - then 'nomodeset' actually works. Otherwise you wouldn't see anything on the screen after about the 12th second (on a slowish, Intel U2500, 1.2GHz machine) of the boot process.

On the other hand, I use Fluxbox, so not sure if there is a further problem with KDE.

Then again, maybe your problem is different then mine, as, without 'nomodeset' - my screen would go black before getting to mounting root volume.

onebuck 05-31-2011 06:09 AM

Hi,

Quote:

Originally Posted by psionl0 (Post 4369823)
How do you "pass 'nomodeset' to the kernel"?

If you use the Install DVD to boot then at the 'boot:' prompt;
Code:

boot: huge.s root=/dev/your_dev rdinit= ro nomodeset
Initial screen provides a sample of booting a kernel, then you can add parameters at the end of that input line to pass parameter(s) to the kernel. This way you do not need to modify the '/etc/lilo.conf' in order to pass parameters. If you decide later that parameters are necessary then place parameters in '/etc/lilo.conf' and then run 'lilo' to update your bootloader.

sudeepkulkarni 06-01-2011 04:49 AM

Quote:

Originally Posted by adamk75 (Post 4370813)
KDE is likely crashing because it is trying to enable compositing. Does xfce4 work? If so, start up xfce4, launch KDE's systemsettings, and then disable compositing in KDE (under desktop effects).

Adam

Thanks. That exactly was the problem. XFCE works fine. Guess I will use it as default


All times are GMT -5. The time now is 10:24 AM.