LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 12-31-2009, 09:13 AM   #1
voyciz
Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 425

Rep: Reputation: 40
Cannot switch between tty1,tty2,etc


Hello all. I just got a Dell Inspiron for Christmas I threw Slack on it and everything is running great.

The only problem I'm having is that I can't switch between consoles like normal (Ctrl+Alt+F2, etc). I can use my ctrl and alt keys just fine, I'm guessing there is a problem with the F keys. Could it be because they're used to serve other functions, like switching to alternate displays, and turning off the wireless card and such? What is it that I need to do to get this working properly?

Thanks in advance.
 
Old 12-31-2009, 09:43 AM   #2
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 490
Blog Entries: 1

Rep: Reputation: 55
I assume that you know that you only have one console in Slackware, runlevel 4. Use Ctrl+Alt+F6 to get to it & Ctrl+Alt+F7 to go back to X.
Regards,
Bill
 
Old 12-31-2009, 09:43 AM   #3
briealeida
Member
 
Registered: Jun 2007
Location: PA
Distribution: FreeBSD, Ubuntu, Knoppix,
Posts: 41

Rep: Reputation: 16
Have you tried a different keyboard?

Have you tried Ctrl+Alt+Shift+F2?
 
Old 12-31-2009, 09:54 AM   #4
Lufbery
Senior Member
 
Registered: Aug 2006
Location: Harrisburg, PA
Distribution: Slackware 64 14.0
Posts: 1,142
Blog Entries: 29

Rep: Reputation: 119Reputation: 119
My keyboard has an F lock. If I don't have it pressed, the F keys don't work as expected. Maybe check that. :-D
 
Old 12-31-2009, 09:59 AM   #5
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
Are you trying to switch while in a graphical environment, like KDE? The extra functions on the keys shouldn't cause that problem since they are mapped the the function key. (on my keyboard its the blue Fn key) Are you using a standard us keyboard layout? Also try using the command chvt to see if you can switch that way or not.
 
Old 12-31-2009, 10:00 AM   #6
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
Quote:
I assume that you know that you only have one console in Slackware, runlevel 4. Use Ctrl+Alt+F6 to get to it & Ctrl+Alt+F7 to go back to X.
Strange I have tty 1,2,3,4,5,6 & 7.

samac
 
Old 12-31-2009, 10:09 AM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
For what it's worth, I have the same problem as the OP. I know my problem is not keyboard related, because I can use my Fn keys. Personally, I didn't know about the chvt command, but it doesn't help me. For example:

nick@mira:~$ chvt 1
Couldn't get a file descriptor referring to the console

The tty devices exist:

nick@mira:~$ ll /dev/tty[1-6]
crw------- 1 root root 4, 1 2009-12-31 10:09 /dev/tty1
crw------- 1 root root 4, 2 2009-12-31 10:09 /dev/tty2
crw------- 1 root root 4, 3 2009-12-31 10:09 /dev/tty3
crw------- 1 root root 4, 4 2009-12-31 10:09 /dev/tty4
crw------- 1 root root 4, 5 2009-12-31 10:09 /dev/tty5
crw------- 1 root root 4, 6 2009-12-31 10:09 /dev/tty6

So confused :/.
 
Old 12-31-2009, 10:21 AM   #8
Karu
Member
 
Registered: Jul 2007
Location: Estonia
Distribution: Slackware
Posts: 53

Rep: Reputation: 16
From file /etc/inittab:
Code:
# These are the standard console login getties in multiuser mode:
c1:1235:respawn:/sbin/agetty 38400 tty1 linux
c2:1235:respawn:/sbin/agetty 38400 tty2 linux
c3:1235:respawn:/sbin/agetty 38400 tty3 linux
c4:1235:respawn:/sbin/agetty 38400 tty4 linux
c5:1235:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux
Numbers after consoles c[1-6] are runlevels.

Note the absence of "4" for consoles c[1-5].
 
Old 12-31-2009, 10:26 AM   #9
voyciz
Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 425

Original Poster
Rep: Reputation: 40
@ TSquaredF:
You must not understand what I'm saying, please reread. By default, Slack has 6 virtual consoles. However, I have 3, due to the editing of /etc/inittab

EDIT: Nevermind, I was mistaken, there really is only one console in runlevel 4. But I use runlevel 3 and was not attempting this from X11.

@ Lufbery:
Thank you! I can't believe I've overlooked something so simple. The Fn key is blue, and so are the words F1,F2,etc. So I must press Ctrl+Alt+Fn+F2, otherwise the F key will perform some laptop function.

Last edited by voyciz; 12-31-2009 at 10:30 AM.
 
Old 12-31-2009, 10:36 AM   #10
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Glad voyciz managed to get the problem solved. I still have the issue, because I don't need to use an extra key to be able to use my Fn keys. Also, for what it's worth, I modified my inittab so that it gives me all 6 consoles in runlevel 4:

c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux


Edit: oh, I needed to be root to use chvt. Oh well, at least that works.

Any ideas, anyone?

Thanks.

Last edited by Nylex; 12-31-2009 at 10:46 AM.
 
Old 12-31-2009, 11:16 AM   #11
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
Quote:
Originally Posted by Nylex View Post
Glad voyciz managed to get the problem solved. I still have the issue, because I don't need to use an extra key to be able to use my Fn keys. Also, for what it's worth, I modified my inittab so that it gives me all 6 consoles in runlevel 4:

c1:12345:respawn:/sbin/agetty 38400 tty1 linux
c2:12345:respawn:/sbin/agetty 38400 tty2 linux
c3:12345:respawn:/sbin/agetty 38400 tty3 linux
c4:12345:respawn:/sbin/agetty 38400 tty4 linux
c5:12345:respawn:/sbin/agetty 38400 tty5 linux
c6:12345:respawn:/sbin/agetty 38400 tty6 linux


Edit: oh, I needed to be root to use chvt. Oh well, at least that works.

Any ideas, anyone?

Thanks.
Using Ctrl+Alt+F6 are you able to load that tty? That is the default getty Slackware leaves open when X is running. It looks like it may be a driver issue with the keyboard, you can try manually setting the kbd options in your xorg.conf file, or run xorgsetup again if you don't have any custom configurations already done. Just make a backup of it first. I'm looking at some other threads with similar issues as you, so far they were all related to drivers and X settings. I would switch to runlevel 3 and see if you are able to switch to other vt's with the Ctrl+F keys, if so then we know it's X related.

Edit: there's a setting in xorg.conf called "DontVTSwitch", you may want to make sure that is commented out.

Last edited by affinity; 12-31-2009 at 11:19 AM.
 
Old 01-01-2010, 03:36 AM   #12
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 518

Rep: Reputation: 133Reputation: 133
Check your BIOS settings.

There should be an option called "Function Key Behavior"

If set to "Multimedia" the functions keys will do things like change the volume, screen brightness, toggle wireless on/off, etc. If set to "Function" they should behave normally.

That's how it is on my Dell Mini 10v, anyway.

Last edited by piratesmack; 01-01-2010 at 03:39 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do i switch from tty1 to tty2? alex1986 Linux - Newbie 4 07-27-2006 06:01 AM
Switch to tty1 on init-5 boot? mackdav Linux - Software 2 04-25-2006 01:32 PM
Slack 10.0 + bootsplash + tty2-6 lucas22 Slackware 4 07-30-2004 12:04 PM
Need to switch tty or send system msgs to tty2 adrianphicks Linux - General 1 08-01-2003 07:33 PM
shortcut way to logout from tty1 or tty2....... hitesh_linux Linux - General 2 03-25-2003 01:52 PM


All times are GMT -5. The time now is 09:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration