LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-11-2011, 06:21 AM   #1
unknown96
LQ Newbie
 
Registered: Aug 2010
Posts: 14

Rep: Reputation: 0
Cannot shutdown, reboot and logout on slackware 13.37 from kde menu


The tittle says it all, please some help guys...
I have done 3 clean installs for this problem and it remains, i don't want to do it from the terminal...
(Buttons exists but they won't work...)

Last edited by unknown96; 06-11-2011 at 06:25 AM.
 
Old 06-11-2011, 07:05 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
Did you add your user account to the group "power"? You need that in order to shutdown or reboot from the KDE menu. Logging out from KDE should always work. If it does not work for you, then there is something wrong with the way you installed.

Eric
 
Old 06-11-2011, 07:06 AM   #3
rg3
Member
 
Registered: Jul 2007
Distribution: Slackware Linux
Posts: 507

Rep: Reputation: Disabled
Hum... try to make sure your user is part of the "power" group. It may have to do with that. The typical desktop user account should be part of the following groups: users, audio, video, cdrom, plugdev, power, netdev.

Edit: Eric was faster.
 
Old 06-11-2011, 07:17 AM   #4
unknown96
LQ Newbie
 
Registered: Aug 2010
Posts: 14

Original Poster
Rep: Reputation: 0
I have my user joined in all groups.
 
Old 01-28-2012, 06:22 AM   #5
heavytull
LQ Newbie
 
Registered: Apr 2006
Posts: 15

Rep: Reputation: 0
I also have this problem since recently.
When I send the following command:
qdbus org.kde.ksmserver /KSMServer logout 0 0 0

A blank line appears and nothing happens.
My user account is part since ever of the group 'power'
 
Old 01-28-2012, 10:23 AM   #6
fgcl2k
Member
 
Registered: Jan 2011
Distribution: Slackware 14.1
Posts: 105

Rep: Reputation: 26
I had the same problem on Slackware 64 and, IIRC, I didn't have the buttons too. The problem went away when I installed gdm instead of using 'startx' to launch KDE.
 
Old 01-28-2012, 06:55 PM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,406

Rep: Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829Reputation: 829
You need to boot to run level 4 for the shutdown, reboot and logout buttons to appear and work.
http://humanreadable.nfshost.com/how...e_shutdown.htm
 
Old 01-29-2012, 03:13 PM   #8
heavytull
LQ Newbie
 
Registered: Apr 2006
Posts: 15

Rep: Reputation: 0
I know how KDE works in RL3.
In my case, the system is running in RL4 and all the buttons are indeed visible and pushable. The problem is that nothing happens. The dialogue box for logging out confirmation does not appear.
 
Old 01-29-2012, 05:24 PM   #9
heavytull
LQ Newbie
 
Registered: Apr 2006
Posts: 15

Rep: Reputation: 0
I finally solved my problem but a bit unintentionally.
I first renamed .kde/share/config to .kde/share/config.bak and Ctrl+Alt+Bkspace and logged in again. Then I could make use of logout, shutdown, restart features from the K menu. But since I wanted all my settings back I moved back the config.bak to config after deleting the newly created config folder in .kde/share at new session opening. Surprisingly when I opened a new session the problems were solved.
 
Old 10-17-2012, 10:25 PM   #10
beder
Member
 
Registered: Apr 2011
Posts: 82

Rep: Reputation: 28
Lightbulb

So I'm responding in this old thread because I haven't found any new one about this same issue, and as I actually found a real solution, and I did found this thread through google, more people probably end up here as well.

I was facing this exact same problem on Slackware 14 (actually slackware-current), using the latest KDE build (4.9.2) from AlienBob (BTW, never can say Thanks Eric enough times).

I also tried removing ~/.kde/share/config and while it did work at first, the problem appeared again after a few reboots.

Turns out that, after lots of googling and finding people with a similar issue in other distros, the problem is actually related with phonon being unable to play .ogg files, because the package "speex" is not present

To confirm that, you can note that if you're facing that problem, you do not have a startup sound!

So to REALLY solve this issue, all I had to do was install the speex package (I used the one from sbopkg) and reload KDE (use ctrl+alt+backspace and startx again)

So there you go
 
1 members found this post helpful.
Old 02-09-2013, 06:31 AM   #11
houzi
LQ Newbie
 
Registered: Jun 2012
Posts: 10

Rep: Reputation: Disabled
Quote:
Originally Posted by beder View Post
Turns out that, after lots of googling and finding people with a similar issue in other distros, the problem is actually related with phonon being unable to play .ogg files, because the package "speex" is not present
I cannot believe that this problem was solved by installing a missing package. I really hope this bug has been squashed in the KDE 4.10 release. I think my problem occurred after installing Counter Strike through Steam, which I do believe use speex for its VOIP.

Thank you so much for posting a fix beder!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to add a "Reboot to Windows" option to KDE logout menu? simopal6 Linux - Software 2 12-31-2008 12:49 PM
KDE shutdown menu lacks 'reboot' option leupi Linux - Software 4 03-02-2006 02:12 PM
ShutDown/Reboot using "KDE graphical logout" and GDM ? tsiMental Ubuntu 2 08-08-2005 10:54 AM
NEWBIE Slackware 10.0 --> logout shutdown reboot (CTRL-ALT-F2) confused?? koodoo Linux - Newbie 5 06-01-2005 06:21 PM
NEWBIE Slackware 10.0 --> logout shutdown reboot (CTRL-ALT-F2 confused?? koodoo Linux - Newbie 1 05-31-2005 05:51 PM


All times are GMT -5. The time now is 07:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration