LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Cannot shutdown, reboot and logout on slackware 13.37 from kde menu (http://www.linuxquestions.org/questions/slackware-14/cannot-shutdown-reboot-and-logout-on-slackware-13-37-from-kde-menu-885728/)

unknown96 06-11-2011 06:21 AM

Cannot shutdown, reboot and logout on slackware 13.37 from kde menu
 
The tittle says it all, please some help guys...
I have done 3 clean installs for this problem and it remains, i don't want to do it from the terminal...
(Buttons exists but they won't work...)

Alien Bob 06-11-2011 07:05 AM

Did you add your user account to the group "power"? You need that in order to shutdown or reboot from the KDE menu. Logging out from KDE should always work. If it does not work for you, then there is something wrong with the way you installed.

Eric

rg3 06-11-2011 07:06 AM

Hum... try to make sure your user is part of the "power" group. It may have to do with that. The typical desktop user account should be part of the following groups: users, audio, video, cdrom, plugdev, power, netdev.

Edit: Eric was faster.

unknown96 06-11-2011 07:17 AM

I have my user joined in all groups.

heavytull 01-28-2012 06:22 AM

I also have this problem since recently.
When I send the following command:
qdbus org.kde.ksmserver /KSMServer logout 0 0 0

A blank line appears and nothing happens.
My user account is part since ever of the group 'power'

fgcl2k 01-28-2012 10:23 AM

I had the same problem on Slackware 64 and, IIRC, I didn't have the buttons too. The problem went away when I installed gdm instead of using 'startx' to launch KDE.

allend 01-28-2012 06:55 PM

You need to boot to run level 4 for the shutdown, reboot and logout buttons to appear and work.
http://humanreadable.nfshost.com/how...e_shutdown.htm

heavytull 01-29-2012 03:13 PM

I know how KDE works in RL3.
In my case, the system is running in RL4 and all the buttons are indeed visible and pushable. The problem is that nothing happens. The dialogue box for logging out confirmation does not appear.

heavytull 01-29-2012 05:24 PM

I finally solved my problem but a bit unintentionally.
I first renamed .kde/share/config to .kde/share/config.bak and Ctrl+Alt+Bkspace and logged in again. Then I could make use of logout, shutdown, restart features from the K menu. But since I wanted all my settings back I moved back the config.bak to config after deleting the newly created config folder in .kde/share at new session opening. Surprisingly when I opened a new session the problems were solved.

beder 10-17-2012 10:25 PM

So I'm responding in this old thread because I haven't found any new one about this same issue, and as I actually found a real solution, and I did found this thread through google, more people probably end up here as well.

I was facing this exact same problem on Slackware 14 (actually slackware-current), using the latest KDE build (4.9.2) from AlienBob (BTW, never can say Thanks Eric enough times).

I also tried removing ~/.kde/share/config and while it did work at first, the problem appeared again after a few reboots.

Turns out that, after lots of googling and finding people with a similar issue in other distros, the problem is actually related with phonon being unable to play .ogg files, because the package "speex" is not present

To confirm that, you can note that if you're facing that problem, you do not have a startup sound!

So to REALLY solve this issue, all I had to do was install the speex package (I used the one from sbopkg) and reload KDE (use ctrl+alt+backspace and startx again)

So there you go

houzi 02-09-2013 06:31 AM

Quote:

Originally Posted by beder (Post 4808708)
Turns out that, after lots of googling and finding people with a similar issue in other distros, the problem is actually related with phonon being unable to play .ogg files, because the package "speex" is not present

I cannot believe that this problem was solved by installing a missing package. I really hope this bug has been squashed in the KDE 4.10 release. I think my problem occurred after installing Counter Strike through Steam, which I do believe use speex for its VOIP.

Thank you so much for posting a fix beder!


All times are GMT -5. The time now is 04:30 PM.