LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-13-2013, 06:51 PM   #1
nepeta
LQ Newbie
 
Registered: Jan 2013
Posts: 9

Rep: Reputation: Disabled
Cannot set ESSID using iwconfig


Hi I've been bashing my head against this for a couple of days now. First I tried editing rc.inet.conf and wpa_supplicant. When that didn't work I tried changing them back the way they were. Then I set my router up to have a guest network with no key just to see if I could get it to work that way. I've been trying to use iwconfig to set the ESSID so far to no avail. I have been using:
Code:
iwconfig wlan0 essid GUEST_Network
I do not get any error messages, but when I check again the ESSID is not listed. It is set to off/any. I'm sure it has to be some stupid little thing I'm doing wrong as I am new at this.

Also, I don't know if it helps, but I can scan with iwlist and get a nice long list of all the access points so I think the wireless adapter is working.
Thanks.
 
Old 01-13-2013, 07:49 PM   #2
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
Do you have either NetworkManager or Wicd running? If so, they may be interfering with your attempts at manual configuration. Also, is there a reason you are trying manual configuration of your wireless adapter rather than using one of the aforementioned tools? (Not that you need to use one; there are perfectly valid reasons for manual configuration.)
 
Old 01-13-2013, 08:19 PM   #3
ttk
Member
 
Registered: May 2012
Location: Sebastopol, CA
Distribution: Slackware
Posts: 218
Blog Entries: 13

Rep: Reputation: 151Reputation: 151
what does "rfkill list" tell you? If a wireless device is hard- or soft-blocked, some iwconfig commands can fail.
 
Old 01-13-2013, 08:36 PM   #4
nepeta
LQ Newbie
 
Registered: Jan 2013
Posts: 9

Original Poster
Rep: Reputation: Disabled
Mike_M: I have no idea how to see if NetworkManager or Wicd are running. I would assume not as it is a fresh install and I have only set up a user account and attempted to connect to the internet. I'm probably doing this completely backwards. Its just that I was going by the configuration guide in docs.slackware.com, and I am a perfectionist and have to follow instructions exactly and I know you probably don't have to do it like that, but one of the first things it said to do was update I think, and I didn't have a way to do that. Also, now that I've started doing it like this, I just think it would be neat to do manually. I guess a good question would be in what order should I be setting up these things.

ttk: There are entries for acer-wireless and phy0 and neither of them are hard or soft blocked.
 
Old 01-13-2013, 09:19 PM   #5
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
Quote:
Originally Posted by nepeta View Post
Mike_M: I have no idea how to see if NetworkManager or Wicd are running. I would assume not as it is a fresh install and I have only set up a user account and attempted to connect to the internet.
Then no, neither is likely to be running. There are several ways to find out if they're running. If the output of

Code:
ps ax|grep NetworkManager
and

Code:
ps ax|grep wicd
don't return anything, then neither is running.

Quote:
Originally Posted by nepeta View Post
ttk: There are entries for acer-wireless and phy0 and neither of them are hard or soft blocked.
This may be your issue. That acer-wireless entry may be what is causing difficulties.

I'm assuming you can't copy/paste information directly from the computer in question due to lack of network connection, so troubleshooting may be more difficult.

If possible, provide the output of the following commands (be as precise as possible if you can't copy/paste):

Code:
/sbin/lspci|grep Network
Code:
/usr/sbin/ethtool -i wlan0
Code:
lsmod|grep acer
 
Old 01-13-2013, 10:08 PM   #6
nepeta
LQ Newbie
 
Registered: Jan 2013
Posts: 9

Original Poster
Rep: Reputation: Disabled
Code:
# ps ax|grep NetworkManager
 1938 ?       Ssl    0:03 /usr/sbin/NetworkManager
 2187 tty1    S+     0:00 grep NetworkManager

# ps ax|grep wicd
 2189 tty1    S+     0:00 grep wicd

# rfkill list
0: acer-wireless: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

# /sbin/lspci|grep Network
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

# /usr/sbin/ethtool -i wlan0
driver: ath9k
version: 3.2.29
firmware-version: N/A
bus-info: 0000:02:00.0

# lsmod|grep acer
acer_wmi            19581  0
sparse_keymap        3016  1 acer_wmi
wmi                  8403  1 acer_wmi
rfkill              15428  3 cfg80211,acer_wmi
 
Old 01-13-2013, 11:12 PM   #7
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
Quote:
Originally Posted by nepeta View Post
Code:
# ps ax|grep NetworkManager
 1938 ?       Ssl    0:03 /usr/sbin/NetworkManager
 2187 tty1    S+     0:00 grep NetworkManager
So network manager is running. That will get in the way of your approach. If you want to continue attempting to manually configure your wireless network, run the following as root to turn off NetworkManager and keep it from starting in the future:

Code:
# /etc/rc.d/rc.networkmanager stop
# chmod -x /etc/rc.d/rc.networkmanager
Quote:
Originally Posted by nepeta View Post
Code:
# rfkill list
0: acer-wireless: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no

# lsmod|grep acer
acer_wmi            19581  0
sparse_keymap        3016  1 acer_wmi
wmi                  8403  1 acer_wmi
rfkill              15428  3 cfg80211,acer_wmi
Even with NetworkManager out of the way, I think the acer_wmi module may also cause problems. After you stop NetworkManager see if you can use iwconfig to associate with your access point. If you still are unable to you may want to try blacklisting the acer_wmi module it to keep it from loading. This can be done by doing the following (again, as root) and rebooting:

Code:
echo "blacklist acer_wmi" > /etc/modprobe.d/acer.conf
I suggest doing this only if you still have problems after stopping NetworkManager because keeping that module from loading may reduce the functionality of your computer in some way (certain special buttons may not work, etc.)

Last edited by Mike_M; 01-14-2013 at 01:49 AM. Reason: Was missing the word "stop" after /etc/rc.d/rc.networkmanager
 
Old 01-13-2013, 11:29 PM   #8
nepeta
LQ Newbie
 
Registered: Jan 2013
Posts: 9

Original Poster
Rep: Reputation: Disabled
Okay, thanks very much.
Kind of off topic, but, I'm trying to decide on a desktop environment. It's going to be on a little netbook so I'm leaning towards xfce. Should I choose xfce or kde and if I do should I still go about setting it up manually, or try to get it running in the de? If I do get it running in the de will I still need to do the stuff above?
Thanks.
 
Old 01-13-2013, 11:42 PM   #9
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
Which DE to use is a matter of personal taste. Either XFCE or KDE should be fine. Both of them will have an applet to configure wireless using NetworkManager, so I'd suggest giving that a shot at some point.

There is nothing wrong with learning how to manually configure wireless networking so that you know what is going on in the background, but NetworkManager is pretty simple to use and makes connecting to multiple access points a snap. If you do decide to skip configuring things manually, leave everything the way it is now and see if you're able to associate with your access point using the NetworkManager applet within whichever DE you choose.
 
Old 01-14-2013, 01:18 AM   #10
nepeta
LQ Newbie
 
Registered: Jan 2013
Posts: 9

Original Poster
Rep: Reputation: Disabled
Okay. Is there a way to turn off NetworkManager for a second to play around with it? I will probably go ahead and use xfce as I am distro hopping and I already have kde running under openSUSE and Openbox running under Crunchbang. I really like Crunchbang so far. It's so plain. I used to think I enjoyed having a bunch of flashy stuff going on and I guess I still do to some extent, but I'm really starting to like simplicity. KDE/openSUSE is nice so far but a little buggy at times and I guess I have a fear it's going to use up too many resources. I was using Ubuntu and Unity which I liked okay, but it started to get really laggy so I gave it up. I think I got a bit teary eyed when I had to give it up because it's the first one I ever really used. Silly, I know. And now I'm trying Slackware. Honestly, I had no idea what I was getting myself into, but I've begun to learn some command line stuff which is great. Still not picking up on what all the lsmod, grep chmod stuff is though. I can get around the file system and edit stuff so far, and now I can use iwconfig, I think. I really need to read up on this stuff. sorry to be so long winded.
 
Old 01-14-2013, 01:47 AM   #11
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
Quote:
Originally Posted by nepeta View Post
Okay. Is there a way to turn off NetworkManager for a second to play around with it?
The following will stop it:

Code:
# /etc/rc.d/rc.networkmanager stop
To start it again:

Code:
# /etc/rc.d/rc.networkmanager start
Quote:
Originally Posted by nepeta View Post
Still not picking up on what all the lsmod, grep chmod stuff is though. I can get around the file system and edit stuff so far, and now I can use iwconfig, I think. I really need to read up on this stuff. sorry to be so long winded.
We all have to start somewhere, and everyone learns at their own pace. No worries at all. Man pages are a great way to learn about commands, although they aren't always the easiest documentation to read. If you are interested to see what those command are/do, run "man <command name>" from a terminal. For example:

Code:
man lsmod
Run "man man" to learn more about what man pages are and how they are laid out.
 
Old 01-14-2013, 03:03 AM   #12
nepeta
LQ Newbie
 
Registered: Jan 2013
Posts: 9

Original Poster
Rep: Reputation: Disabled
I think I would like to use wicd and xfce. Will I need to uninstall NetworkManager first? Should I just keep using NetworkManager?
 
Old 01-14-2013, 06:11 AM   #13
Mike_M
Member
 
Registered: Mar 2011
Location: California
Distribution: Slackware
Posts: 116

Rep: Reputation: 50
You don't need to uninstall NetworkManager. Just follow the two steps I posted earlier to disable it:

Code:
# /etc/rc.d/rc.networkmanager stop
# chmod -x /etc/rc.d/rc.networkmanager
The first step stops it from running. The second step removes executable permission from the script that starts it, so it won't start up when your system boots. That way you can switch to it latter if you feel like without the need to reinstall.
 
Old 01-14-2013, 01:09 PM   #14
nepeta
LQ Newbie
 
Registered: Jan 2013
Posts: 9

Original Poster
Rep: Reputation: Disabled
Thanks. I will try it. Thank you for providing explanations also.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot SET ESSID using IWCONFIG Fergatron Linux - Wireless Networking 11 04-03-2012 12:36 PM
Cannot set ESSID with iwconfig leapingfrog Linux - Wireless Networking 37 09-15-2008 04:54 AM
iwconfig does nor set essid irena56 Linux - Wireless Networking 4 09-18-2006 09:20 AM
iwconfig - can't set essid simon_w Linux - Wireless Networking 5 04-13-2005 10:23 PM
essid not being set with iwconfig jonathan_t Linux - Wireless Networking 17 10-19-2004 07:14 AM


All times are GMT -5. The time now is 01:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration