LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-27-2004, 10:30 AM   #1
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Rep: Reputation: 57
Cannot play music CDs


Tried Xine, KsCD, XMMS. Nothing seems to be seeing my music cds.

KsCD is pointed at /dev/cdrom. There is sound when playing mpg etc.

I have ssci emulation installed if that makes a difference.
 
Old 06-27-2004, 10:58 AM   #2
horndude
Member
 
Registered: Sep 2003
Posts: 43

Rep: Reputation: 15
Make sure audio cable is connected between cdrom and sound card.

Try playing them as root, if that works then change permissions in fstab for cdrom.
 
Old 06-27-2004, 03:19 PM   #3
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
you say you are using scsi emulation. check your /etc/fstab, does the entries there reflect that in combination with the symlinks in your /dev.
 
Old 06-27-2004, 03:41 PM   #4
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Original Poster
Rep: Reputation: 57
Regarding cables; I can play CDS from knoppix or Windows.

Regarding fstab I have no problem mounting cds

Here are the relevant lines.

/dev/sr0 /mnt/cdrom iso9660 user,noauto,ro 0 0
/dev/sr1 /mnt/cdrw iso9660 user,rw 0 0

In fact I have kscd pointing at /dev/sr0 not cdrom as I wrote before.
 
Old 06-27-2004, 03:42 PM   #5
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Original Poster
Rep: Reputation: 57
Oh, and I have tried unsuccessfully as root
 
Old 06-27-2004, 03:48 PM   #6
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Quote:
Tried Xine, KsCD, XMMS. Nothing seems to be seeing my music cds.
Could you be more precise ? no error message ? same if programs started from command-line ?

Did you try ln -s /dev/sr0 /dev/cdrom ?
 
Old 06-27-2004, 04:05 PM   #7
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Original Poster
Rep: Reputation: 57
No error message. Clicking play just shows 00.00 on the timer. Same if from the console

CDDB show 'No disc'

ln -s /dev/sr0 /dev/cdrom does not help
 
Old 06-27-2004, 04:09 PM   #8
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,617

Rep: Reputation: 136Reputation: 136
Just to make sure, you have SCSI CDrom not IDE ?
 
Old 06-27-2004, 04:31 PM   #9
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
do you have correct permissions on /dev/sr0?
 
Old 06-27-2004, 04:32 PM   #10
miqorz
LQ Newbie
 
Registered: Dec 2003
Distribution: Slackware Current
Posts: 12

Rep: Reputation: 0
Make sure you're in the CDROM group in /etc/group
 
Old 06-27-2004, 04:40 PM   #11
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Original Poster
Rep: Reputation: 57
I have ssci emulation as advised in the xcdroast faq

ine for /etc/modules.conf

options ide-cd ignore='hdc hdd'

(This tells the IDE-driver to ignore the two devices you want to use within X-CD-Roast)

-

Line for /etc/lilo.conf (add anywhere before any "image=" lines)

append="hdc=ide-scsi hdd=ide-scsi" (Kernel 2.2.x and most 2.4.x)

or

append="hdc=scsi hdd=scsi" (Kernel 2.4.x only, if the above line does not work
 
Old 06-27-2004, 04:59 PM   #12
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Original Poster
Rep: Reputation: 57
Just discovered that I can listen to music CDs from gnome.

My problem is in KDE 3.2.3 ( a recent swaret upgrade)
 
Old 06-27-2004, 05:07 PM   #13
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,211

Original Poster
Rep: Reputation: 57
This is really odd. It is now working in kde. And the only thing I did different was try it out in gnome!
 
Old 06-27-2004, 06:16 PM   #14
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
Further proof that Bob must use Gnome.
 
Old 08-21-2004, 10:09 PM   #15
boolim
Member
 
Registered: Aug 2003
Distribution: Slackware
Posts: 32

Rep: Reputation: 15
strangely.. i can't play it in gnome(din tried kde n other coz din install them)! it says drive error... no way, they play well in windows, my hi-fi..... besides, i've no prb at all to mount other data disc

Last edited by boolim; 08-21-2004 at 10:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Listening to music? Not me! (can't play or rip audio CDs) NetRAVEN5000 Slackware 21 06-19-2005 06:57 PM
I can only play music cds as root r3dhatter Linux - Newbie 5 12-30-2004 03:50 PM
Music cds vapebait Slackware 14 12-11-2003 06:03 PM
CD-RW does not want to play music CDs! Dzemo Linux - General 6 01-09-2003 10:23 AM
Music CDs TX_metalhead Linux - General 6 05-02-2002 09:29 PM


All times are GMT -5. The time now is 10:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration