LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-24-2010, 03:35 AM   #1
traveller1212
LQ Newbie
 
Registered: Feb 2010
Location: Vancouver Canada
Distribution: Slackware
Posts: 8

Rep: Reputation: 0
Cannot play audio CD on Slackware 13.0 KDE 4.2.4


I use Slackware full-time on my personal machine, a Lenovo T61, and I've used Slackware happily for the past 15 years. I've always been able to find answers to my questions by searching, but this time I'm stumped and find myself posting my first question ever to a help site.

Recently installed Slackware 13.0 out of the box, which has KDE 4.2.4. I've added myself as a regular user, and made sure I'm a member of the audio and cdrom groups. I've configured sound with alsaconf and alsamixer, and sound works fine when playing digital files (audio and video). I can mount data CDs and DVDs, and read them with Dolphin. When I insert an audio CD, I can't get any application to see it, except for the "Last plugged in device" widget, which only gives me K3B as an option to rip the CD - no option to play the CD. If I allow K3B to launch, that application can see the tracks.

In my searches for a solution, I've read posts that suggest KDE 4 does not have good support for playing audio CDs. I've seen various suggestions for fixes that relate to udev, HAL and adding actions. I'm out of my league here, as I'm a casual user, not one who can dive into these details.

My guess is that udev is OK because K3B can see the audio CD.

When I look at /usr/share/apps/solid/actions, I see the following:
-rw-r--r-- 1 root root 2871 2009-03-26 07:42 test-predicate-openinwindow.desktop
-rw-r--r-- 1 root root 2385 2009-04-02 23:16 k3b_videodvd_rip.desktop
-rw-r--r-- 1 root root 861 2009-04-02 23:16 k3b_create_data_project_from_blank_medium.desktop
-rw-r--r-- 1 root root 2391 2009-04-02 23:16 k3b_create_audio_cd_from_blank_medium.desktop
-rw-r--r-- 1 root root 636 2009-04-02 23:16 k3b_copy_disc.desktop
-rw-r--r-- 1 root root 2272 2009-04-02 23:16 k3b_audiocd_rip.desktop
-rw-r--r-- 1 root root 3174 2009-04-30 02:13 dragonplayer-opendvd.desktop

There are no actions that appear to relate to start playing a CD, so I think this is where the problem lies, but I'm not sure, and if it is, I don't know how to fix it. Things have gotten a lot more complicated over the years...

Playing an audio CD should be a simple task, and I'm embarrassed that it's taking so long to debug this problem.

Please let me know if you have a solution, or need more info on my configuration. Any tips on methodical troubleshooting would also be appreciated.

Thanks!
 
Old 02-24-2010, 03:42 AM   #2
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
Which programs have you tried to play the cd with?

Does cdda-player work?

Last edited by dive; 02-24-2010 at 03:44 AM.
 
Old 02-24-2010, 11:37 AM   #3
traveller1212
LQ Newbie
 
Registered: Feb 2010
Location: Vancouver Canada
Distribution: Slackware
Posts: 8

Original Poster
Rep: Reputation: 0
Thank you for the quick reply.

I'm not particular about the CD player I want to use, but I'd prefer it to be GUI based. Amarok would be fine. I tried cdda-player from the command line as you suggested, and I can see that it is playing the tracks (so I can add this to the list of applications that at least can see the CD); however, there was no sound from the speakers or headphones. I don't see anything obvious from alsamixer why there would be no sound. I'll need to investigate this further later.

With Amarok, when I select "Play Media", I can't find where to point it to see the CD. I tried all of the devices under /media.

Similar result with the other GUI-based players (Audacious, XMMS) that come stock with Slackware - cannot find the CD.
 
Old 02-24-2010, 12:37 PM   #4
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
The device would be /dev/hdc or /dev/sr0 or similar (last digit/letter may be different). You may also find that there's a symlink of the device to /dev/cdrom

It sounds like you may have a sound problem if cdda-player can play the cd with no sound. Have you configured 'alsaconf', 'alsamixer' and 'alsactl store'?

Last edited by dive; 02-24-2010 at 12:39 PM.
 
Old 02-24-2010, 04:04 PM   #5
hughetorrance
Member
 
Registered: Aug 2009
Location: London North West
Distribution: x86_64 Slack 13.37 current : +others
Posts: 459

Rep: Reputation: 59
The first thing I would do is stick a live distro in the CD/DVD drve and fire it up and if evrything works then you can say your hardware is Ok then you can continue trying to resolve the software issue...
 
Old 02-24-2010, 10:01 PM   #6
globaltree
Member
 
Registered: Oct 2007
Location: Oregon
Distribution: Slackware 12.2
Posts: 65

Rep: Reputation: 18
Well... according to amarok, they don't support cd playing in amarok 2: http://amarok.kde.org/wiki/FAQ#How_do_I_play_audio-CDs...

Grr, bugger them... how can we get folks trying out and switching to linux if it can't play audio cd's...

Hmm... it may be possible to run kde3/amarok1 in a chroot just for cd playback...

Or maybe could use combination of cdda2wav and flac to just grap cd contents and feed them to amarok in flac files, though that wouldn't be technically solving the cdda deal...

Or maybe going all the way to slac-current would help... they might have worked it out already...

Last edited by globaltree; 02-24-2010 at 10:06 PM. Reason: added flac suggestion
 
Old 02-24-2010, 10:55 PM   #7
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
There used to be a kde cd player but I don't know for kde4.x. I thought it was called kscd. Seems to be gone, but I found this:

http://www.amb.org/xmcd/

looks ok first impression. I will have a go at building shortly and hopefully be able provide a slackbuild script (and also submit slackbuilds.org if it's any good).

Edit: Doesn't compile.

You should at least be able to play cd's in xine (gxine)

Grip is a little better: http://slackbuilds.org/repository/13.0/multimedia/grip/

You can install from there or use sbopkg

But if cdda-player appears to be playing without sound check alsamixer (cd level perhaps?)
If you do manage to get sound then 'alsactl store' as root will save the settings.

Last edited by dive; 02-25-2010 at 12:31 AM.
 
1 members found this post helpful.
Old 02-25-2010, 04:47 AM   #8
traveller1212
LQ Newbie
 
Registered: Feb 2010
Location: Vancouver Canada
Distribution: Slackware
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks to everyone for your comments and suggestions.

hughetorrance: Tested live distro and it works fine.

globaltree: Thanks for the link to the FAQ. It's good to know when a solution does not exist, so I can stop looking. I read the Amarok Handbook that described how to play an audio CD - so I expected it should work - but now I realize that was for Amarok 1.x, and I didn't expect to lose a feature going to Amarok 2.

I noticed this link on the Amarok site:
http://amarok.kde.org/en/releases/2.2/beta/1
and the following excerpt from the description of the new release:
"Want to play a CD? Just put it in your drive and it will appear in the collection browser, allowing you to either play it directly or copy the tracks to your harddrive."
There is now stable source for 2.2.2, so I might give that a try when I find more time.

dive: I tried xine to play the CD, and it works - sound and all!

The "no sound from cdda-player" issue still puzzles me, as I wonder if it will bite me again with some other app in the future. I've tried tinkering with alsamixer, and I don't see anything obviously wrong. I don't think anything is muted that should not be, and I unmuted everything anyway just to check. Still no sound (but only with cdda-player).

Playing volume = 100 in the cdda-player window.

I tried adjusting KMix - the settings look a lot like those in alsamixer, and I don't know if they are linked or one overrides the other.

For now, I will just use xine. The solution is a workaround - skip by the "Audio Player" apps in the KDE Applications menu, and choose this multimedia player instead.

I will watch the Slackbuild site to see if xmcd gets uploaded there.

Thanks again very much for your help and suggestions!
 
Old 02-25-2010, 05:58 AM   #9
veeall
Member
 
Registered: May 2007
Location: Estonia
Distribution: Slackware 12.1, slackware64-current
Posts: 255

Rep: Reputation: 43
Quote:
"Want to play a CD? Just put it in your drive and it will appear in the collection browser, allowing you to either play it directly or copy the tracks to your harddrive."
I just tried, cd-s work as advertised using amarok 2.2.1 from current.
 
Old 02-25-2010, 06:59 AM   #10
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
Does the kio-audiocd-slave work? In konq or dolphin, type audiocd:// in the location bar. Not a player, but many people seem to forget about the various kio-slaves.

FWIW, workbone nor cdda-player have sound on any of our PCs. But, we also do not use the analog audio cable from the cdrom to the sound card.

If you wanted a couple of other solutions included with Slackware 13.0 -
xmms -p /mnt/cdrom
mplayer cdda://

With audacious I had to go through the plugin service - scan cd - add cd, to get that app to play audio cds. I do find it strange there is not a better application to play audio CDs. Wonder why this feature is not included in Juk, or even a simple play button in KAudioCreator.
 
1 members found this post helpful.
Old 02-25-2010, 08:46 AM   #11
w1k0
Senior Member
 
Registered: May 2008
Location: Poland
Distribution: Slackware, Mint
Posts: 1,240

Rep: Reputation: 196Reputation: 196
I use ThinkPad T60 with Slackware 13.0 and I can confirm: cdda-player plays music from Audio CDs without producing sound. It's really strange. I tried commands: xmms -p /mnt/cdrom as well as mplayer cdda:// and both play music. I tried also xine and audaciuos and both work well too. In my opinion audacious is the best if you prefer GUI applications.

EDIT 1: In audacious you'll find CD-ROM after right mouse button click in Plugin Services menu.

EDIT 2: Since T61 uses SCSI hard drive CD-ROM device isn't /dev/hdc but /dev/hda (or /dev/cdrom symbolic link).

EDIT 3: I tried workbone -a command. It plays music though it isn't comfortable to use numpad on my T60.

EDIT 4: After trying workbone I tried cdda-player and it started to play music aloud.

EDIT 5: Two above reports was about miracles. I can't force workbone or cdda-player to play music now.

Last edited by w1k0; 02-25-2010 at 07:05 PM.
 
1 members found this post helpful.
Old 02-28-2010, 04:25 AM   #12
traveller1212
LQ Newbie
 
Registered: Feb 2010
Location: Vancouver Canada
Distribution: Slackware
Posts: 8

Original Poster
Rep: Reputation: 0
Both the xmms and mplayer command line options worked. workbone did not, but I agree that workbone isn't the most convenient choice because of the numpad control. Actually, my machine seized when I ran workbone - to the extent that I had to hit the power button, which managed to start an orderly (but very, very slow) shutdown sequence.

Thanks for the tip to get audacious to find the CD. That works now too.

Excellent responses - thanks everyone! I haven't seen such a list of options on this topic anywhere else.
 
Old 03-01-2010, 02:59 PM   #13
veeall
Member
 
Registered: May 2007
Location: Estonia
Distribution: Slackware 12.1, slackware64-current
Posts: 255

Rep: Reputation: 43
I found out that there's ksCD in kde 4.3.4 too, but it is not compiled since it needs musicbrainz v2. It has a gui that is different from kde3 version. Not to be missed, though

Last edited by veeall; 03-01-2010 at 03:15 PM.
 
Old 03-01-2010, 03:21 PM   #14
x-alien
Member
 
Registered: Aug 2008
Distribution: Slackware
Posts: 39

Rep: Reputation: 21
Kaffeine-1.0_pre3

Package ready for use with Slackware 13:

http://repository.slacky.eu/slackwar...eine/1.0_pre3/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't play audio CD in slackware ceashton Slackware 21 10-26-2011 06:01 PM
kde : ability to play audio cd gone crispyleif Linux - Software 4 11-24-2005 06:07 PM
how to play audio cd in slackware 10.1? anindyanuri Slackware 13 06-26-2005 01:06 AM
Audio CD Doesn't Play - Slackware mijenks Slackware 9 07-22-2004 11:44 PM


All times are GMT -5. The time now is 12:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration