LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-23-2007, 07:39 AM   #1
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Rep: Reputation: 137Reputation: 137
Cannot modprobe snd-usb-audio Slackware Current


Hi all

On trying to modprobe snd-usb-audio I get the following error message.

Quote:
FATAL: Error inserting snd_usb_audio (/lib/modules/2.6.18.8-smp/kernel/sound/usb/snd-usb-audio.ko): Unknown symbol in module, or unknown parameter (see dmesg)
dmesg reveals
Quote:
snd_usb_audio: Unknown symbol snd_hwdep_new
Any thoughts

Samac
 
Old 03-24-2007, 10:11 AM   #2
erklaerbaer
Member
 
Registered: Mar 2006
Posts: 381

Rep: Reputation: 30
the alsa project has probably renamed some stuff(e.g. snd-hwdep-new).
run alsaconf and see if it fixes your issue.
 
Old 03-24-2007, 11:52 AM   #3
samac
Senior Member
 
Registered: Mar 2004
Location: Westray, Orkney
Distribution: Slackware64-14.1 (multi-lib) KDE 4.11.4
Posts: 1,422

Original Poster
Rep: Reputation: 137Reputation: 137
Hi

I've done that, and my sound card was detected, however my laptop speakers did not work, so I needed external usb speakers.

However one of my laptop speakers just started working, first time in a year, both windows and linux.

So I now know that sound works in current on my laptop, but I would still like to be able to change to my usb speakers from time to time.

Samac
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel HD Audio (azalia) - No sound! (kernel 2.6.17.8 @ slackware current) violat0r Linux - Hardware 11 08-25-2006 03:07 AM
External USB SB Live 24 with snd-usb-audio: mixer too rudimentary LaoNiu Linux - Hardware 0 05-28-2006 10:22 AM
snd-usb-audio driver loaded, but not the mic (fc4) Alterego Linux - Hardware 0 12-25-2005 04:12 PM
modprobe snd-usb-audio error abunsair Debian 5 07-08-2005 05:41 PM
problem loading snd-usb-audio as card 1 farpoint Debian 2 05-03-2005 04:19 PM


All times are GMT -5. The time now is 11:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration