LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-30-2010, 05:02 AM   #1
trumpet_tom
Member
 
Registered: Dec 2004
Distribution: Slackware64-current
Posts: 95

Rep: Reputation: 19
cannot compile qjackctl from slackbuild on slackware64-current


Hi, when I try to compile qjackctl I get this error
Code:
 QjackCtl 0.3.4

  Build target . . . . . . . . . . . . . . . . . . .: release

  JACK Audio Connection Kit support  . . . . . . . .: yes
  JACK Realtime support  . . . . . . . . . . . . . .: yes
  JACK Transport support . . . . . . . . . . . . . .: yes
  JACK XRUN delay support  . . . . . . . . . . . . .: yes
  JACK Maximum scheduling delay support  . . . . . .: yes
  JACK MIDI support  . . . . . . . . . . . . . . . .: yes
  ALSA MIDI Sequencer support  . . . . . . . . . . .: yes
  System tray icon support . . . . . . . . . . . . .: yes

  Install prefix . . . . . . . . . . . . . . . . . .: /usr

Now type 'make', followed by 'make install' as root.

make[1]: Entering directory `/tmp/SBo/qjackctl-0.3.4'
/usr/lib/qt/bin/uic src/qjackctlAboutForm.ui -o ui_qjackctlAboutForm.h
/usr/lib/qt/bin/uic src/qjackctlConnectionsForm.ui -o ui_qjackctlConnectionsForm.h
/usr/lib/qt/bin/uic src/qjackctlMainForm.ui -o ui_qjackctlMainForm.h
/usr/lib/qt/bin/uic src/qjackctlMessagesForm.ui -o ui_qjackctlMessagesForm.h
/usr/lib/qt/bin/uic src/qjackctlPatchbayForm.ui -o ui_qjackctlPatchbayForm.h
/usr/lib/qt/bin/uic src/qjackctlSetupForm.ui -o ui_qjackctlSetupForm.h
/usr/lib/qt/bin/uic src/qjackctlSocketForm.ui -o ui_qjackctlSocketForm.h
/usr/lib/qt/bin/uic src/qjackctlStatusForm.ui -o ui_qjackctlStatusForm.h
g++ -c -pipe -O2 -march=i486 -mtune=i686 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_XML_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt/mkspecs/linux-g++ -I. -I/usr/lib/qt/include/QtCore -I/usr/lib/qt/include/QtGui -I/usr/lib/qt/include/QtXml -I/usr/lib/qt/include -Isrc -I/usr/lib/qt/include -I/usr/local/include -I/usr/include -I. -I. -o main.o src/main.cpp
src/main.cpp:1: error: CPU you selected does not support x86-64 instruction set
make[1]: *** [main.o] Error 1
make[1]: Leaving directory `/tmp/SBo/qjackctl-0.3.4'
make: *** [qjackctl] Error 2
I can assure you I have a 64 bit processor. Has anyone else experienced this?
 
Old 09-30-2010, 05:19 AM   #2
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
Quote:
Originally Posted by trumpet_tom View Post
Hi, when I try to compile qjackctl I get this error
Code:
g++ -c -pipe -O2 -march=i486 -mtune=i686 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_XML_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/lib/qt/mkspecs/linux-g++ -I. -I/usr/lib/qt/include/QtCore -I/usr/lib/qt/include/QtGui -I/usr/lib/qt/include/QtXml -I/usr/lib/qt/include -Isrc -I/usr/lib/qt/include -I/usr/local/include -I/usr/include -I. -I. -o main.o src/main.cpp
src/main.cpp:1: error: CPU you selected does not support x86-64 instruction set
I can assure you I have a 64 bit processor. Has anyone else experienced this?
You may have a 64bit cpu but you told configure to build a i486 application.

Try this SlackBuild qjackctl

Last edited by XGizzmo; 09-30-2010 at 05:26 AM.
 
Old 09-30-2010, 06:40 AM   #3
trumpet_tom
Member
 
Registered: Dec 2004
Distribution: Slackware64-current
Posts: 95

Original Poster
Rep: Reputation: 19
That's the slackbuild I was using before. Even if I specify "ARCH=x86_64" the error still occurs.
 
Old 09-30-2010, 11:19 AM   #4
BrZ
Member
 
Registered: Apr 2009
Distribution: Slackware
Posts: 490

Rep: Reputation: 79
Mine was built with this script.

qjackctl.desktop
Attached Images
File Type: png qjackctl.png (35.0 KB, 12 views)
 
Old 09-30-2010, 12:43 PM   #5
lyle_s
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 52
This has been a problem for a long time.

Here's my patch; there's really only one line to change:

--- qjackctl.SlackBuild.orig 2010-04-28 22:34:33.922032119 -0500
+++ qjackctl.SlackBuild.new 2010-04-28 22:33:17.753998927 -0500
@@ -59,6 +59,9 @@
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm
400 \) \
-exec chmod 644 {} \;

+# Tell qmake about our SLACKFLAGS.
+echo "QMAKE_CXXFLAGS_RELEASE=$SLKCFLAGS" >> qjackctl.pro.in
+
CFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \


Lyle.
 
1 members found this post helpful.
Old 10-01-2010, 12:04 PM   #6
trumpet_tom
Member
 
Registered: Dec 2004
Distribution: Slackware64-current
Posts: 95

Original Poster
Rep: Reputation: 19
I couldn't get that patch to work but I just installed qjackctl directly from source and it works fine. Does the slackbuild maintainer know about the problem if it has been around for a while?
 
Old 10-01-2010, 12:22 PM   #7
sahko
Senior Member
 
Registered: Sep 2008
Distribution: Slackware
Posts: 1,041

Rep: Reputation: Disabled
Did you use custom CFLAGS or the SlackBuilds.org defaults?
You could also have them defined in a file such as ~/.bashrc

Last edited by sahko; 10-01-2010 at 12:24 PM.
 
Old 10-01-2010, 12:28 PM   #8
trumpet_tom
Member
 
Registered: Dec 2004
Distribution: Slackware64-current
Posts: 95

Original Poster
Rep: Reputation: 19
I just used sbopkg which normally leaves me with a 64 bit package without me making any modifications. When I tried using the slackbuild myself, I didn't set any CFLAGS, but it compiled from source fine with just --prefix=/usr and --libdir=/usr/lib64.
 
Old 10-01-2010, 07:17 PM   #9
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
Quote:
Originally Posted by trumpet_tom View Post
I couldn't get that patch to work but I just installed qjackctl directly from source and it works fine. Does the slackbuild maintainer know about the problem if it has been around for a while?
There is nothing wrong with the SlackBuild so there is nothing to report.
You need to make sure you are using builds for 13.1 and a sbopkg that is
updated for 13.1.
 
Old 01-28-2011, 11:53 AM   #10
tdos20
Member
 
Registered: Aug 2006
Location: London
Distribution: Slackware
Posts: 103

Rep: Reputation: 29
I had success using the amended line in the patch - thanks - was scratching my head!
 
Old 06-13-2011, 12:57 PM   #11
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,453

Rep: Reputation: Disabled
I just had the same problem on 13.37, solved by the additional line. Thanks a lot.

Brian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] bluez.Slackbuild fix for Slackware64-13.0 drumz Slackware 5 05-04-2010 11:30 PM
[SOLVED] Can't compile tolua++ in slackware64-current Daedra Slackware 1 03-23-2010 08:04 AM
What changes must be made in a slackBuild from 11.x To build for Slackware64 current? Alexvader Slackware 5 12-30-2009 01:38 PM
How can I make PyQt4 slackbuild compile in Slackware64 <current>...? Alexvader Slackware 9 12-30-2009 07:45 AM
For the Krusader fans on slackware64 slackbuild ROXR Slackware 0 07-20-2009 06:03 PM


All times are GMT -5. The time now is 10:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration