Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Slackware This Forum is for the discussion of Slackware Linux.


  Search this Thread
Old 01-06-2006, 05:29 AM   #1
Registered: Apr 2004
Distribution: Slackware, Ubuntu
Posts: 101

Rep: Reputation: 15
Cannot compile OpenGL program because libGL.a is missing

I've been trying to compile Blender on my computer, and so far I've managed to fix errors until I get the following linker error:

g++: /usr/lib/libGL.a: No such file or directory
make[1]: *** [/opt/installations/blender-2.40/obj/linux-glibc2.3.6-i386/bin/blenderstatic] Error 1
make: *** [all] Error 1
I've installed both the binary NVIDIA drivers and installed MesaLib from source, but neither contain libGL.a. Where should I get this file from?
Old 01-06-2006, 10:23 AM   #2
Registered: Nov 2002
Location: Yorkshire,England
Distribution: Slackware, Slamd64
Posts: 47

Rep: Reputation: 15
i think this packages contains libGL.a

Old 01-07-2006, 01:21 AM   #3
Registered: Apr 2004
Distribution: Slackware, Ubuntu
Posts: 101

Original Poster
Rep: Reputation: 15
Found it, thanks!
Old 04-12-2009, 03:46 PM   #4
LQ Newbie
Registered: Apr 2009
Posts: 1

Rep: Reputation: 0
I had the same problem,
the Ubuntu equivalent would be:
sudo apt-get install libgl1-mesa-swx11-dev
Old 04-12-2009, 04:09 PM   #5
Alien Bob
Slackware Contributor
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,789

Rep: Reputation: Disabled
Please do not try to resurrect old long-dead threads!

The information in this particular thread no longer has any relevance to Slackware, because the "x11-devel" package of Slackware 11.0 (X.Org 6.9.0) is no longer present in present-day Slackware with it's modular X.Org build.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post file missing? Xandor Linux - Software 2 10-25-2005 01:42 AM
libgl opengl rendering problem Astro Slackware 5 05-15-2005 06:34 PM
Missing doctorwebbox Debian 12 04-14-2005 01:00 PM
missing OpenGL component GuShPaNkA Linux - Software 1 03-17-2005 05:09 AM
[c++ / glut] program will not compile (missing references) xuniL1 Programming 2 09-21-2004 04:17 AM

All times are GMT -5. The time now is 11:12 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration