LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-14-2013, 07:26 AM   #1
amenos42
Member
 
Registered: Jun 2013
Location: USA
Distribution: Slackware
Posts: 35

Rep: Reputation: Disabled
Cannot change file permissions


The file in question is "start-tor-browser" part of the Tor Browser Bundle which I've just extracted to my USB disk. Its permissions are "-rw-rw-rw" and if I log in as root and try to use chmod to change the permissions nothing happens.

The commands I've used are:

chmod 777 ./start-tor-browser
and
chmod a+x ./start-tor-browser

Both times there has been no output to the console and no change in the file's permissions. What's up?
 
Old 07-14-2013, 07:31 AM   #2
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,014

Rep: Reputation: 146Reputation: 146
Quote:
Originally Posted by amenos42 View Post
...
Both times there has been no output to the console and no change in the file's permissions. What's up?
Probably your USB disk'es filesystem does not support POSIX permissions. Run the "mount" command to check.
 
Old 07-14-2013, 08:23 PM   #3
amenos42
Member
 
Registered: Jun 2013
Location: USA
Distribution: Slackware
Posts: 35

Original Poster
Rep: Reputation: Disabled
You're right, it's vfat. I guess what this means is that I should split the disk into two partitions: one FAT type thing so I can transfer data between Linux and Windows and one ext4 for stuff like this.
 
Old 07-14-2013, 10:05 PM   #4
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 344

Rep: Reputation: 84
Or you could leave it like it is and just change the default file permissions for the given device. You cannot change file permissions on vfat on a file by file basis because the filesystem is incapable of storing this information, but you can specify the file permissions Linux sets for the entire device to be rwx in your /etc/fstab.

To do this, add "umask=000" in /etc/fstab as a mount option. This specifies the default permissions for all files on the given filesystem; a umask value of 000 would mean you have octal permissions of 777 for everything on the drive.

To learn more:

http://www.slackbook.org/html/filesystem-structure-mounting.html

Last edited by Kallaste; 07-14-2013 at 10:07 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How can I change file permissions in windows ntfs partition.Even root can't change it e3399 Linux - Newbie 3 03-02-2011 10:54 PM
Cannot change file permissions on a mounted file system koodoo Linux - Newbie 2 04-06-2010 11:22 PM
Trying to change file permissions Rollotamasi Linux - Software 2 09-22-2006 10:01 AM
unable to change file permissions!! dcdbutler Linux - General 11 02-06-2005 09:58 AM
file permissions and file owner won't change Nadim Slackware 5 11-29-2003 06:03 PM


All times are GMT -5. The time now is 04:47 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration