LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Cannot change file permissions (http://www.linuxquestions.org/questions/slackware-14/cannot-change-file-permissions-4175469589/)

amenos42 07-14-2013 07:26 AM

Cannot change file permissions
 
The file in question is "start-tor-browser" part of the Tor Browser Bundle which I've just extracted to my USB disk. Its permissions are "-rw-rw-rw" and if I log in as root and try to use chmod to change the permissions nothing happens.

The commands I've used are:

chmod 777 ./start-tor-browser
and
chmod a+x ./start-tor-browser

Both times there has been no output to the console and no change in the file's permissions. What's up?

guanx 07-14-2013 07:31 AM

Quote:

Originally Posted by amenos42 (Post 4990079)
...
Both times there has been no output to the console and no change in the file's permissions. What's up?

Probably your USB disk'es filesystem does not support POSIX permissions. Run the "mount" command to check.

amenos42 07-14-2013 08:23 PM

You're right, it's vfat. I guess what this means is that I should split the disk into two partitions: one FAT type thing so I can transfer data between Linux and Windows and one ext4 for stuff like this.

Kallaste 07-14-2013 10:05 PM

Or you could leave it like it is and just change the default file permissions for the given device. You cannot change file permissions on vfat on a file by file basis because the filesystem is incapable of storing this information, but you can specify the file permissions Linux sets for the entire device to be rwx in your /etc/fstab.

To do this, add "umask=000" in /etc/fstab as a mount option. This specifies the default permissions for all files on the given filesystem; a umask value of 000 would mean you have octal permissions of 777 for everything on the drive.

To learn more:

http://www.slackbook.org/html/filesystem-structure-mounting.html


All times are GMT -5. The time now is 05:16 PM.