LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Cannot build extreme tuxracer Slackware64 (http://www.linuxquestions.org/questions/slackware-14/cannot-build-extreme-tuxracer-slackware64-734181/)

mlangdn 06-19-2009 08:49 AM

Cannot build extreme tuxracer Slackware64
 
The build fails when configure can't find tclConfig.sh. This is not on my system, and seems to be part of tcl-dev. I can't seem to find a package or source code for a tcl8.5-dev. I have googled till my eyes hurt. :)

vinegaroon 06-19-2009 11:03 AM

That file is part of tcl, install the tcl package or the t series.

mlangdn 06-19-2009 02:14 PM

It is installed. This is a full install of Slackware64. But I am going to re-install the t series again anyway. There always could be a defect.

mlangdn 06-19-2009 09:47 PM

That didn't work, and looking at the package in mc shows that tclConfig.sh is not there. It's not that big a deal.

rg3 06-20-2009 01:52 AM

At least in 32 bits -current, the file is indeed part of the tcl package:

Code:

# slackroll local-search tclConfig
Reading contents of /var/log/packages ...
Matching files:
    tcl-8.5.7-i486-1
        /usr/lib/tclConfig.sh

End of list

As you can see, it's in /usr/lib, though.

Edit: I went further and downloaded the tcl package for Slackware64, and the file is also present, in /usr/lib64.

niels.horn 06-20-2009 07:42 AM

It's actually quite simple :)

The ./configure script gives the solution:
Quote:

error: tclConfig.sh not found - use the --with-tcl option
So use:
Code:

./configure --with-tcl=/usr/lib64
(and any other options you prefer...)

I just compiled it on my Slackware64-current and am dizzy from flying :D

The error is in the "configure.ac" file from upstream - they do not search for tclConfig.sh in the 64-bit library folder.

mlangdn 06-20-2009 10:16 AM

Thanks - I will try that later!

mlangdn 06-20-2009 01:44 PM

Well, it compiled, installed, then I heard the music, but nothing on the display except input not supported. On to google.

niels.horn 06-20-2009 03:53 PM

uhm, ok... that's a different kind of problem.
Here it worked from the start.

Do you have any special input device that may make it complain? I just have a standard keyboard (ps/2) + mouse (usb) here.

mlangdn 06-20-2009 04:26 PM

The same input for me, but I believe its related to the monitor and/or the nvidia driver. My monitor is a widescreen 1440x900 @ 70 mhz. I'm betting the problem is in there somewhere.

I'm at work now until 4:00 am CST. I will try again tomorrow.

Maybe the new xorg as well?

adriv 06-20-2009 04:36 PM

Quote:

Originally Posted by mlangdn (Post 3580843)
The same input for me, but I believe its related to the monitor and/or the nvidia driver. My monitor is a widescreen 1440x900 @ 70 mhz. I'm betting the problem is in there somewhere.

I'm at work now until 4:00 am CST. I will try again tomorrow.

Maybe the new xorg as well?

I recognize this (not on 64-bit, but on an earlier version of etracer).
It has to do with the default screensize. Change the settings in the etracer file in your /home/ and you'll be fine. :)

Edit/Update:
Installed etracer, checked (I've got a 1440x900 monitor as well) it and indeed, the default settings cause trouble. Modify ~/.etracer/options like this:
Code:

# x_resolution
#
# The horizontal size of the Tux Racer window
#
set x_resolution 1440

# y_resolution
#
# The vertical size of the Tux Racer window
#
set y_resolution 900


mlangdn 06-20-2009 06:49 PM

Thanks adriv! I'll try that in the morning. Kinda figured that may be the problem. That's the problem with work - not enough time for Slack(ing). :)

mlangdn 06-21-2009 04:42 AM

That worked! Edited and running. Its more difficult than the original tuxracer and a lot of fun.


All times are GMT -5. The time now is 09:31 AM.