LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Cannot boot with ext4 (http://www.linuxquestions.org/questions/slackware-14/cannot-boot-with-ext4-4175488699/)

charlie_lab 12-20-2013 12:26 PM

Cannot boot with ext4
 
Hello,

I installed 14.0 with a ext4 partition and lilo on the root partition.

After that I pointed Easybsd to where lilo can be found.
But after booting it's stops with this message :

ext3fs (sda1) Error: could not mount because of unsupported options.

I verified the downloaded iso and it's allright. The md5sum's are correct.

Roelof

yars 12-20-2013 01:34 PM

Please show your /etc/fstab, /etc/lilo.conf. Also which kernel do you use? To boot your installed system, boot from installation media, then after "boot:>" line type:
Code:

root=/dev/sda1 rdinit= ro
where /dev/sda1 is your root partition, and then press Enter. If it's does not work, you can execute a chroot into installed system:
First, boot from installation media, log in as root and then:
Code:

# mount /dev/sda1 /mnt
# for i in dev proc sys ; do mount --bind "$i" "/mnt/$i"; done
# chroot /mnt
# cat /etc/fstab
# cat /etc/lilo.conf
# ls -l /var/log/packages/kernel*


charlie_lab 12-20-2013 02:27 PM

Hello,

I have wrote them on paper.

fstab :
Code:

/dev/sda1    /            ext4 defaults      1  1
/dev/fdo    /mnt/floppy  auto noauto, owner  0  0
devpts      /dev/pts      devpts              0  0
proc        /dev/proc    proc defaults      0  0

relavant part of lilo.conf
Code:

image  /boot/vmlinuz
      root=/dev/sda1
      label=Linux
      readonly

kernelversion : 3.2.29

Roelof

yars 12-20-2013 06:28 PM

Your kernel is kernel-huge* package? Please check for this and also check for that kernel-modules package is in accord to the kernel package, i.e:
Code:

# ls -1 /var/log/packages/kernel-{huge,modules}-smp*
/var/log/packages/kernel-huge-smp-3.2.29_smp-i686-1
/var/log/packages/kernel-modules-smp-3.2.29_smp-i686-1

That's used on my 14.0 system. Also, maybe the your HDD is partitioned or formatted incorrectly? Please show:
Code:

# fdisk -l
# file -s /dev/sda
# file -s /dev/sda1

About
Code:

ext3fs (sda1) Error: could not mount because of unsupported options.
It's okay, i think the kernel tries to find a suitable module for filesystem. On my system I have:
Code:

[    1.725206] EXT3-fs (sda2): error: couldn't mount because of unsupported optional features (240)
[    1.727182] EXT2-fs (sda2): error: couldn't mount because of unsupported optional features (240)
[    1.748328] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)

As you see, I use the ext4 filesystem.

charlie_lab 12-21-2013 02:21 AM

Hello,

The file -s does not work on the install disk.

I noticed that first it seems to be stuck at checking for RAID arrays.
Then when it goes on I see the first, sometimes the second line ext2, ext3 but that took also ages.
Is there a way I can tell lilo not to check Raid and that the rootfs is ext4.

Wierdest thing is that 14.1 has not that problem.It boots very fine but then I cannot install Dropline Gnome.
The version is not released yet and I have no idea when that happens.

Roelof

yars 12-21-2013 09:18 PM

Hello,
Lilo does not support access to the kernel as a file on a filesystem at boot time, he does not depend on a filesystem. Lilo looks for kernel image on a first 0...1023 cylinders.
Can you provide a photo of screen when boot process is stopped? Currently I have no any ideas, sorry for that.
UPD: But you can make a 'file -s something' to work on the install disk with following commands:
Code:

# mkdir -p /mnt/dvd # just in case, by default /mnt/dvd is exist (but I could be wrong)
# mount -r /dev/sr0 /mnt/dvd # that is boot device that contain a boot media
# installpkg /mnt/dvd/slackware/a/file*txz


perbh 12-21-2013 10:24 PM

I hope the '/dev/fdo' in your fstab is a typo ...
I have seen strange behaviour with typo's there ...

yars 12-21-2013 11:21 PM

Quote:

I hope the '/dev/fdo' in your fstab is a typo ...
Maybe. But, this is a floppy. If you have a floppy drive then it's normal, otherwise you can comment out this line. But yes, between parameters auto, noauto the spacebar is not needed. But charlie_lab says he copied from the paper.

perbh 12-21-2013 11:42 PM

I was speaking of /dev/fdo instead of the correct /dev/fd0
And yes, I know its a floppy, but it comes immediate after the entry for sda1 ... it might have caused errors when reading through the fstab

charlie_lab 12-22-2013 07:13 AM

This one can be closed. Im giving up on it. It takes to many time.

Roelof

GNU/Linux 12-24-2013 12:05 AM

Code:

ext3fs (sda1) Error: could not mount because of unsupported options.
May be ext3 is expected instead of ext4?

gegechris99 12-24-2013 05:35 AM

Quote:

Originally Posted by charlie_lab (Post 5084601)
After that I pointed Easybsd to where lilo can be found.
But after booting it's stops with this message :


Do you mean Easybsd, the script to manage post installation of FreeBSD or EasyBCD the Windows utility to manage the Windows bootloader?

Anyway, it seems that Slackware is not the sole OS in your PC. Could you please describe what OS are installed and how Slackware is supposed to be booted?

If you have a dual-boot Windows 7/Vista - Slackware, you should consider reading this tutorial from Alien's Bob: Adding-linux-to-the-windows7-boot-menu/

colorpurple21859 12-24-2013 08:18 AM

I don't think easybsd will boot ext4 will have to use ext3 partition.


All times are GMT -5. The time now is 11:23 PM.