LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Cannot add Keyboard layouts with Slack 12 rc1 (http://www.linuxquestions.org/questions/slackware-14/cannot-add-keyboard-layouts-with-slack-12-rc1-565892/)

stelmed 07-01-2007 06:06 PM

Cannot add Keyboard layouts with Slack 12 rc1
 
Hello everybody,

I have successfully updated my system to 12 rc1. The only problem I 've come through is that I cannot add any keyboard layout from the KDE Control Center. The available layouts list seems to be empty.
Any ideas?

randomsel 07-01-2007 07:24 PM

Didn't know about kde keyboard layouts, I add keyboard layouts into my xorg.conf with xorgsetup...

Zmyrgel 07-01-2007 09:33 PM

Have you installed the kde-i18n language packages?

Ilgar 07-01-2007 09:37 PM

Quote:

Originally Posted by Zmyrgel
Have you installed the kde-i18n language packages?

Keyboard layouts should work without any i18n packages (it's an X11 feature, after all).

H_TeXMeX_H 07-01-2007 10:19 PM

For changing your keyboard layout inside xserver, I would use 'xorgsetup'. If you don't want to, just take a look inside '/etc/X11/xorg.conf', and look for a section like this:

Code:

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "XkbModel"  "pc101"
        Option      "XkbLayout"  "us(dvorak)"
EndSection

Notice the "XkbLayout" and after that "us(dvorak)", that's just my keyboard layout, replace it with yours.

Zmyrgel 07-02-2007 09:35 PM

Quote:

Originally Posted by Ilgar
Keyboard layouts should work without any i18n packages (it's an X11 feature, after all).

Ah, my mistake, I forgot the i18n packages only offer translations for KDE, not the layouts. I stand corrected.

stelmed 07-03-2007 04:23 PM

I finally managed to solve it by installing everything from the /x folder. I will now try to figure out which packages are necessary by uninstalling one package at a time.
Thanx for the help


All times are GMT -5. The time now is 09:04 AM.