LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-15-2010, 04:03 PM   #31
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,270

Rep: Reputation: Disabled

Quote:
Originally Posted by 2handband View Post
Think I get it now; I just hope I can remember how I've got everything set up. I installed this thing last summer...
Merely running "fdisk -l" will give a hint or two about what partitions were used for what. Look at partition sizes, and try to mount them somewhere (dismount them afterwards!) to peek at the contents.

Eric
 
Old 11-15-2010, 04:05 PM   #32
2handband
Member
 
Registered: Jan 2009
Location: Alexandria, Minnesota
Distribution: Slackware 13.1
Posts: 809

Original Poster
Rep: Reputation: 96
Quote:
Originally Posted by volkerdi View Post
Perhaps first things first... if you didn't have any idea how to make an initrd before, I'm going to step out on a limb and guess that you did not previously have one. So rather than consider the pros and cons of using an initrd versus using the huge kernel, probably we should start by getting you back where you were. So...

First, make sure that the new 2.6.35.7 kernel packages are installed, and make sure that /etc/lilo.conf is pointing to the new huge kernel in /boot (either by using the full filename, or by making sure if lilo.conf uses a symlink, that it points to the right kernel). Then run "lilo" as root, and you should be good to reboot without the disc.

Assuming that works, you can check out README.initrd in /usr/doc/mkinitrd[...] at your leisure.

Hope this helps.
Okay, I used Eric's instructions to mount my filesystem... good. The mkinitrd command didn't work, says no such file or directory... bad. So I checked out my lilo.conf file to see where it's pointing to. Here's what we've got:

Code:
image = /boot/vmlinuz
root = /dev/sda3
label = Linux
read-only
Is that what it's supposed to look like?
 
Old 11-15-2010, 04:09 PM   #33
2handband
Member
 
Registered: Jan 2009
Location: Alexandria, Minnesota
Distribution: Slackware 13.1
Posts: 809

Original Poster
Rep: Reputation: 96
Weird... there IS a mkinitrd_command_generator.sh file in the specified location. I wonder why the damn dumb machine is insisting it ain't there when I try to run the command?
 
Old 11-15-2010, 04:16 PM   #34
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,270

Rep: Reputation: Disabled
Quote:
Originally Posted by 2handband View Post
Okay, I used Eric's instructions to mount my filesystem... good. The mkinitrd command didn't work, says no such file or directory... bad. So I checked out my lilo.conf file to see where it's pointing to. Here's what we've got:

Code:
image = /boot/vmlinuz
root = /dev/sda3
label = Linux
read-only
Is that what it's supposed to look like?
That is the part for the huge kernel (not using an initrd). If that's all there is then you were not using an initrd after all.
Which is strange, because in order to use LVM you have to use an initrd (together with a "generic" kernel).

Eric
 
Old 11-15-2010, 04:21 PM   #35
2handband
Member
 
Registered: Jan 2009
Location: Alexandria, Minnesota
Distribution: Slackware 13.1
Posts: 809

Original Poster
Rep: Reputation: 96
Quote:
Originally Posted by Alien Bob View Post
That is the part for the huge kernel (not using an initrd). If that's all there is then you were not using an initrd after all.
Which is strange, because in order to use LVM you have to use an initrd (together with a "generic" kernel).

Eric
That IS odd, because I set this thing up from the word go with separate /usr, /tmp/, /var/, and /home partitions... all of which are in a volume named VG0. I know this because I just successfully mounted them as per your instructions.

What should I do next?
 
Old 11-15-2010, 04:24 PM   #36
2handband
Member
 
Registered: Jan 2009
Location: Alexandria, Minnesota
Distribution: Slackware 13.1
Posts: 809

Original Poster
Rep: Reputation: 96
By the way, how can I get out of this chroot jail and back into the boot disk's shell? It seems I must have mounted the wrong thing for /boot; the directory is empty. I'm going to need to get it mounted in order to do anything with lilo.conf.
 
Old 11-15-2010, 04:30 PM   #37
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,270

Rep: Reputation: Disabled
Quote:
Originally Posted by 2handband View Post
By the way, how can I get out of this chroot jail and back into the boot disk's shell? It seems I must have mounted the wrong thing for /boot; the directory is empty. I'm going to need to get it mounted in order to do anything with lilo.conf.
Just type "exit" ...

Eric
 
Old 11-15-2010, 04:34 PM   #38
2handband
Member
 
Registered: Jan 2009
Location: Alexandria, Minnesota
Distribution: Slackware 13.1
Posts: 809

Original Poster
Rep: Reputation: 96
Didn't work... I'm still in my computer's filesystem. This is not my day...
 
Old 11-15-2010, 05:11 PM   #39
2handband
Member
 
Registered: Jan 2009
Location: Alexandria, Minnesota
Distribution: Slackware 13.1
Posts: 809

Original Poster
Rep: Reputation: 96
Okay, I managed to get out and double-check, and I DID mount the correct partition for /boot. So why the heck is the directory showing up as being empty? I can access it fine from the install disk shell, but not from inside the chroot.
 
Old 11-15-2010, 05:23 PM   #40
2handband
Member
 
Registered: Jan 2009
Location: Alexandria, Minnesota
Distribution: Slackware 13.1
Posts: 809

Original Poster
Rep: Reputation: 96
Okay, fixed that bit... I can now access /boot from within the chroot. What should I do next?
 
Old 11-15-2010, 05:43 PM   #41
2handband
Member
 
Registered: Jan 2009
Location: Alexandria, Minnesota
Distribution: Slackware 13.1
Posts: 809

Original Poster
Rep: Reputation: 96
I think I've gone a bit further on my own... I modified the lilo.conf file to comply with the instructions for using initrd here:

ftp://ftp.osuosl.org/pub/slackware/s.../README.initrd

However, trying to run mkinitrd using the command you gave me yields the following:

Code:
$( /usr/share/mkinitrd/mkinitrd_command_generator.sh -r )
sh: Modules: command not found
 
Old 11-15-2010, 07:23 PM   #42
2handband
Member
 
Registered: Jan 2009
Location: Alexandria, Minnesota
Distribution: Slackware 13.1
Posts: 809

Original Poster
Rep: Reputation: 96
After doing some additional research I ran the following command:

Code:
mkinitrd -c -k 2.6.35.7 -m ext4 -r /dev/sda3
It ran okay, so I ran lilo and attempted a reboot. Got:

Code:
kernel panic - not syncing: attempted to kill init!
Obviously I do not understand how mkinitdr works. Could somebody tell me what I'm doing wrong?
 
Old 11-15-2010, 11:47 PM   #43
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,441

Rep: Reputation: 851Reputation: 851Reputation: 851Reputation: 851Reputation: 851Reputation: 851Reputation: 851
The ext4 file system uses some additional modules.
Try 'mkinitrd -c -k 2.6.35.7 -f ext4 -r /dev/sda3 -m ext4:jbd2:mbcache -o /boot/initrd.gz'
If you need support for usb devices (e.g. mouse, keyboard) then add ':usbhid:ehci-hcd:uhci-hcd' to the -m string
 
Old 11-16-2010, 12:15 AM   #44
Squall90
Member
 
Registered: Oct 2009
Distribution: Currently several distros :S
Posts: 148

Rep: Reputation: 29
I uses ext2 for my boot partition and ext4 for the others. I never add anything else than ext2 and ext4 support in the initrd and it worked every time.

Are there any other errors beside the kernel panic?
 
Old 11-16-2010, 02:50 AM   #45
zhoun
Member
 
Registered: Oct 2007
Location: anywhere
Distribution: slackware64 current & win7 64 on thinkpad X61
Posts: 104

Rep: Reputation: 18
I got the same problems after upgrade aaa_elflibs.
The lvm partitions can't be mounted.

The solution was: reinstall the e2fsprogs and lvm packages, then reboot.

Last edited by zhoun; 11-16-2010 at 02:52 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to see shares on samba server - no authentication access desired (open access) neoelf Linux - Networking 1 06-14-2009 03:18 PM
How to access Access root(/) hard drive attached in Windows XP machine farrukhndm Linux - Software 2 07-29-2008 12:52 PM
Debian Woody: Can't access internet through router, but can access network computers marales314 Linux - Networking 3 06-09-2006 12:33 PM
WIFI WLAN / Cannot access internet but can access the router configuration page?SUSE thomas939 Linux - Wireless Networking 12 12-13-2005 10:28 AM
Samba access by Windows users locking out directory access with Konqueror harry_fine Suse/Novell 1 12-18-2004 05:33 AM


All times are GMT -5. The time now is 11:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration