LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-09-2008, 06:45 PM   #1
IamSauce
LQ Newbie
 
Registered: Mar 2008
Posts: 2

Rep: Reputation: 0
can ping router, can't ping internet


Hi guys,

Judging from my forum search, you get this question a lot

I just installed Slackware 12. I'm finally able to ping my router, but I can't ping outside my LAN.

My ifconfig says:

Link encap:Ethernet HWaddr 00:13:20:36:A1:72
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0

I'm receiving packets and sending packets, so I don't think this is a driver issue.

Running route reveals:

localnet | * | 255.255.255.0 |U | 0| 0| 0| eth0
loopback | * | 255.0.0.0 | U | 0 |0 |0 |lo
default |192.168.1.1 | 0.0.0.0 | UG| 0| 0| 0| eth0

I'm at a loss for what to do. I can't sleep. I can't eat. When I close my eyes, shell scripted text scrolls across my vision. This is really tearing me apart.

Also, I need to modprobe e100 to load my intel NIC card driver everytime I start up. How do I make it so this loads automatically?

Any help is appreciated. Sorry I can't copy and paste my info for all of you.
 
Old 03-09-2008, 07:00 PM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Try changing your mask to 255.255.255.255.
You can always add the modprobe line for your NIC to the /etc/rc.d/rc.modules script so that the NIC is configured at boot.
 
Old 03-09-2008, 07:18 PM   #3
IamSauce
LQ Newbie
 
Registered: Mar 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Wow! Thank you very much. That worked perfectly. You've made my week a lot easier
 
Old 03-09-2008, 07:27 PM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
Glad it worked!
And welcome to LQ!

PS - If you are adding a line to your rc.modules script, remember that the script name will be rc.modules-<kernel version>.
 
Old 03-09-2008, 11:50 PM   #5
symatic
Member
 
Registered: May 2007
Distribution: Slackware
Posts: 242

Rep: Reputation: 32
You may also want to know this. the e100 module is blacklisted /etc/modeprobe.d/blacklist

Code:
# Alternate Intel EtherExpress Pro/100 support driver.  List it
# here so it won't conflict with an already-loaded eepro100 module.
blacklist e100
 
Old 03-10-2008, 03:01 PM   #6
MarcusMoeller
Member
 
Registered: Nov 2002
Location: Germany
Distribution: GNU/Linux
Posts: 33

Rep: Reputation: 15
broadcast

I REALLY won't suggest to set the Subnet Mask to (255.255.255.255) which is a single host definition.

About the only time this mask could be useful is defining a loopback, an IP device that can only talk to itself.

Best Regards
Marcus

Last edited by MarcusMoeller; 03-10-2008 at 04:09 PM.
 
Old 03-11-2008, 07:03 AM   #7
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,379

Rep: Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824Reputation: 824
@Marcus
You are correct. Thanks for so politely pointing out my error.

Perhaps the OP had another problem that went away after editing the configuration.
 
  


Reply

Tags
e100, network, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No internet/but I can ping router acidblue Slackware 9 03-06-2009 07:24 PM
able to ping router but no internet madhacker Linux - Networking 4 02-25-2006 12:13 PM
LAN/ADSL Router ping working but DNS ping fails R N Ghosh Linux - Networking 1 01-13-2006 07:44 AM
PPP establish can ping the gateway router but unable to ping the host deepalalla Linux - Networking 0 11-18-2004 09:10 AM
Internet Ping AND router? garr0323 Linux - Networking 1 03-09-2004 11:30 AM


All times are GMT -5. The time now is 05:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration