LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   can not play audio CD (http://www.linuxquestions.org/questions/slackware-14/can-not-play-audio-cd-400202/)

hottdogg 01-06-2006 08:35 AM

can not play audio CD
 
I use slackware 10.2.
I want to play audio cd but mount said that it can't determine filesystem type. But i can mount data or installation cd.
Here's my /etc/fstab
Code:

/dev/hdb1        /                ext3        defaults        1  1
/dev/hda5        /backup          ext3        defaults        1  2
/dev/hda6        /var            ext3        defaults        1  2
/dev/hda7        /tmp            ext3        defaults        1  2
/dev/hda8        /wwwdocs        ext3        defaults        1  2
/dev/hda10        none                  swap              defaults              0  0
/dev/hdb5        /home            ext3        defaults        1  2
/dev/hdb6        /bak_wwwdocs    ext3        defaults        1  2
/dev/hda2        /winshared      vfat        defaults        1  0
/dev/cdrom0      /mnt/cdrom0      auto    noauto,user,ro,unhide  0  0
/dev/cdrom1        /mnt/cdrom1            auto    noauto,user,ro,unhide  0  0
/dev/fd0        /mnt/floppy      auto        noauto,owner    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0

And how to auto mount/unmount that everytime I insert the cd, I don't have to type mount /dev/cd***

using auto on the 4th column in fstab results dmesg complain can not mount cd every boot.

simcox1 01-06-2006 08:44 AM

You don't need to mount an audio cd. It should just play automatically with xine or whatever. As long as sound is configured.

Xian 01-06-2006 09:46 AM

If using KDE/Gnome you should be able to configure the Desktop settings to show a mounted disk automagically as an icon, but in any case you certainly don't need to manually mount the drive. The CD player will access the tunes and play them without need for any further intervention.

187807 01-06-2006 08:45 PM

Basically, from what I have read, a 'regular' audio CD (like you would burn from WAV tracks or might buy in the store or have at home) does NOT have a filesystem on it.

'mount' mounts, well, from the man page:
Code:

MOUNT(8)                    Linux Programmer's Manual                  MOUNT(8)

NAME
      mount - mount a file system

'mount' won't mount a straight audio CD because there is no filesystem.

Now SOME CDs you might buy now might have some filesystem on them (like mixed data and audio where some CDs aren't pure audio anymore but have data stuff on them too, like movies or extra information content you can view on a PC).

As mentioned by others, cd-playing applications in linux will access the audio CD directly via hardware (as they have to). Also as mentioned, if sound is configured correctly and the audio applications are configured correctly (typically little or no configuration is necessary...if you hear sounds from speakers then the cd-playing application should play the audio cd without problem most of the time).

Hope that helped some. And, don't feel bad at all, I had the VERY same question at one point. It confused the heck out of me, too :)

Regarding auto-mount, I recognize that you asked but do not have any experience with that.

Alien_Hominid 01-07-2006 02:52 PM

If you didn't understand what was said, start for example totem > Movie > Play Disc.

P.S.As well, your cds will be auto-mounted if your kernel is 2.6. Automounting is enabled by hal feature.

hottdogg 01-16-2006 09:43 AM

I use kernel 2.4.31.
xine, mplayer intentionally uninstalled.
if you haven't noticed, I use 2 drives. one is cd writer and the other is plain cd rom.

audio CD just can't play.Period. It seems in my box there's no autorun for audio cd.

app: ksCD. result: message error saying about that i don't have permission.

app:xmms.
trying with open directory. result: nothing happen.


can you guys give me advice to change my /etc/fstab maybe?
or anything else.

gosh, it's been 2 month since slackware installed but my slackware still in the configuring-tweaking mode. Am I the only one who have this kind of problem?
:cry:

simcox1 01-16-2006 10:09 AM

Add yourself to the group 'cdrom'. It will give you the permissions.

su to root in a console and type:

emacs /etc/group

or use any other text editor, and where you see the entry:

cdrom::19:

add your username. eg:

cdrom::19:bob

add any other users to the group seperated with a comma.

cdrom::19:bob,jim,jon

Then, to check which groups you are a member of, as normal user, in a console type:

groups

hottdogg 02-01-2006 08:44 AM

Well, before i did follow your steps,
checking group
$groups already contains 'cdrom'

but i followed your steps anyway
Quote:

cdrom::19:

add your username. eg:

cdrom::19:bob

add any other users to the group seperated with a comma.

cdrom::19:bob,jim,jon
Still can't play audio CD. There's gotta be some missing point here.
I know my linux should can play audio CD.

BTW I just changed my cdrom to dvdrom. I think it's a snap. Detected by my slackware. I hope that doesn't add to the problem.

here's my
$dmesg|grep hd
if this matter.
Code:

ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xd808-0xd80f, BIOS settings: hdc:DMA, hdd:DMA
hda: Maxtor 6E040L0, ATA DISK drive
hdb: ST340810A, ATA DISK drive
hdc: LITE-ON CD-RW SOHR-5238S, ATAPI CD/DVD-ROM drive
hdd: ASUS DVD-E616A, ATAPI CD/DVD-ROM drive
hda: attached ide-disk driver.
hda: host protected area => 1
hda: 80293248 sectors (41110 MB) w/2048KiB Cache, CHS=4998/255/63, UDMA(33)
hdb: attached ide-disk driver.
hdb: host protected area => 1
hdb: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63, UDMA(33)
hdc: attached ide-cdrom driver.
hdc: ATAPI 52X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
hdd: attached ide-cdrom driver.
hdd: ATAPI 48X DVD-ROM drive, 2048kB Cache, UDMA(33)
 hda: hda1 hda2 hda3 < hda5 hda6 hda7 hda8 > hda4
 hda4: <netbsd: hda9 hda10 hda11 >
 hdb: hdb1 hdb2 < hdb5 hdb6 hdb7 hdb8 > hdb3

Plz help...

simcox1 02-01-2006 09:43 AM

Does 'groups' say audio as well.

pdw_hu 02-01-2006 03:07 PM

I think your problem isn't software related. Back when i used XMMS for music playing (now it's cplay) i had to check "digital audio extraction" in the options of the cdplayer plugin to make it work, because my cdrom and the soundcard wasn't connected with a 'audio' (or whatever) cable which is needed for cdplaying.

hottdogg 02-26-2006 11:30 PM

$ groups
users cdrom floppy audio video

still can't play from either dvdrom or cd writer.

Ok, here's my new /etc/fstab snippet
Code:

/dev/cdrom0      /mnt/cdrom0      auto    noauto,user,ro,unhide  0  0
/dev/hdd        /mnt/dvdrom          auto    noauto,user,ro,unhide  0  0

Oh! about the cd-in analogue cable that connect between cdrom(cd writer, for my case) and sound card? I have my own problem with that.
See, my cd writer has earphone input on the front panel, my dvd rom doesn't. I connect the cable to cd writer instead to dvd rom. But even I can't listen cd from earphone (no sound) in windows XP which I should be able to because of that cable. Through speaker only the cd would sound.

Anyway, I tried plug the cable connector with different configuration(as I don't know which the positive/negative side of the cable and cd drive and sound card ). BUt still no result whatsoever in linux and xp.

IMO, cd-in analogue cable doesn't effect on my current problem. That cable thing is another problem. Set that aside first.

CMIWW.

gbonvehi 02-27-2006 12:37 AM

Check their permissions:
Code:

ls -l /dev/cdrom0 && ls -l /dev/hdd
Probably cdrom0 is a symlink to the right device. Depends on the version you're using they sometimes belong to disk group.

XMMS has an option on the CD input plugin to use digital extraction of the sound instead of using default analog (the cable is needed for it).

insaneavocado 02-28-2006 05:06 PM

I have had the same problem... What I did (and it might not be considered a good idea) is I went to the device in /dev/ that was my cdrom as root and gave read permissions to everyone (chmod +r /dev/<your device>) after that I was able to play CDs... but again; that may not be a good idea and I just don't know it (akin to working as root all the time).

mustangfanatic01 03-08-2006 05:47 AM

Quote:

Originally Posted by pdw_hu
I think your problem isn't software related. Back when i used XMMS for music playing (now it's cplay) i had to check "digital audio extraction" in the options of the cdplayer plugin to make it work, because my cdrom and the soundcard wasn't connected with a 'audio' (or whatever) cable which is needed for cdplaying.

That was the fix I've been searching for :)

pdw_hu 03-08-2006 03:35 PM

Your welcome :)


All times are GMT -5. The time now is 07:24 PM.