LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Can not get XDMCP to work on 13.37 (http://www.linuxquestions.org/questions/slackware-14/can-not-get-xdmcp-to-work-on-13-37-a-918941/)

damgar 12-15-2011 02:50 PM

Can not get XDMCP to work on 13.37
 
I have a machine running 13.37 and kde 4.7.2. I have followed all the usual steps to get xdmcp going as best as I can remember and followed several how-to's including Eric's. for some reason I am unable to get an XDMCP login from GDM on 13.0 laptop, from a terminal with the usual
Code:

X :1 -query hostname
and mobaxterm on the same machine fails to see an XDMCP server as well. I'm not real sure where to start testing and looking for the problem and don't want to go will-nilly editing config files.

Any help is appreciated.

SCerovec 12-16-2011 08:04 AM

damgar,
a) It would be easier if You where using either the default packages on a 13.37 ("vanilla") and get it working.
b) And get help until You manage
c) And upgrade from there (a running config), than to expect anyone follow Your package choice just to be able to reproduce Your problem?

I know this helps little if any, but I usually oversee such things and later do step "backwards" few steps to find I should have done so in the first place?
:)
Best regards,
Stevan C.

trist007 12-17-2011 03:25 PM

A good first step would be to make sure xdm is listening on the server machine. Login to the server and run
Code:

netstat -plnt
See if you see 0.0.0.0:6000 that is if X is running on :0
If is then, then see if you can reach it from your client.

From you client computer run this
Code:

nc -v hostname 6000
If it says connected then that's a good sign and the next step would be to look at xdm server configuration.

damgar 12-17-2011 07:40 PM

I got it working, but it was by setting /etc/hosts on both machines. I wasn't trying to ever connect via hostname, but I'm not sure why that is?

pino_otto 05-20-2012 09:21 PM

Quote:

I got it working, but it was by setting /etc/hosts on both machines. I wasn't trying to ever connect via hostname, but I'm not sure why that is?
I have the same problem, can you explain what does "setting /etc/hosts on both machines" mean?

Can you give an example?

SCerovec 05-21-2012 09:59 AM

Quote:

Originally Posted by trist007 (Post 4552585)
A good first step would be to make sure xdm is listening on the server machine. Login to the server and run
Code:

netstat -plnt
See if you see 0.0.0.0:6000 that is if X is running on :0
If is then, then see if you can reach it from your client.

From you client computer run this
Code:

nc -v hostname 6000
If it says connected then that's a good sign and the next step would be to look at xdm server configuration.

the upper command is to be given on the machine that has the X running we want to connect to ("Serving X")
The lower command is to be given on the machine we want to connect from ("Client X"),
but the word "hostname" is to be replaced with either the "Serving X"s IP or DNS-name
The XDCP (is this name right?) is usually restrictive "out of the box" on Slackware, and maybe a FQDN might be needed:
Quote:

1. nc -v 192.168.1.2 6000
2. nc -v ithildin 6000
3. nc -v ithildin.bogous.lan 6000
hope this sheds some light on the issue?
in the later case You need to make up Your both machine /etc/hosts file to reflect the topology of Your particular network:
file:/etc/hosts
Quote:

#
# hosts This file describes a number of hostname-to-address
# mappings for the TCP/IP subsystem. It is mostly
# used at boot time, when no name servers are running.
# On small systems, this file can be used instead of a
# "named" name server. Just add the names, addresses
# and any aliases to this file...
#
# By the way, Arnt Gulbrandsen <agulbra@nvg.unit.no> says that 127.0.0.1
# should NEVER be named with the name of the machine. It causes problems
# for some (stupid) programs, irc and reputedly talk. :^)
#

# For loopbacking.
127.0.0.1 localhost
127.0.0.1 <look below for this!!!>.bogous.lan <look left!>

#our "client X" host
192.168.1.1 rohan.bogous.lan rohan
#our "serving X" host
192.168.1.2 ithildin.bogous.lan ithildin

# End of hosts.

The marked entry will most probably be already there on Your machine(s) so You should take note of it, and lie it as is :)
The below is an illustration only of how a working hosts file might look, it was never tested (I wrote and edited quite few of them, and over quite a while, so I'm just comfortable it is probably correct) so I won't guarantee (GPL3 applies), but it is a good file IMHO.
Take note of the space separation and only full IP allowed
"#" denotes comment lines (not affecting DNS)

The file is checked by ping:
Code:

ping -c4 ithildin
ping -c4 ithildin.bogous.lan

for each IP and hostname used ;)

Best regards,
Stevan C.

pino_otto 05-22-2012 12:16 AM

Yeappa! Yeappa!

It works!

Thanks, SCerovec.

It was the problem of setting the IP addresses and hostnames in the /etc/hosts of both machines.
One machine (the client) is windows xp with mobaxterm.

SCerovec 05-22-2012 04:05 AM

Yeappa! Yeappa! to You too buddy
:)
You are welcome (glad You made it)!
Best regards,
Stevan C.


All times are GMT -5. The time now is 07:04 AM.