LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-13-2006, 03:10 PM   #1
Ellops
Member
 
Registered: Nov 2005
Location: ath.gr
Distribution: Slackware 11.0 / 2.6.19.1 /Linux Mint
Posts: 124

Rep: Reputation: 15
Red face Can't switch between keybord layouts...


Hi there.

I've setup my slack to support my language, but I cannot switch between layouts using the key combination (only by clicking on the flag on the taskbar...)

Code:
 Option         "XkbLayout" "us+gr"(i ve also tried with ',' instead of '+'and 'el' instead of 'gr'
 Option         "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
I ve done everything i used to do for years, but now it ain't working...

Am I missing something????
 
Old 04-13-2006, 03:12 PM   #2
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
It doesn't work for me either so I use setxkbmap lng.
 
Old 04-13-2006, 03:20 PM   #3
Ellops
Member
 
Registered: Nov 2005
Location: ath.gr
Distribution: Slackware 11.0 / 2.6.19.1 /Linux Mint
Posts: 124

Original Poster
Rep: Reputation: 15
but it used to work for me..
for 10.2...

I can't figure out why it doesn't now... *scratch*
 
Old 04-13-2006, 03:23 PM   #4
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
I'm using xorg 6.8.2 (not current, as you see).
 
Old 04-13-2006, 03:32 PM   #5
Ellops
Member
 
Registered: Nov 2005
Location: ath.gr
Distribution: Slackware 11.0 / 2.6.19.1 /Linux Mint
Posts: 124

Original Poster
Rep: Reputation: 15
so do I...
 
Old 04-14-2006, 06:27 AM   #6
IceChant
Member
 
Registered: Jan 2006
Location: Israel
Distribution: Windows Xp, Slackware
Posts: 316
Blog Entries: 3

Rep: Reputation: 30
You use KDE ? I got same problem with KDE 3.5.2 so I setted switch in the KDE CC for the rest of the DE or WM it works fine.
 
Old 04-15-2006, 01:19 AM   #7
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Or if you use gnome, you could add keyboard changer box into the panel and change it like in windows. Gnome uses setxkbmap, while KDE (as I know) uses its own fonts.

Last edited by Alien_Hominid; 04-15-2006 at 03:41 AM.
 
Old 04-15-2006, 01:42 AM   #8
hackobacko
LQ Newbie
 
Registered: Apr 2006
Posts: 17

Rep: Reputation: 0
the same problem for me

I searched alot of times on how to do that but i didn't find asolution
I guess this is the most difficult problem I've ever met since searching results many confusing results .

you may check this how to and please tell me if you found it useul because I got confused reading it

http://tldp.org/HOWTO/Intkeyb/
 
Old 04-15-2006, 01:42 AM   #9
hackobacko
LQ Newbie
 
Registered: Apr 2006
Posts: 17

Rep: Reputation: 0
also check that :

http://hektor.umcs.lublin.pl/~mikosm...youts-xkb.html

Last edited by hackobacko; 04-15-2006 at 01:44 AM.
 
Old 04-15-2006, 05:48 AM   #10
hackobacko
LQ Newbie
 
Registered: Apr 2006
Posts: 17

Rep: Reputation: 0
look man there's still ahope

disable xkdb from control center "disable lay out options "

then add the line you mentioned above then to xorg.conf (you already added it ) then

restart x or even make totally restart

then you will be able to change layouts by alt+shift (but without aflag applet below )

in cas you want to keep xkdb , try some other layout options like alt+ctrol+space
it may work .

but I also still want asolution for xkdb
 
Old 04-15-2006, 06:23 AM   #11
Ellops
Member
 
Registered: Nov 2005
Location: ath.gr
Distribution: Slackware 11.0 / 2.6.19.1 /Linux Mint
Posts: 124

Original Poster
Rep: Reputation: 15
@IceChant I use KDE 3.5.1, but it didn't work for 3.4.2, as well. The strange is that it used to work...
Since the last time that worked, if I remember well, I ve changed my keybord with a slightely older, could be this??

hackobacko Ive already tried this but... nothing..
 
Old 04-15-2006, 03:42 PM   #12
hackobacko
LQ Newbie
 
Registered: Apr 2006
Posts: 17

Rep: Reputation: 0
It does working man , just disable xkdb and do arestart for x

this is apart of my xorg.conf "input devices "
Code:
# If you'd like to switch the positions of your capslock and
# control keys, use:
#    Option "XkbOptions"  "ctrl:swapcaps"
# These are the default XKB settings for Xorg
    Option "XkbRules"    "xorg"
    Option "XkbModel"    "pc105"
    Option "XkbLayout"   "us,ar(digits)"
    Option "XkbVariant"  ""
   # Option "XkbOptions"  "grp:alt_shift_togg,legrp_led:scroll"
    Option "XkbDisable"
    Identifier     "Keyboard1"
    Driver         "kbd"
    Option         "AutoRepeat" "500 30"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    Option         "XkbRules" "xorg"
   Option         "XkbModel" "pc105"
    Option         "XkbLayout" "us,ar(digits)"
   Option         "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
EndSection
 
Old 04-16-2006, 04:25 AM   #13
Ellops
Member
 
Registered: Nov 2005
Location: ath.gr
Distribution: Slackware 11.0 / 2.6.19.1 /Linux Mint
Posts: 124

Original Poster
Rep: Reputation: 15
Daamat! I must be blind,
I read "disablexkb" (something I'd already done)

Thanks a lot hackobacko!
 
Old 04-16-2006, 06:59 AM   #14
hackobacko
LQ Newbie
 
Registered: Apr 2006
Posts: 17

Rep: Reputation: 0
you are welcome , but I read also many times if you want to activate it from xkdb you have to selct your language as alayout then check
include latin groub
but I don't know where is this option because I edit many files and deleted most other layout options so is it alay out option or waht ?
 
Old 04-16-2006, 10:28 AM   #15
Ellops
Member
 
Registered: Nov 2005
Location: ath.gr
Distribution: Slackware 11.0 / 2.6.19.1 /Linux Mint
Posts: 124

Original Poster
Rep: Reputation: 15
In control center->keybordlayaout u check the "include latin layout" box.
Is this what u mean?

It didn't work for me, however.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless confert keybord juggalostll7 Linux - Software 1 09-06-2006 06:30 PM
Keybord not working ValidiusMaximus Linux - Laptop and Netbook 0 01-05-2005 04:07 PM
Keybord layer Getafix Linux - Newbie 0 10-11-2004 08:28 AM
read key from keybord in c arthur_mueller Programming 6 03-13-2004 05:18 AM
the windows key on the keybord RIgimp75 Slackware 1 09-02-2003 09:43 PM


All times are GMT -5. The time now is 07:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration