LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-21-2006, 10:54 AM   #1
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Rep: Reputation: 35
X-6.9.0 problems in Slack11 (like switching to virtual terminals, language change)


After I booted to X I can't switch back to virtual terminals.
Thanks.

Last edited by kornerr; 10-21-2006 at 11:44 AM.
 
Old 10-21-2006, 11:27 AM   #2
uselpa
Senior Member
 
Registered: Oct 2004
Location: Luxemburg
Distribution: Slackware, OS X
Posts: 1,507

Rep: Reputation: 46
I had the same issue when upgrading from 10.2 to 11. It turned out to be a X.org change; I am using a swiss-french keyboard, and in /etc/X11/xorg.conf, I now have to use:
Code:
Option     "XkbLayout"     "ch"
Option     "XkbVariant"    "fr"
whereas in the previous version it was simply
Code:
Option     "XkbLayout"     "fr_CH"
.
So I'd suggest you look at that part of xorg.conf.
What keyboard layout are you using?
 
Old 10-21-2006, 11:43 AM   #3
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Original Poster
Rep: Reputation: 35
I had:
Code:
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "geniuscomfy2"
    Option "XkbLayout"  "en_US,ru(winkeys)"
    Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
I modified it according to how you did it:
Code:
    Option "XkbRules"   "xorg"
    Option "XkbModel"   "geniuscomfy2"
    Option "XkbLayout"  "en"
    Option "XkbVariant" "ru(winkeys)"
    Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll"
but I still can't switch to VTs.
And moreover, I can't switch layout!!!
Thanks.
 
Old 10-21-2006, 12:48 PM   #4
kornerr
Member
 
Registered: Dec 2004
Location: Russia, Siberia, Kemerovo
Distribution: Slackware
Posts: 893

Original Poster
Rep: Reputation: 35
Ok, the problem was in "en_US", now it must be "us".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CTRL+ALT+F* Terminals don't work sekelsenmat Mandriva 3 11-26-2005 04:46 AM
Accessing Terminals in MEPIS. (Ctrl + Alt +F? not working) Eerath MEPIS 2 10-27-2005 11:51 AM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 09:13 AM
Avoid X to switch virtual terminals when starting jribot Linux - General 1 01-17-2005 03:40 AM
terminals & Ctrl+Alt+F1 salparadise Linux - General 2 02-19-2004 07:24 AM


All times are GMT -5. The time now is 03:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration