LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-12-2013, 09:46 AM   #1
PrinceCruise
Member
 
Registered: Aug 2009
Location: /Universe/Earth/India/Pune
Distribution: Slackware64 14.1/Current, CentOS 6.5/7.0
Posts: 716

Rep: Reputation: Disabled
Can't set static IP to Slackware VM in Virtualbox


Hello,

I've installed and set up a Slackware 14.0 VM in Virtualbox(4.2).
The Network setting is NAT and host-only-adapter (Vboxnet0). I have set the static IP address 192.168.56.101 to eth3 editing the /etc/rc.d/rc.inet1.conf file. Snippets of the file (Typed manually as the shared clipboard is also not working, so can't copy paste):-

Quote:
# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="no"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]="192.168.56.101"
NETMASK[3]="255.255.255.0"
USE_DHCP[3]="no"
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""
I've restarted inetd daemon, even rebooted the system, still the ifconfig doesn't show the IP address associated to eth3. Can't show the guest's ifconfig -a output here as copt paste is not working.

The local ifconfig o/p for vboxnet0 is -

Quote:
vboxnet0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.56.1 netmask 255.255.255.0 broadcast 192.168.56.255
inet6 fe80::800:27ff:fe00:0 prefixlen 64 scopeid 0x20<link>
ether 0a:00:27:00:00:00 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 129 bytes 5634 (5.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
I want to achieve simply ssh connectivity from guest to host and vice versa. I have two other VMs, CentOS 5 and 6 where this works fine.
I've searched a lot but didn't find something which could address the exact issue.Let me know what I'm missing here.

Regards.
 
Old 03-12-2013, 10:34 AM   #2
tuxbg
Member
 
Registered: Sep 2012
Location: Bulgaria,Varna
Distribution: Slackware64
Posts: 248

Rep: Reputation: Disabled
Did you enable remote control in VirtualBox and choose the port?

pp
I dont think its posiblle to get static ip adress in vm
 
Old 03-12-2013, 10:43 AM   #3
PrinceCruise
Member
 
Registered: Aug 2009
Location: /Universe/Earth/India/Pune
Distribution: Slackware64 14.1/Current, CentOS 6.5/7.0
Posts: 716

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by tuxbg View Post
Did you enable remote control in VirtualBox and choose the port?

pp
I dont think its posiblle to get static ip adress in vm
The remote display has nothing to do with the static or dynamic IP address assignment and I'm not using ip port forwarding so no need to choose the port from the advance networking section.

And all my CentOS VMs use static IPs in Virtualbox, the issue is only with Slackware VM.

Regards.
 
Old 03-12-2013, 11:06 AM   #4
NeoMetal
Member
 
Registered: Aug 2004
Location: MD
Distribution: Slackware
Posts: 101

Rep: Reputation: 18
You don't have networkmanager or wicd enabled by accident and trying to grab a dynamic IP do you? Make sure /etc/rc.d/rc.networkmanager isn't executable


(Or is the issue that the interface is not being assigned an address at all? )

Last edited by NeoMetal; 03-12-2013 at 11:08 AM.
 
Old 03-12-2013, 11:14 AM   #5
PrinceCruise
Member
 
Registered: Aug 2009
Location: /Universe/Earth/India/Pune
Distribution: Slackware64 14.1/Current, CentOS 6.5/7.0
Posts: 716

Original Poster
Rep: Reputation: Disabled
No, I checked that beforehand. Anyways I found the solution myself and its kinda weird. Sharing in case.

The default adapter for NAT and host-only-networking AMD PCNet FAST III turned out to be the culprit. I dug the dmesg output of the freshly booted VM and realized somethings wrong with this adapter type. Changed it to the Intel PRO/1000 MT Desktop (82540EM) and VOILA! eth3 has the static IP assigned now. Can connect from host using hostname and IP and the simple mission is accomplished.


Regards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I set up Slackware 9.1 to use DHCP with a static DNS? h00chman Linux - Newbie 2 12-18-2012 09:30 AM
Move Slackware guest from a Slackware hosted Virtualbox to Windows hosted Virtualbox? damgar Slackware 1 08-07-2012 11:28 PM
[SOLVED] Problem on assigning static ip address.. RHEL 5 as guest OS on Virtualbox odessy Linux - Newbie 4 08-28-2009 11:51 AM
How to set static ip address in slackware vitalstrike82 Linux - Networking 2 05-23-2009 01:56 PM
FC2 Overriding static if in favor of dhcp system set for static pkraus109 Linux - Networking 8 09-21-2004 11:13 AM


All times are GMT -5. The time now is 06:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration