LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 11-12-2006, 05:14 PM   #1
ceashton
Member
 
Registered: Nov 2006
Distribution: Slackware 12.2
Posts: 36

Rep: Reputation: 15
Can't play audio CD in slackware


Hi Everyone,

I have a problem with my CD player, in that I am not able to play audio CDs. Other CD and sound functions seem to work just fine. I have read through some of the posts that seem to have had a similar problem and tried most of the advice they contain, but the problem still persists. I will outline the problem in a little more detail and the steps I have taken to try to attempt to remedy the situation, in the hope that you will offer your advice.

I can mount data CDs both manually and through auto mounting in /etc/fstab. My fstab file contains the lines:

Code:
#/dev/cdrom       /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/cdrom       /mnt/cdrom       auto        noauto,user,ro  0   0
I believe that I am using the correct block device as I can mount data CDs. In any case I show the relevant section from /dev:

Code:
chris@dinosaur:~$ ls -l /dev/cdrom && ls -l /dev/dvd && ls -l /dev/hdc
lrwxrwxrwx 1 root root 8 2006-10-22 19:08 /dev/cdrom -> /dev/hdc
lrwxrwxrwx 1 root root 8 2006-10-22 19:08 /dev/dvd -> /dev/hdc
brw-rw---- 1 root disk 22, 0 2002-06-09 20:27 /dev/hdc
I've tried changing the permissions of /dev/hdc to 777, but this doesn't help. Originally I wasn't a member of the "disk" group, so I added myself to this:

Code:
chris@dinosaur:~$ groups chris
chris : users disk floppy audio video cdrom
I've tried playing mp3s and wavs in xmms and they play fine now I've configured sound with alsamixer. And now we get to my specific problem. If I run the command:

Code:
chris@dinosaur:~$ xmms /dev/hdc
xmms opens and prompts me to play files from /dev. If I go to /dev/hdc and play, nothing happens. Contrast this with if I try to play the CD as root (using the same command), where xmms prompts me to play files from /dev/hdc. If I select some files, then xmms plays the songs but with no sound. I guess root gets no sound as root does not belonging to the appropriate groups:

Code:
chris@dinosaur:~$ groups root
root : root bin daemon sys adm disk wheel floppy
Root not being able to play sound isn't a problem, I just use this example to show that I am pointing to the correct device. I believe that music players act independently of fstab and so I've checked in xmms>options>preferencies>inputplugins>CD Audio Player 1.2.10 and checked it is configured for device=/dev/cdrom and directory=/mnt/cdrom.

I've tried playing the CD from kscd and encounter similar problems. I have also confirmed that there is a physical set of wires running from the CD drive to the on board sound card.

I'm a linux/slackware newbie so I'm a bit green around the edges, and apologize if I've missed anything obvious... but I don't mind getting my hands dirty in terminal. Any help would be very much appreciated.

Many thanks for you help in advance,

Chris

PS I've tried several CDs!

Slackware 11.0
kernel 2.4.33.3
 
Old 11-12-2006, 05:41 PM   #2
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
You probably don't have properly connected the audio cable that goes from the CD-ROM to the sound card connector and most linux programs use that analog way to read audio by default.
In XMMS press CTRL+P, goto Audio CD Player plugin, choose Config and select Digital audio extraction (i'm translating those names from Spanish, they may be different).

Last edited by gbonvehi; 11-12-2006 at 05:43 PM.
 
1 members found this post helpful.
Old 11-12-2006, 07:37 PM   #3
ceashton
Member
 
Registered: Nov 2006
Distribution: Slackware 12.2
Posts: 36

Original Poster
Rep: Reputation: 15
Wow, thanks for the quick reply!

Picking up on your thoughts that the actual wire connecting the CD player to the sound card might not be connected properly, I have just reconnected it at each end, which didn't alter my situation. I guess that doesn't rule out the cable being faulty, but I'd be unlucky to not plug the cable in properly for a second time.

I also tried your second suggestion of switching from analog to digital audio extraction, which again had no effect for an ordinary user or root.

I have tried something else however... In my first post I reported that I could play a CD when I was logged in as root but didn't get any sound, and went on to suggest this was because root wasn't in the correct groups, well I wanted to confirm this. So I added root to some extra groups - audio video and cdrom:

Code:
$groups root
root: root bin daemon sys adm disk wheel floppy audio video cdrom
Having added the extra groups to root, root can now play and listen to audio CDs via both analog and digital audio extraction! I guess this means that it is some kind or permissions thing, but I'm at a loss as to know where to look now. I believe I showed all the relevant permissions in the first post of this thread so I won't write them again here, but if any other information is helpful please let me know.

Thanks once again for the suggestions, I guess we've eliminated something.

Chris
 
Old 11-13-2006, 09:27 PM   #4
bl0tt0
Member
 
Registered: Aug 2005
Location: The Glorious People's Republic of Austin
Posts: 145

Rep: Reputation: 21
ceashton, sounds like you need to add your regular user to the audio and possibly the cdrom groups. just open up /etc/group, add your user to the lines for audio and cdrom, and you ought to be set up.
 
Old 11-14-2006, 06:05 PM   #5
ceashton
Member
 
Registered: Nov 2006
Distribution: Slackware 12.2
Posts: 36

Original Poster
Rep: Reputation: 15
Hi bl0tt0,

Thanks for the reply. I believe I am a member of the audio and cdrom groups:

Code:
chris@dinosaur:~$ id chris
uid=1065(chris) gid=100(users) groups=100(users),6(disk),11(floppy),17(audio),18(video),19(cdrom)
Code:
chris@dinosaur:~$ groups chris
chris : users disk floppy audio video cdrom
Code:
chris@dinosaur:~$ cat /etc/group | grep chris
disk::6:root,adm,chris
floppy::11:root,chris
audio::17:chris,root
video::18:chris,root
cdrom::19:chris,root
users::100:chris
Things are fine for root (can play audio CDs) since I added them to audio, video and cdrom groups:

Code:
chris@dinosaur:~$ id root
uid=0(root) gid=0(root) groups=0(root),1(bin),2(daemon),3(sys),4(adm),6(disk),10(wheel),11(floppy),17(audio),18(video),19(cdrom)
but obviously I don't wish to use root to play CDs. Just to open things up a little, I changed the permissions of the relevant block device and /dev to 777:

Code:
chris@dinosaur:~$ ls -l /dev/cdrom && ls -l /dev/dvd && ls -l /dev/hdc && ls -l /dev/hdd
lrwxrwxrwx 1 root root 8 2006-10-22 19:08 /dev/cdrom -> /dev/hdc
lrwxrwxrwx 1 root root 8 2006-10-22 19:08 /dev/dvd -> /dev/hdc
brwxrwxrwx 1 root disk 22, 0 2002-06-09 20:27 /dev/hdc
brw-rw---- 1 root disk 22, 64 2002-06-09 20:27 /dev/hdd
And I still can't play audio CDs as a normal user. I show /dev/hdd just to illustrate the permissions of the other devices. Please, if you or anyone else have any more ideas, I'd really like to hear them.

Thank you,

Chris
 
Old 11-14-2006, 07:41 PM   #6
ceashton
Member
 
Registered: Nov 2006
Distribution: Slackware 12.2
Posts: 36

Original Poster
Rep: Reputation: 15
Just to supplement the information I have already provided, I have the following line in /etc/login.defs

Code:
CONSOLE_GROUPS          floppy:audio:video:cdrom
Any hints would be much appreciated.

Chris
 
Old 11-14-2006, 08:05 PM   #7
bl0tt0
Member
 
Registered: Aug 2005
Location: The Glorious People's Republic of Austin
Posts: 145

Rep: Reputation: 21
two other things: have you taken a look in /dev/sound to check the permissions there? Also, what output plugin are you using in XMMS?
 
Old 11-15-2006, 09:25 AM   #8
ceashton
Member
 
Registered: Nov 2006
Distribution: Slackware 12.2
Posts: 36

Original Poster
Rep: Reputation: 15
Hi, I couldn't find /dev/sound, so I presumed you meant /dev/snd, or has it changed name? Anyway, the contents and permissions for /dev/snd are:

Code:
chris@kapitza:~$ ls -ld /dev/snd
drwxr-xr-x 2 root root 4096 2003-08-29 08:48 /dev/snd/


chris@kapitza:~$ ls -l /dev/snd
total 0
crw-rw-rw- 1 root audio 116,   0 2003-08-29 08:47 controlC0
crw-rw-rw- 1 root audio 116,  32 2003-08-29 08:47 controlC1
crw-rw-rw- 1 root audio 116,  64 2003-08-29 08:47 controlC2
crw-rw-rw- 1 root audio 116,  96 2003-08-29 08:47 controlC3
crw-rw--w- 1 root audio 116,   4 2003-08-29 08:47 hwC0D0
crw-rw--w- 1 root audio 116,   5 2003-08-29 08:47 hwC0D1
crw-rw--w- 1 root audio 116,   6 2003-08-29 08:47 hwC0D2
crw-rw--w- 1 root audio 116,   7 2003-08-29 08:47 hwC0D3
crw-rw--w- 1 root audio 116,  36 2003-08-29 08:47 hwC1D0
crw-rw--w- 1 root audio 116,  37 2003-08-29 08:47 hwC1D1
crw-rw--w- 1 root audio 116,  38 2003-08-29 08:47 hwC1D2
crw-rw--w- 1 root audio 116,  39 2003-08-29 08:47 hwC1D3
crw-rw--w- 1 root audio 116,  68 2003-08-29 08:47 hwC2D0
crw-rw--w- 1 root audio 116,  69 2003-08-29 08:47 hwC2D1
crw-rw--w- 1 root audio 116,  70 2003-08-29 08:47 hwC2D2
crw-rw--w- 1 root audio 116,  71 2003-08-29 08:47 hwC2D3
crw-rw--w- 1 root audio 116, 100 2003-08-29 08:47 hwC3D0
crw-rw--w- 1 root audio 116, 101 2003-08-29 08:47 hwC3D1
crw-rw--w- 1 root audio 116, 102 2003-08-29 08:47 hwC3D2
crw-rw--w- 1 root audio 116, 103 2003-08-29 08:47 hwC3D3
crw-rw-rw- 1 root audio 116,   8 2003-08-29 08:47 midiC0D0
crw-rw-rw- 1 root audio 116,   9 2003-08-29 08:47 midiC0D1
crw-rw-rw- 1 root audio 116,  10 2003-08-29 08:47 midiC0D2
crw-rw-rw- 1 root audio 116,  11 2003-08-29 08:47 midiC0D3
crw-rw-rw- 1 root audio 116,  12 2003-08-29 08:47 midiC0D4
crw-rw-rw- 1 root audio 116,  13 2003-08-29 08:47 midiC0D5
crw-rw-rw- 1 root audio 116,  14 2003-08-29 08:47 midiC0D6
crw-rw-rw- 1 root audio 116,  15 2003-08-29 08:47 midiC0D7
crw-rw-rw- 1 root audio 116,  40 2003-08-29 08:47 midiC1D0
crw-rw-rw- 1 root audio 116,  41 2003-08-29 08:47 midiC1D1
crw-rw-rw- 1 root audio 116,  42 2003-08-29 08:47 midiC1D2
crw-rw-rw- 1 root audio 116,  43 2003-08-29 08:47 midiC1D3
crw-rw-rw- 1 root audio 116,  44 2003-08-29 08:47 midiC1D4
crw-rw-rw- 1 root audio 116,  45 2003-08-29 08:47 midiC1D5
crw-rw-rw- 1 root audio 116,  46 2003-08-29 08:47 midiC1D6
crw-rw-rw- 1 root audio 116,  47 2003-08-29 08:47 midiC1D7
crw-rw-rw- 1 root audio 116,  72 2003-08-29 08:47 midiC2D0
crw-rw-rw- 1 root audio 116,  73 2003-08-29 08:47 midiC2D1
crw-rw-rw- 1 root audio 116,  74 2003-08-29 08:47 midiC2D2
crw-rw-rw- 1 root audio 116,  75 2003-08-29 08:47 midiC2D3
crw-rw-rw- 1 root audio 116,  76 2003-08-29 08:47 midiC2D4
crw-rw-rw- 1 root audio 116,  77 2003-08-29 08:47 midiC2D5
crw-rw-rw- 1 root audio 116,  78 2003-08-29 08:47 midiC2D6
crw-rw-rw- 1 root audio 116,  79 2003-08-29 08:47 midiC2D7
crw-rw-rw- 1 root audio 116, 104 2003-08-29 08:47 midiC3D0
crw-rw-rw- 1 root audio 116, 105 2003-08-29 08:47 midiC3D1
crw-rw-rw- 1 root audio 116, 106 2003-08-29 08:47 midiC3D2
crw-rw-rw- 1 root audio 116, 107 2003-08-29 08:47 midiC3D3
crw-rw-rw- 1 root audio 116, 108 2003-08-29 08:47 midiC3D4
crw-rw-rw- 1 root audio 116, 109 2003-08-29 08:47 midiC3D5
crw-rw-rw- 1 root audio 116, 110 2003-08-29 08:47 midiC3D6
crw-rw-rw- 1 root audio 116, 111 2003-08-29 08:47 midiC3D7
crw-rw--w- 1 root audio 116,  24 2003-08-29 08:47 pcmC0D0c
crw-rw-rw- 1 root audio 116,  16 2003-08-29 08:47 pcmC0D0p
crw-rw--w- 1 root audio 116,  25 2003-08-29 08:47 pcmC0D1c
crw-rw-rw- 1 root audio 116,  17 2003-08-29 08:47 pcmC0D1p
crw-rw--w- 1 root audio 116,  26 2003-08-29 08:47 pcmC0D2c
crw-rw-rw- 1 root audio 116,  18 2003-08-29 08:47 pcmC0D2p
crw-rw--w- 1 root audio 116,  27 2003-08-29 08:47 pcmC0D3c
crw-rw-rw- 1 root audio 116,  19 2003-08-29 08:47 pcmC0D3p
crw-rw--w- 1 root audio 116,  28 2003-08-29 08:47 pcmC0D4c
crw-rw-rw- 1 root audio 116,  20 2003-08-29 08:47 pcmC0D4p
crw-rw--w- 1 root audio 116,  29 2003-08-29 08:47 pcmC0D5c
crw-rw-rw- 1 root audio 116,  21 2003-08-29 08:47 pcmC0D5p
crw-rw--w- 1 root audio 116,  30 2003-08-29 08:47 pcmC0D6c
crw-rw-rw- 1 root audio 116,  22 2003-08-29 08:47 pcmC0D6p
crw-rw--w- 1 root audio 116,  31 2003-08-29 08:47 pcmC0D7c
crw-rw-rw- 1 root audio 116,  23 2003-08-29 08:47 pcmC0D7p
crw-rw--w- 1 root audio 116,  56 2003-08-29 08:47 pcmC1D0c
crw-rw-rw- 1 root audio 116,  48 2003-08-29 08:47 pcmC1D0p
crw-rw--w- 1 root audio 116,  57 2003-08-29 08:47 pcmC1D1c
crw-rw-rw- 1 root audio 116,  49 2003-08-29 08:47 pcmC1D1p
crw-rw--w- 1 root audio 116,  58 2003-08-29 08:47 pcmC1D2c
crw-rw-rw- 1 root audio 116,  50 2003-08-29 08:47 pcmC1D2p
crw-rw--w- 1 root audio 116,  59 2003-08-29 08:47 pcmC1D3c
crw-rw-rw- 1 root audio 116,  51 2003-08-29 08:47 pcmC1D3p
crw-rw--w- 1 root audio 116,  60 2003-08-29 08:47 pcmC1D4c
crw-rw-rw- 1 root audio 116,  52 2003-08-29 08:47 pcmC1D4p
crw-rw--w- 1 root audio 116,  61 2003-08-29 08:47 pcmC1D5c
crw-rw-rw- 1 root audio 116,  53 2003-08-29 08:47 pcmC1D5p
crw-rw--w- 1 root audio 116,  62 2003-08-29 08:47 pcmC1D6c
crw-rw-rw- 1 root audio 116,  54 2003-08-29 08:47 pcmC1D6p
crw-rw--w- 1 root audio 116,  63 2003-08-29 08:47 pcmC1D7c
crw-rw-rw- 1 root audio 116,  55 2003-08-29 08:47 pcmC1D7p
crw-rw--w- 1 root audio 116,  88 2003-08-29 08:47 pcmC2D0c
crw-rw-rw- 1 root audio 116,  80 2003-08-29 08:47 pcmC2D0p
crw-rw--w- 1 root audio 116,  89 2003-08-29 08:47 pcmC2D1c
crw-rw-rw- 1 root audio 116,  81 2003-08-29 08:47 pcmC2D1p
crw-rw--w- 1 root audio 116,  90 2003-08-29 08:47 pcmC2D2c
crw-rw-rw- 1 root audio 116,  82 2003-08-29 08:47 pcmC2D2p
crw-rw--w- 1 root audio 116,  91 2003-08-29 08:47 pcmC2D3c
crw-rw-rw- 1 root audio 116,  83 2003-08-29 08:47 pcmC2D3p
crw-rw--w- 1 root audio 116,  92 2003-08-29 08:47 pcmC2D4c
crw-rw-rw- 1 root audio 116,  84 2003-08-29 08:47 pcmC2D4p
crw-rw--w- 1 root audio 116,  93 2003-08-29 08:47 pcmC2D5c
crw-rw-rw- 1 root audio 116,  85 2003-08-29 08:47 pcmC2D5p
crw-rw--w- 1 root audio 116,  94 2003-08-29 08:47 pcmC2D6c
crw-rw-rw- 1 root audio 116,  86 2003-08-29 08:47 pcmC2D6p
crw-rw--w- 1 root audio 116,  95 2003-08-29 08:47 pcmC2D7c
crw-rw-rw- 1 root audio 116,  87 2003-08-29 08:47 pcmC2D7p
crw-rw--w- 1 root audio 116, 120 2003-08-29 08:47 pcmC3D0c
crw-rw-rw- 1 root audio 116, 112 2003-08-29 08:47 pcmC3D0p
crw-rw--w- 1 root audio 116, 121 2003-08-29 08:47 pcmC3D1c
crw-rw-rw- 1 root audio 116, 113 2003-08-29 08:47 pcmC3D1p
crw-rw--w- 1 root audio 116, 122 2003-08-29 08:47 pcmC3D2c
crw-rw-rw- 1 root audio 116, 114 2003-08-29 08:47 pcmC3D2p
crw-rw--w- 1 root audio 116, 123 2003-08-29 08:47 pcmC3D3c
crw-rw-rw- 1 root audio 116, 115 2003-08-29 08:47 pcmC3D3p
crw-rw--w- 1 root audio 116, 124 2003-08-29 08:47 pcmC3D4c
crw-rw-rw- 1 root audio 116, 116 2003-08-29 08:47 pcmC3D4p
crw-rw--w- 1 root audio 116, 125 2003-08-29 08:47 pcmC3D5c
crw-rw-rw- 1 root audio 116, 117 2003-08-29 08:47 pcmC3D5p
crw-rw--w- 1 root audio 116, 126 2003-08-29 08:47 pcmC3D6c
crw-rw-rw- 1 root audio 116, 118 2003-08-29 08:47 pcmC3D6p
crw-rw--w- 1 root audio 116, 127 2003-08-29 08:47 pcmC3D7c
crw-rw-rw- 1 root audio 116, 119 2003-08-29 08:47 pcmC3D7p
crw-rw-rw- 1 root audio 116,   1 2003-08-29 08:47 seq
crw-rw-rw- 1 root audio 116,  33 2003-08-29 08:47 timer
As I am a member of the audio group I have read/write permissions so everything should fine, shouldn't it?

Xmms uses the following plugins:

1) CD Audio Player 1.2.10 [libcdaudio.so]
2) MikMod Player 1.2.10 [libmikmod.so]
3) MPEG Layer 1/2/3 Player 1.2.10 [libmpg123.so]
4) Ogg Vorbis Player 1.2.10 [libvorbis.so]
5) Reference FLAC Player v1.1.2 [libxmms-flac.so]
6) Tone Generator 1.2.10 [libtonegen.so]
7) Wave Player 1.2.10 [libwav.so]

which can be found in the following locations:

Code:
chris@kapitza:~$ ls -l /usr/lib/xmms/Input/libcdaudio.so && ls -l /usr/lib/libmikmod.so && ls -l /usr/lib/libmikmod.so.2.0.4 && ls -l /usr/lib/xmms/Input/libmpg123.so && ls -l /usr/lib/libvorbis.so && ls -l /usr/lib/libvorbis.so.0.3.1 && ls -l /usr/lib/xmms/Input/libxmms-flac.so && ls -l /usr/lib/xmms/Input/libtonegen.so && ls -l /usr/lib/xmms/Input/libwav.so
-rwxr-xr-x 1 root root 51668 2005-08-04 20:36 /usr/lib/xmms/Input/libcdaudio.so*
lrwxrwxrwx 1 root root 18 2006-10-31 16:56 /usr/lib/libmikmod.so -> libmikmod.so.2.0.4*
-rwxr-xr-x 1 root root 260344 2005-03-21 21:36 /usr/lib/libmikmod.so.2.0.4*
-rwxr-xr-x 1 root root 172300 2005-08-04 20:36 /usr/lib/xmms/Input/libmpg123.so*
lrwxrwxrwx 1 root root 18 2006-10-31 16:57 /usr/lib/libvorbis.so -> libvorbis.so.0.3.1*
-rwxr-xr-x 1 root root 164464 2006-02-03 03:15 /usr/lib/libvorbis.so.0.3.1*
-rwxr-xr-x 1 root root 115712 2005-06-15 01:35 /usr/lib/xmms/Input/libxmms-flac.so*
-rwxr-xr-x 1 root root 8140 2005-08-04 20:36 /usr/lib/xmms/Input/libtonegen.so*
-rwxr-xr-x 1 root root 9964 2005-08-04 20:36 /usr/lib/xmms/Input/libwav.so*


chris@kapitza:~$ ls -ld /usr/lib
drwxr-xr-x 80 root root 32768 2003-01-10 16:16 /usr/lib/


chris@kapitza:~$ ls -ld /usr/lib/xmms/
drwxr-xr-x 7 root root 4096 2005-08-04 20:36 /usr/lib/xmms//


chris@kapitza:~$ ls -ld /usr/lib/xmms/Input/
drwxr-xr-x 2 root root 4096 2005-08-04 20:36 /usr/lib/xmms/Input//
I would be surprised if it was missing plugins, because as I reported in my earlier posts, root can play audio CDs just fine. I suspect permissions, but I really don't know where else to look. Keep your suggestions coming, I really appreciate them!
Cheers, Chris
 
Old 11-15-2006, 11:55 AM   #9
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
I guess you already checked, but just to be sure, are you sure your user's volume settings are ok? Check again just in case, if you're using KDE, you should use KMix to set them.
 
Old 11-15-2006, 12:42 PM   #10
bl0tt0
Member
 
Registered: Aug 2005
Location: The Glorious People's Republic of Austin
Posts: 145

Rep: Reputation: 21
Strange, I have a /dev/sound directory that contains a dsp file that is symlinked to /dev/dsp. I see you've run alsamixer, but have you gone through running alsaconf first?

Also, I was referring to the output plugin for XMMS, not input. You can find that right below the input plugins. Take a look at what sound system you are using, and whether it is configured to use your sound card.
 
Old 11-15-2006, 07:32 PM   #11
ceashton
Member
 
Registered: Nov 2006
Distribution: Slackware 12.2
Posts: 36

Original Poster
Rep: Reputation: 15
Hi again,

thanks for the replies. I've checked the volume settings in alsamixer again, for both root and as a normal user and they are both fine. I also ran KMix and the volume setting seem to be equivalent to the settings of alsamixer - in that, if I change a volume setting in one mixer it is reflected in the second mixer as you would expect.

Yep there is definitely no /dev/sound on my installation of Slack 11.0 that I ordered. Just to check, we also run Slack 11.0 on a work computer that whose installation CDs were downloaded and this installation also lacks a /dev/sound. So yeah, strange! Are you using the Slack 11.0 too? There is no link to /dev/dsp in /dev/snd. /dev/dsp exists and has the following permissions:

Code:
chris@dinosaur:~$ ls -l /dev/dsp*
lrwxrwxrwx 1 root root       4 2006-10-22 18:47 /dev/dsp -> dsp0
crw-rw--w- 1 root audio 14,  3 2003-08-29 08:47 /dev/dsp0
crw-rw--w- 1 root audio 14, 19 2003-08-29 08:47 /dev/dsp1
crw-rw--w- 1 root audio 14, 35 2003-08-29 08:47 /dev/dsp2
crw-rw--w- 1 root audio 14, 51 2003-08-29 08:47 /dev/dsp3
I have run alsaconfig, but just to be sure, I ran it again and it detected my sound card... still the problem persists.

Yikes, I see you did ask about output rather that input plugins... its all there before me, just like I hope this answer will be soon ;-) The output plugins are as follows:

1) ALSA 1.2.10 output plugin [libALSA.so]
2) aRts Output 0.7.1 [libarts.so]
3) Disk Writer Plugin 1.2.10 [libdisk_writer.so]
4) eSound Output Plugin 1.2.10 [libesdout.so]
5) OSS Driver 1.2.10 [libOSS.so]

Interestingly OSS was selected as my output plugin. I've changed this to the ALSA plugin and checked this to be the case for both root and normal user. In configuring the audio device section of ALSA there is a choice of devices, default, VIA 8235: VIA 8235 (hw:0,0) and VIA 8235: VIA 8235 (hw:0,1). I have tried all three of these devices, for both root and a normal user, and root may play audio CDs and normal users may not. In the end I just left the audio device at its default value of "default".

I'd be really surprised if my problem is being caused by the mixer (alsamixer or KMix), as I can play mp3s and wavs etc and have good control over their volume etc.... unless I'm missing something blindingly obvious!

To recap just in case I wasn't explicit enough, to attempt to play an audio CD I issue the command:

Code:
xmms /dev/hdc
this opens a "play files" dialogue box, which for root is in the location /dev/hdc, but for a normal user is /dev. As root I select the files I wish to play, hit play and music plays. As a normal user I try to open hdc by hitting play/add (I've tried them both) and the dialogue box closes and I am presented with the xmms player console which is doing nothing. Why when I issue the same command am I given a different location in the dialogue box?

Keep the suggestions coming,

Chris
 
Old 11-15-2006, 08:30 PM   #12
bl0tt0
Member
 
Registered: Aug 2005
Location: The Glorious People's Republic of Austin
Posts: 145

Rep: Reputation: 21
I am running Slack 11, but I upgraded mine progressively with slackware-current, so maybe /dev/sound came from that. I'll have to do a little more reading on that. In any case, I think I figured out the problem. I thought you were having problems with playing sound with XMMS using cds, but it looks like you're having problems with playing the cd itself, and I think I can help.

Looking at the console command you entered, you were asking alsa to load files from /dev/hdc itself, not the contents of the cdrom.

try entering
Code:
xmms /mnt/cdrom
and see if that works.

It should also be said that you don't actually need to mount the cdrom, xmms will take care of getting the files.

Give that a try, and let me know if that solves your problem.
 
Old 11-15-2006, 09:59 PM   #13
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
I had the same problem and found that it was as simple as turning the CD volume up in the alsamixer panel.
 
Old 11-16-2006, 08:51 AM   #14
ceashton
Member
 
Registered: Nov 2006
Distribution: Slackware 12.2
Posts: 36

Original Poster
Rep: Reputation: 15
bl0tt0, I've tried running the command:

Code:
xmms /mnt/cdrom
and still no joy.

Vincent_Vega, I'm fairly confident its not my mixer settings, as I can play audio CDs as root and I have checked and double checked that I have the same mixer settings as a normal user as I have as root.

Keep the suggestions coming guys.

Cheers, Chris.
 
Old 11-16-2006, 12:18 PM   #15
adriv
Member
 
Registered: Nov 2005
Location: Diessen, The Netherlands
Distribution: Slackware 14.1
Posts: 661

Rep: Reputation: 38
Can't you get audio cd's going with KsCD?
Try some settings and read the KsCD Help-pages.
Worked for me (I can't seem to get XMMS playing audio cd's either).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio::Play/Audio::Data DanTaylor Programming 0 02-07-2006 07:37 PM
how to play audio cd in slackware 10.1? anindyanuri Slackware 13 06-26-2005 01:06 AM
Audio CD Doesn't Play - Slackware mijenks Slackware 9 07-22-2004 11:44 PM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 08:52 AM


All times are GMT -5. The time now is 03:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration