LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-19-2004, 05:07 AM   #1
melinda_sayang
Member
 
Registered: Dec 2003
Location: Petaling Jaya
Distribution: Ubuntu
Posts: 475

Rep: Reputation: 31
Can't play audio cd


With Debian, RH 9, FC 1, I can play audio cd easily. Now with Slackware, with xmms, kscd, audio player, alsa player, I cann't play audio cd. They can not detect my audio cd. The only way I can play audio cd is to use xcdroast. I read the track then I play it. I use creative sound card blaster. Any idea?
 
Old 03-19-2004, 05:21 AM   #2
wallison
Member
 
Registered: Jul 2003
Location: MD USA
Distribution: Slackware
Posts: 136

Rep: Reputation: 18
You need to add your user account to the groups sys and disk. Or chmod the devices.
 
Old 03-19-2004, 08:57 AM   #3
sgtbob
Member
 
Registered: Jan 2004
Location: Kansas
Distribution: Windows 7, iMAC Lion 8.5, Ubuntu
Posts: 92

Rep: Reputation: 15
Question

wallison - can you be more specific on this procedure? I am so new that this suggestion is beyond me, but would appreciate a step-by-step on how to do this. Sounds as though it might solve a problem I am having - no audio CD's play
 
Old 03-19-2004, 09:18 AM   #4
Frank_Drebin
Member
 
Registered: Feb 2004
Location: Atlanta, GA USA
Posts: 232

Rep: Reputation: 30
Also may want to go in to XMMS and click on properties or options (can't remember which) . There is a list of plugins and one of them is for CD reading. 2nd one on mine. click on it, and hit configure. When it opens, click on read digital signal. It defaults to analog and if you don't have the 4 pin connector it won't read anything.

Good Luck.....

Frank
 
Old 03-19-2004, 09:21 AM   #5
flyfishin
Member
 
Registered: Aug 2003
Location: KC, MO
Distribution: CentOS, RHEL, SuSE, Fedora
Posts: 243

Rep: Reputation: 30
What happens when you run alsaconf as root? Creative cards are pretty common and should be recognized.
 
Old 03-19-2004, 09:25 AM   #6
Frank_Drebin
Member
 
Registered: Feb 2004
Location: Atlanta, GA USA
Posts: 232

Rep: Reputation: 30
Flyfishin.. it looks like he isn't reading the CD's or at least the analog output (ie no 4pin plug to sound card). If other aps work with the sound card I don't believe its an ALSA issue. Your thoughts?


Could be that he needs to turn on the digital read (if xmms is moving and appears to be playing but no sound).
 
Old 03-19-2004, 09:35 AM   #7
flyfishin
Member
 
Registered: Aug 2003
Location: KC, MO
Distribution: CentOS, RHEL, SuSE, Fedora
Posts: 243

Rep: Reputation: 30
He doesn't mention any other apps. In fact we don't know if any sounds play. He did mention other distros. I just figured start with the basics, see if alsa picks it up and sound levels are set correctly with alsamixer or aumix, and then go from there. A really simple test would be to type play /usr/share/sounds/warning.wav and see if any sound comes through the speakers.
 
Old 03-19-2004, 02:49 PM   #8
failure_man
Member
 
Registered: Mar 2004
Location: Chicago
Distribution: Slackware
Posts: 60

Rep: Reputation: 16
Quote:
Originally posted by Frank_Drebin
Flyfishin.. it looks like he isn't reading the CD's or at least the analog output (ie no 4pin plug to sound card). If other aps work with the sound card I don't believe its an ALSA issue. Your thoughts?


Could be that he needs to turn on the digital read (if xmms is moving and appears to be playing but no sound).
That reminds me of a problem that's been bugging me slightly for the past year: how DO you get an audio CD to play in digital mode under Linux? My current primary box doesn't have that analog crossover cable deal going so I don't get any sound. (The workaround is that I end up ripping my CDs anyway so I just listen to the MP3s but it still irritates me.)
 
Old 03-19-2004, 07:39 PM   #9
melinda_sayang
Member
 
Registered: Dec 2003
Location: Petaling Jaya
Distribution: Ubuntu
Posts: 475

Original Poster
Rep: Reputation: 31
Quote:
Originally posted by flyfishin
What happens when you run alsaconf as root? Creative cards are pretty common and should be recognized.
My sound is working properly. I can play mp3 and ogg files easily. Yes, I use alsa driver for my sound stuff with kernel 2.6.3. I have run alsaconf as root. Yes, with alsaconf I can detect my sound card easily.

But hey, when I put audio cd in my computer box, I run cd player program in Gnome desktop, it seems like I don't put anything in my computer box. Grip also can not detect my cd player. So I can not rip cd with grip too.

So again, the only thing I could do with audio cd is to use xcdroast. I forgot to mention something. Xcdroast can not play audio cd too. What I can do with audio cd with xcdroast it to READ ( not play ) audio cd tracks so that in my tmp directory I got trackblabla.wav. From that I could play the music.
 
Old 03-19-2004, 10:10 PM   #10
ringwraith
Senior Member
 
Registered: Sep 2003
Location: Indiana
Distribution: Slackware-current
Posts: 1,244

Rep: Reputation: 47
Not using 2.6.x kernel yet but I know it has changed the need for scsi emulation. Are you still passing ide=scsi in your lilo entry? How is the cd referenced in your fstab?
 
Old 03-19-2004, 10:25 PM   #11
wallison
Member
 
Registered: Jul 2003
Location: MD USA
Distribution: Slackware
Posts: 136

Rep: Reputation: 18
Did you try to add your user account to the disk group?
 
Old 03-20-2004, 01:07 AM   #12
melinda_sayang
Member
 
Registered: Dec 2003
Location: Petaling Jaya
Distribution: Ubuntu
Posts: 475

Original Poster
Rep: Reputation: 31
Quote:
Originally posted by wallison
Did you try to add your user account to the disk group?
That's not the solution because I already added as disk group user. But your first post is the right solution because after I added my self as sys group user, I can read audio cd. Then after I increase the volume from audio cd, I can totally play audio cd.

Thank you.

I have face similar problem in Debian but in Debian as normal user in default mode I cann't access sound stuff so I have to added my self as blablabla group user so I can access sound stuff but this is the first time I know that to use audio cd you have to be blabla group user too.

Enjoy.
 
Old 03-20-2004, 04:23 AM   #13
Jernej
LQ Newbie
 
Registered: Jan 2004
Location: Slovenia
Posts: 8

Rep: Reputation: 0
The solution for ripping cd is easy. Put cd in cdrom. Close it. Hit Home icon. On the left side you will see Audio cd Browser. Only one thing for mp3 you will need lame.(http://mitiok.cjb.net/)
I was talking about KDE 3.2.1 environment here.

Last edited by Jernej; 03-20-2004 at 04:29 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
why i can't play my CD audio mamasmoe DamnSmallLinux 1 08-12-2004 07:31 PM
Can't play Audio CD's bugsbunny Slackware 7 05-07-2004 09:07 AM
Can't play CD Audio morrolan Linux - Software 3 01-05-2004 08:55 AM
DVD plays but no audio (can play audio cd's though)? guitarnix Linux - Newbie 2 10-05-2003 07:52 AM
play audio cd bfkeats Linux - General 4 02-06-2002 12:19 AM


All times are GMT -5. The time now is 03:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration