LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-27-2009, 06:41 PM   #1
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,019

Rep: Reputation: 63
Can't open grub.conf/lilo.conf with kate being root


From konsole:
Code:
su
kate grub.conf
Code:
No protocol specified
kate: cannot connect to X server :0.0
 
Old 09-27-2009, 07:40 PM   #2
vik
Member
 
Registered: Apr 2008
Distribution: Gentoo
Posts: 225
Blog Entries: 7

Rep: Reputation: 50
This is because you're logged into your desktop environment as another user. I don't know of a good solution other than logging out and logging back in as root if you want to use kate. Otherwise nano might be more intuitive if you don't like vim or emacs.
 
Old 09-28-2009, 01:05 AM   #3
mattydee
Member
 
Registered: Dec 2006
Location: Vancouver, BC
Distribution: Debian
Posts: 462

Rep: Reputation: 39
try kdesu:
kdesu "kate grub.conf"
 
Old 09-28-2009, 01:54 AM   #4
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,252

Rep: Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048Reputation: 1048
In your konsole, issue following command:
Code:
xhost local:
before typing su.

You can add this to your ~/.bashrc

PS For whatever reason, I don't need this in Slackware63-13.0 (though I don't use kate: I use either nano or geany).

Last edited by Didier Spaier; 09-28-2009 at 02:05 AM.
 
Old 09-28-2009, 02:07 AM   #5
ppr:kut
Member
 
Registered: Aug 2006
Location: Netherlands
Distribution: Slackware
Posts: 361

Rep: Reputation: 93
konsole in kde3 did support this, konsole in kde4 doesn't. Another solution to all all the already mentioned ones would be to run it from another terminal like xterm for example (instead of konsole)
 
Old 09-28-2009, 04:41 AM   #6
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,031
Blog Entries: 52

Rep: Reputation: Disabled
I've never had any problems with kdesu kwrite filename. Maybe it's different with kate?
 
Old 09-28-2009, 07:26 AM   #7
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,019

Original Poster
Rep: Reputation: 63
kdesu kate grub.conf works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Is lilo.conf file format is same for grub.conf? Chundo Linux - Newbie 1 01-30-2006 06:21 PM
the "default" ( as we have in grub.conf ) option of lilo.conf ??? b0nd Linux - Newbie 4 09-14-2005 05:51 AM
Switching from grub to lilo, messed up Lilo.conf, rescuing via Knoppix. SonicGT Debian 2 08-21-2005 01:15 PM
create lilo.conf or grub.conf through commands newpenguin Linux - Software 1 11-28-2003 08:22 PM
lilo.conf and grub.conf no read access shanenin Linux - Software 1 10-02-2003 03:53 PM


All times are GMT -5. The time now is 01:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration