LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-21-2003, 09:41 AM   #1
Useff
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Rep: Reputation: 0
Can't log into slackware anymore


Hello everyone, I'm pretty new to Linux in general so please bear with me.
I had just installed Slackware 8.1 on a dual-boot system with Windows XP, and the installation worked, no real problems there.
After that, I configured X and when I started KDE, I couldn't use my USB optical mouse, but the USB keyboard worked.
I got the USB mouse to work fine, and it continued to work fine throughout multiple reboots.
After this, I decided the resolution wasn't for me, so I edited XF86Config and added the resolution I wanted - 1280x1024.
Now after all this, even after a restart, Slackware still worked for me. At one point I restarted the computer, and when I booted into Slackware, I couldn't log in. The reason for this was because every time I typed one letter, it was really typing two. That is, for every keystroke, two were recorded, which as far as I know makes it impossible for me to log in. This is the point I'm at right now, and I'd love for someone to help me through this.
 
Old 02-21-2003, 11:19 AM   #2
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 199Reputation: 199
Well the one thing I would suggest is something isn't reading your keyboard right. One way of testing would be to try maybe a regular PS/2 keyboard attached instead of your usb one to boot your system with to troubleshoot. If that works, you should be able to check your settings and configurations for your USB keyboard.
 
Old 02-21-2003, 11:45 AM   #3
Useff
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Original Poster
Rep: Reputation: 0
alright

I tried a PS/2 keyboard, and I was able to log in fine - no doubled keystrokes.
I then tried to log in with a different USB keyboard, and I got the same problem I had with the original.
I guess what I need to do now is change the settings for the USB keyboard - what's the best way of going about that?
Thanks.
 
Old 02-22-2003, 07:26 AM   #4
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
It sounds like the kernel is receiving keyboard input from two different sources. Perhaps the USB driver that was functioning to begin with and then a compatibility option was also enabled perhaps in the BIOS. What were some of the changes, if any, just prior to the problem starting? Have you added any other USB devices that a driver be loaded for it?

I think you can check the kernel boot command line by; "cat /proc/cmdline". Just to see if a kernel command statement may have been added.

If you are able to login with a PS/2 keyboard, check what modules are loaded using the "lsmod" command. There is only one module that I think is directly related to a keyboard, "usbkbd". However, there is also another module called "hid", the name would imply "human interface device" that might also include keyboard support. If both are loaded, then you might try replacing "hid" with "usbmouse". You could also try to disable the "usbkbd" module. A USB enabled kernel might also provide the support and then another module is loading as well. Thus two drivers are providing duplicate input. If you know what modules were loading when it was working properly, then comparing the current listing might provide an answer.

Hope it helps.
 
Old 02-22-2003, 10:41 AM   #5
Useff
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Original Poster
Rep: Reputation: 0
I run lsmod and I get this list:

Module Size Used by Tainted: P
emu10k1 62280 0
ac97_codec 9544 0 [emu10k1]
soundcore 3236 4 [emu10k1]
agpgart 29824 3 (autoclean)
nvidia 1467488 10
pcmcia_core 40896 0
ide-scsi 7456 0
8139too 13792 1
mii 1008 0 [8139too]
mousedev 3744 1
keybdev 1664 0 (unused)
usbmouse 1728 0 (unused)
hid 18816 0 (unused)
usb-uhci 20708 1 (initializing)

Could keybdev and hid be giving double input?
I'm going to try hashing out /sbin/modprobe keybdev from rc.modules.
I'm a little hesitant to do this though, because if I do this and have no keyboard support at all, how will I be able to progress from there?
 
Old 02-22-2003, 11:28 AM   #6
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Well, you will still be able to use the PS/2 keyboard to go back and make any modifications. The way you are now.

In regard to your question though, keybdev may be a similar module to the mousedev module, I think it provides a common interface for apps to work with.

The usb-uhci provides the controller interface to enable the USB ports. But it may be that only hid or usbmouse may be required. I would try to remove "hid" first I think. But thats me, and I will 100% of the time choose wrong on a 50/50 chance.
 
Old 02-22-2003, 01:06 PM   #7
Useff
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Original Poster
Rep: Reputation: 0
So far I've hashed out
/sbin/modprobe hid
and
/sbin/modprobe keybdev .
Even with both of those out of the picture, the usb keyboard still continues to register two keystrokes for every one.
I'll just continue down the line and see what happens.
 
Old 02-22-2003, 04:12 PM   #8
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
After you boot the system, you can review the kernel messages by using shift-pgup and shift-pgdn I think it is. See if you can read anything about what it is detecting in reference to the keyboard. It might sort of difficult if it doubles those keys as well.

If you want to just disable all modules then use the command "chmod 000 /etc/rc.d/rc.modules" It will remove the execute bit from the file so it cannot execute. I do it when I build a kernel that modules are disabled.
 
Old 02-22-2003, 08:55 PM   #9
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Well, I tried everything I can to duplicate the problem without success. Even with two keyboards and two mice attached. PS/2 and USB on each. They worked just the way they are supposed too.

I did learn about the specific drivers though. The usbkbd and usbmouse are HID Boot protocol described as basic support. The hid module is full support for the devices. "Full" I couldn't tell. The USB keyboard I had the function keys didn't work using either driver. The mousedev and keybdev modules are going to be required for the mouse and keyboard to function respectively.

In the lsmod listing you provided above appears to be a complete listing because of the other modules that are listed. But it is also odd that the module "input" is not included in the listing. Whenever, I modprobed either the hid or the usb... modules it always included the input module as well. Your output also looks a little different in that it doesn't list usbcore either. You also stated that you removed keybdev and hid modules. I would think the USB keyboard would not even work. At least in my tests I couldn't login at all. I had to use the PS/2 keyboard to login and load the modules then the USB keyboard started working. Now, I was also running the bare.i stock 2.4.18 kernel. What kernel are you using? Perhaps the modules have changed. I know that many updates were made in 2.4.19 and the 2.4.20 kernels for USB and Firewire devices. That might explain the differences. If your kernel has built-in support, like maybe one of the USB enabled kernels, then the modules would not be required at all and the modules could be causing the porblem. If you are using a usb enabled kernel then you should not even load the uhci module, that module is what activates the USB host controller and it should also be included in the kernel. If you haven't built a new kernel or installed a different one from the install CD, then it should still be running the kernel you chose when you installed.
 
Old 02-23-2003, 12:11 AM   #10
Useff
LQ Newbie
 
Registered: Feb 2003
Posts: 6

Original Poster
Rep: Reputation: 0
I'm running kernel version 2.4.18, usb.i from the install disc. Maybe the reason I'm getting this duplicate activity is because I don't need the modules since they're already built into the core? I'll try disabling all usb modules and see what that does.
Thanks a lot for the insight.

EDIT: Problem solved! Thanks for all the help!

Last edited by Useff; 02-23-2003 at 01:10 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't log in anymore! DJOtaku Linux - Software 4 08-06-2005 07:37 PM
Slackware not my most hated anymore adamb10 LinuxQuestions.org Member Success Stories 6 07-30-2005 05:09 PM
cant log in anymore on Mandrake 10.1 etim Linux - Hardware 4 04-01-2005 02:25 AM
KDE and Gnome not working anymore in Slackware... Necronomicom Slackware 9 07-03-2004 05:36 PM
Newbie screwed up and can't log as root anymore chumley115 Linux - Software 3 03-12-2004 02:20 PM


All times are GMT -5. The time now is 04:17 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration