LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-03-2011, 10:07 AM   #1
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Rep: Reputation: 16
Can't install 'rmagick' Ruby gem...


Hi all,
Has anyone been able to successfully install rmagick on slackware 13.1? On both my systems (one multilib and one 32-bit), it complains about having a 'partial' ImageMagick install!

Code:
$ sudo gem install rmagick
Building native extensions.  This could take a while...
ERROR:  Error installing rmagick:
	ERROR: Failed to build gem native extension.

/usr/bin/ruby extconf.rb install rmagick
checking for Ruby version >= 1.8.5... yes
checking for gcc... yes
checking for Magick-config... yes

Warning: Found a partial ImageMagick installation. Your operating system likely has some built-in ImageMagick libraries but not all of ImageMagick. This will most likely cause problems at both compile and runtime.
Found partial installation at: /usr
checking for ImageMagick version >= 6.4.9... yes
checking for HDRI disabled version of ImageMagick... yes
checking for stdint.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
	--with-opt-dir
	--without-opt-dir
	--with-opt-include
	--without-opt-include=${opt-dir}/include
	--with-opt-lib
	--without-opt-lib=${opt-dir}/lib
	--with-make-prog
	--without-make-prog
	--srcdir=.
	--curdir
	--ruby=/usr/bin/ruby
/usr/lib64/ruby/1.9.1/mkmf.rb:364:in `try_do': The complier failed to generate an executable file. (RuntimeError)
You have to install development tools first.
	from /usr/lib64/ruby/1.9.1/mkmf.rb:433:in `try_cpp'
	from /usr/lib64/ruby/1.9.1/mkmf.rb:811:in `block in have_header'
	from /usr/lib64/ruby/1.9.1/mkmf.rb:670:in `block in checking_for'
	from /usr/lib64/ruby/1.9.1/mkmf.rb:276:in `block (2 levels) in postpone'
	from /usr/lib64/ruby/1.9.1/mkmf.rb:250:in `open'
	from /usr/lib64/ruby/1.9.1/mkmf.rb:276:in `block in postpone'
	from /usr/lib64/ruby/1.9.1/mkmf.rb:250:in `open'
	from /usr/lib64/ruby/1.9.1/mkmf.rb:272:in `postpone'
	from /usr/lib64/ruby/1.9.1/mkmf.rb:669:in `checking_for'
	from /usr/lib64/ruby/1.9.1/mkmf.rb:810:in `have_header'
	from extconf.rb:193:in `<main>'


Gem files will remain installed in /usr/lib64/ruby/gems/1.9.1/gems/rmagick-2.13.1 for inspection.
Results logged to /usr/lib64/ruby/gems/1.9.1/gems/rmagick-2.13.1/ext/RMagick/gem_make.out

Last edited by ahmadj; 01-04-2011 at 03:34 AM.
 
Old 01-04-2011, 02:49 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
/usr/lib64/ruby/1.9.1/mkmf.rb:364:in `try_do': The complier failed to generate an executable file. (RuntimeError)
You have to install development tools first.
 
Old 01-04-2011, 03:35 AM   #3
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by acid_kewpie View Post
/usr/lib64/ruby/1.9.1/mkmf.rb:364:in `try_do': The complier failed to generate an executable file. (RuntimeError)
You have to install development tools first.
Which development tools? AFAIK, Slackware has full installs of Ruby and Imagemagick. There are no 'dev' versions of packages, everything is included from the get-go. So what am I missing?

Last edited by ahmadj; 01-04-2011 at 03:40 AM.
 
Old 01-04-2011, 03:52 AM   #4
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 87
I found this on the slackbuilds.org mail list:

https://rcpt.yousendit.com/101792090...28116c1b86c27d

I hope it works
 
Old 01-04-2011, 04:23 AM   #5
ahmadj
Member
 
Registered: Jun 2010
Distribution: Slackware64_13.37 \ Slackware_13.1 \ ARMedslack_13.37
Posts: 80

Original Poster
Rep: Reputation: 16
Doesn't seem to

Code:
$ pdfbeads
/home/ahmad/.gem/ruby/1.9.1/gems/rmagick-2.13.1/lib/RMagick.rb:11:in `require': no such file to load -- RMagick2.so (LoadError)
	from /home/ahmad/.gem/ruby/1.9.1/gems/rmagick-2.13.1/lib/RMagick.rb:11:in `<top (required)>'
	from /usr/lib/ruby/gems/1.9.1/gems/pdfbeads-1.0.3/lib/pdfbeads.rb:36:in `require'
	from /usr/lib/ruby/gems/1.9.1/gems/pdfbeads-1.0.3/lib/pdfbeads.rb:36:in `<top (required)>'
	from /usr/lib/ruby/gems/1.9.1/gems/pdfbeads-1.0.3/bin/pdfbeads:38:in `require'
	from /usr/lib/ruby/gems/1.9.1/gems/pdfbeads-1.0.3/bin/pdfbeads:38:in `<top (required)>'
	from /usr/bin/pdfbeads:19:in `load'
	from /usr/bin/pdfbeads:19:in `<main>'
I do not think this is a Slackware problem; am opening an issue with RMagick on github... (yes I tried the git version too.. same failure to compile).

EDIT: .tgz provided in that zip (2.5.1) is too old for 13.1's version of ImageMagick; using the SlackBuild with 2.13.1 (latest, supposedly compatible) fails with same error...

Last edited by ahmadj; 01-04-2011 at 04:32 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Any issues installing Ruby Gems and Ruby on Rails in Slackware? Lufbery Slackware 8 02-09-2011 07:22 PM
[SOLVED] Installing Ruby on Rails -- "gem update --system is disabled on Debian". bartonski Debian 2 08-23-2009 09:17 PM
Error while installing MySQL Ruby gem skie_knite007 Programming 5 07-12-2009 06:57 PM
RMagick shared libraries problem (ruby on rails setup) Roosta21 Linux - Server 4 08-18-2008 05:57 AM
RMagick Ninju Linux - Software 1 09-26-2007 01:35 PM


All times are GMT -5. The time now is 01:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration