LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-27-2006, 11:05 PM   #1
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,490

Rep: Reputation: Disabled
Can't get my ATI Radeon XPRESS vidcard working right


Hi all,

Trying to get the video card working on an HP dv5000 with slack 10.2 and a custom 2.6.13 kernel

I've installed the ati drivers and done a basic config with aticonfig. It seems to start up fine, but startx mutters in the background:


Symbol DRIGetDrawableInfo from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!
Symbol DRIGetDeviceInfo from module /usr/X11R6/lib/modules/drivers/fglrx_drv.o is unresolved!

and fglrxinfo gives:

Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)

I think it's supposed to mention the ATI card here when it's all set up right.

All the other posts on the subject mention fglrxconfig, which i don't seem to have. They are also all pretty distribution-specific involving things like sax and yast. So I think I need help from a slacker on this one.

Thanks,
Brian
 
Old 04-27-2006, 11:19 PM   #2
187807
Member
 
Registered: Oct 2003
Location: North Carolina, USA
Distribution: Slackware 11
Posts: 174

Rep: Reputation: 30
What does "custom 2.6.13 kernel" mean? Did you compile it yourself?

If you did compile it yourself double check to be sure that you selected the DRI choice (even if you don't choose any of the cards in the sub-menu choose the DRI choice).

Now, depending on which X you are using the X config file should be /etc/X11/xorg.conf but you MIGHT have an older X where it's called something like XF86config or something like that.

In either case, edit the appropriate file with text editor. You are looking for section that looks like this:

Code:
Section "Device"

    #VideoRam    131072
    # Insert Clocks lines here if appropriate
    Identifier     "** NVIDIA (generic)                   [nv]"
    Driver         "nvidia"
EndSection
Yours will look different but you should have a line that starts with "Driver" like mine above. Within the quotes you should try "fglrx". If you've got your drivers installed correctly it might work. If not just revert to the option you are using now while you are figuring it out. Another "Driver" option might be "ati" as I believe some X stuff now comes with native ati (limited, I believe) drivers.

Sorry can't help you more. Just couple things to try though. you will need to restart your X session after modifying the config file to see if the effects work. There are other options in the X config file involving loading GLX and DRI and another or two I can't remember that different manufacturers might use differently. Just have to research and try.

{edit: vagueness}

Good luck. You'll get it figured out.

Last edited by 187807; 04-27-2006 at 11:23 PM.
 
Old 04-27-2006, 11:20 PM   #3
187807
Member
 
Registered: Oct 2003
Location: North Carolina, USA
Distribution: Slackware 11
Posts: 174

Rep: Reputation: 30
Oh, and if it wasn't a kernel that you personally compiled then you will want to install the kernel-headers for that kernel as well. Then rerun the ati installer and try the above mentioned.
 
Old 04-27-2006, 11:33 PM   #4
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,490

Original Poster
Rep: Reputation: Disabled
Thanks for the quick reply!

Yes, I meant that i compiled it myself. Do you know where the DRI option is? I couldn't find one.

I'm using X 6.8.2, I've got a section in my xorg.conf pointing to fglrx, and lsmod shows that a module called fglrx is loaded.

Any other ideas?

Thanks,
Brian
 
Old 04-27-2006, 11:50 PM   #5
187807
Member
 
Registered: Oct 2003
Location: North Carolina, USA
Distribution: Slackware 11
Posts: 174

Rep: Reputation: 30
I'm using 64-bit and a different kernel version but it should be in the same or a similar location for your config. Under "Device Drivers"-->"Character Devices" you might see something like I have pasted below.

I'll keep thinking about other problems that might be occuring. I've had the very issue you describe before but downloading a new kernel source, untarbzip2ing and then making and installing, then installing nvidia drivers again worked fine for me with the DRI issue.

anyway, here's the section I was talking about:


Code:
Arrow keys navigate the menu.  <Enter> selects submenus --->.  Highlighted      │
  │  letters are hotkeys.  Pressing <Y> includes, <N> excludes, <M> modularizes      │
  │  features.  Press <Esc><Esc> to exit, <?> for Help, </> for Search.  Legend:[*] │
  │  built-in  [ ] excluded  <M> module  < > module capable                          │
  │ ┌─^(-)─────────────────────────────────────────────────────────────────────────┐ │
  │ │ < > Applicom intelligent fieldbus card support                               │ │
  │ │     Ftape, the floppy tape device driver  --->                               │ │
  │ │ --- /dev/agpgart (AGP Support)                                               │ │
  │ │ < >   Intel 440LX/BX/GX, I8xx and E7x05 chipset support                      │ │
  │ │ <*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)          │ │
  │ │ < >   3dfx Banshee/Voodoo3+                                                  │ │
  │ │ < >   ATI Rage 128                                                           │ │
  │ │ < >   ATI Radeon                                                             │ │
  │ │ < >   Matrox g200/g400                                                       │ │
  │ │ < >   SiS video cards                                                        │ │
  │ │ < >   Via unichrome video cards                                              │ │
  │ │ < >   Savage video cards                                                     │ │
  │ │ < > ACP Modem (Mwave) support                                                │ │
  │ │ < > RAW driver (/dev/raw/rawN) (OBSOLETE)                                    │ │
  │ │[*] HPET - High Precision Event Timer
Good luck
 
Old 04-27-2006, 11:51 PM   #6
187807
Member
 
Registered: Oct 2003
Location: North Carolina, USA
Distribution: Slackware 11
Posts: 174

Rep: Reputation: 30
btw, might as well grab a 2.6.16.11 source at kernel.org. It's what I'm using now (on 64-bit though) but should work for you, too. nvidia has always been great to me for driver stuff. I mean as far as getting them working with DRI, etc.
 
Old 04-28-2006, 12:07 AM   #7
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,490

Original Poster
Rep: Reputation: Disabled
I have also had no problem with NVidia drivers once I got the hang of them. This ATI driver is a little bit of a pain though.

I am building DRI as a module. I am not sure whether it is loading properly. An lsmod doesn't show any module called DRI. Do you think that I should build it into the kernel?

Thanks,
Brian
 
Old 04-28-2006, 12:30 AM   #8
187807
Member
 
Registered: Oct 2003
Location: North Carolina, USA
Distribution: Slackware 11
Posts: 174

Rep: Reputation: 30
Quote:
Originally Posted by BCarey
I have also had no problem with NVidia drivers once I got the hang of them. This ATI driver is a little bit of a pain though.

I am building DRI as a module. I am not sure whether it is loading properly. An lsmod doesn't show any module called DRI. Do you think that I should build it into the kernel?

Thanks,
Brian
You could try it. I don't usually build stuff as modules, but that's just the way I've always done it. I build stuff in. I don't know why I just do. I know I use stuff that I choose to enable so I just get it in there instead of doing modular stuff.

Just out of curiosity, how are you building this kernel?

That is, I'm guessing you either make xconfig or make menuconfig....then do you just do plain "make" or do you do "make bzImage"?

If you just do "make" it should "build" the modules in stage 2 of the make process there. I always, after doing plain make as regular user, go root and issue the following (your "arch" may differ):

Code:
# make modules_install
# cp arch/x86_64/boot/bzImage /boot/linux-2.x.y.z
Then I modify my /etc/lilo.conf adding the new linux-2.x.y.z at top for default then reboot.

IF you do "make bzImage" then you will probably have to do (as root):

Code:
# make modules
# make modules_install
# cp arch/x86_64/boot/bzImage /boot/linux-2.x.y.z
 
Old 04-28-2006, 12:34 AM   #9
187807
Member
 
Registered: Oct 2003
Location: North Carolina, USA
Distribution: Slackware 11
Posts: 174

Rep: Reputation: 30
Sounds like you know what you are doing, but just to be sure you may do a:

Code:
$ uname -a
to verify that you are, in fact, using the kernel that you compiled and not another version.
 
Old 04-28-2006, 09:53 AM   #10
BCarey
Senior Member
 
Registered: Oct 2005
Location: New Mexico
Distribution: Slackware
Posts: 1,490

Original Poster
Rep: Reputation: Disabled
I do:

make menuconfig
make modules_install

then I copy my kernel and configure lilo. Sometimes I use initrd, other times not.

I have also confirmed my kernel with uname.

Brian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon Xpress 200 izelpii Linux - Hardware 44 10-30-2007 10:00 AM
How to ATI Radeon® Xpress 200M IGP imdeemvp Fedora 3 03-04-2007 07:20 AM
8.6.20 ATI Drivers and ATI Radeon XPress 200M ltracy Linux - Hardware 8 04-28-2006 08:52 PM
ATI Radeon Xpress 200M drivers konowdude Debian 1 01-13-2006 04:53 AM
how to get dri working with ATI radeon xpress 200m chmtdist Suse/Novell 1 12-19-2005 03:17 PM


All times are GMT -5. The time now is 02:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration