LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-16-2006, 07:12 AM   #1
binary1011100
Member
 
Registered: Apr 2006
Location: Manchester, UK
Distribution: Slackware, Debian
Posts: 89

Rep: Reputation: 15
Can't Get 3D acceleration with ATI Radeon X300 SE in slackware


Can anybody help me get my PCI-E ATI X300 SE card working in 3D with X on slackware with kernel 2.6.16.18
 
Old 06-16-2006, 10:42 AM   #2
Fluxx
Member
 
Registered: Aug 2005
Location: Bavaria, Germany
Distribution: Slackware (Current)
Posts: 225

Rep: Reputation: 30
Did you install the ATI-driver from ati homepage? Did you receive errors during the installation?

I ask, because I have running an ATI X600SE here on Slackware current with last Slackware kernel (2.6.16.20) without problems.

Fluxx.

P. S.: If you are not successful with Slackware standard kernel with ATI drivers I can help you to recompile your kernel so that there are no more errors with ATI drivers.
 
Old 06-16-2006, 05:36 PM   #3
syvy
Member
 
Registered: Sep 2005
Location: Germany
Distribution: slackware64
Posts: 110

Rep: Reputation: 16
I had that adventure yesterday:

I installed kernel 2.6.16.20 (test26.s) from slackware current and the newest
ATI drivers fglrx_6_8_0-8.25.18-1.i386. I got error messages about the kernel modules.
They werenīt compiled with the same compiler version the kernel was made.
So I temporarily installed gcc 3.4.4, ran the ati-installer again and everything works fine now.
No recompiling of the kernel was nessesary. (BTW, itīs a Radeon X800 GTO here)
 
Old 06-18-2006, 02:40 PM   #4
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Check my thread in my sig about DRI (3D Acceleration).

It has an extensive ATI section.
 
  


Reply

Tags
3d, acceleration, ati, cant, get, radeon, slackware, x300


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon x300 Driver Problems Kavon89 Linux - Hardware 4 01-24-2006 01:09 PM
no OpenGL Driect Rendering or 3D Acceleration for ATI X300 jsworth Linux - Hardware 3 01-15-2006 11:04 PM
Ati Radeon Mobility X300 Graphics Card Murdock1979 Linux - Hardware 4 01-15-2006 01:24 AM
Cannot start X with ATi Radeon X300 on Slackware 10.1 belga Linux - Hardware 2 07-14-2005 01:18 PM
laptop vid card (ati radeon x300) trying to get hardware accelleratoin going. nkoplm Linux - General 2 06-18-2005 08:51 PM


All times are GMT -5. The time now is 03:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration