LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-24-2013, 04:32 PM   #1
m1m
Member
 
Registered: Jan 2011
Posts: 38

Rep: Reputation: 0
Can't eject CD in Slackware 14.1 Inappropriate ioctl for device


After upgrade to Slackware 14.1 x86_64 I can't eject from console as normal user:

Code:
eject: unable to eject, last error: Inappropriate ioctl for device
I have sufficient permissions etc.
Code:
~> ls /dev/sr0
brw-rw---- 1 root cdrom 11, 0 11-24 22:31 /dev/sr0
~> groups 
users lp floppy audio video cdrom plugdev power netdev scanner burning
As root I don't see any errors, but cd-rom isn't ejected. It was working in Slackware 14.0
However I can eject from XFCE Thunar menu (as normal user)

More information:
as normal user
Code:
~> eject -v
eject: using default device `cdrom'
eject: device name is `cdrom'
eject: expanded name is `/dev/cdrom'
eject: `/dev/cdrom' is a link to `/dev/sr0'
eject: `/dev/sr0' is not mounted
eject: `/dev/sr0' is not a mount point
eject: `/dev/sr0' is not a multipartition device
eject: trying to eject `/dev/sr0' using CD-ROM eject command
eject: CD-ROM eject command failed
eject: trying to eject `/dev/sr0' using SCSI commands
eject: SCSI eject failed
eject: trying to eject `/dev/sr0' using floppy eject command
eject: floppy eject command failed
eject: trying to eject `/dev/sr0' using tape offline command
eject: tape offline command failed
eject: unable to eject, last error: Inappropriate ioctl for device
as root
Code:
~> eject -v
eject: using default device `cdrom'
eject: device name is `cdrom'
eject: expanded name is `/dev/cdrom'
eject: `/dev/cdrom' is a link to `/dev/sr0'
eject: `/dev/sr0' is not mounted
eject: `/dev/sr0' is not a mount point
eject: `/dev/sr0' is not a multipartition device
eject: trying to eject `/dev/sr0' using CD-ROM eject command
eject: CD-ROM eject command failed
eject: trying to eject `/dev/sr0' using SCSI commands
eject: SCSI eject succeeded

Last edited by m1m; 11-24-2013 at 04:40 PM.
 
Old 11-24-2013, 05:09 PM   #2
Diantre
Member
 
Registered: Jun 2011
Distribution: Slackware
Posts: 390

Rep: Reputation: 150Reputation: 150
Possibly related to the udev/eject problem... Check this thread and this one.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 14, udev, eject Woodsman Slackware 16 10-21-2012 01:56 AM
when i use right click and then choose eject button eject: unable to open `/dev/hda' sanatkrtiwari86 Linux - Newbie 3 12-02-2008 05:10 AM
Eject CD/DVD Media using Eject Button - Hal/Udev help v00d00101 Linux - Hardware 4 03-17-2008 03:04 PM
Cannot eject CD in Slackware 10 pcd007 Linux - Newbie 11 10-01-2004 11:25 PM


All times are GMT -5. The time now is 09:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration