LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-12-2003, 05:41 PM   #1
exec
LQ Newbie
 
Registered: Feb 2003
Posts: 19

Rep: Reputation: 0
can't disable pcmcia


I'm trying to get my sound working on slackware, but when I do make modules_install, it errors during some pcmcia stuff, I tryed to just disable all pcmcia options in my kernel since I don't need them, but the xconfig won't let me touch any of them. is there anyway I can disable them all?
 
Old 02-12-2003, 07:25 PM   #2
exec
LQ Newbie
 
Registered: Feb 2003
Posts: 19

Original Poster
Rep: Reputation: 0
Unresolved symbols in /lib/modules/2.4.18/pcmcia/parport_cs.o.gz
parport_cs.o.gz seems to be the problem, I didn't make mrproper and took out all pcmcia support, but this still pops up....anyone know where this is in the kernel config?
 
Old 02-12-2003, 08:40 PM   #3
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
I think you need to delete the module /lib/modules/2.4.18/pcmcia/parport_cs.o.gz. If all the references are removed from the running kernel, but something is attempting to load the module or build the dependency file (like depmod -a in rc.modules) then the prior existing module will result in unresolved symbols. The make modules_install could be attempting to run depmod as well causing the error.
 
Old 02-12-2003, 08:44 PM   #4
exec
LQ Newbie
 
Registered: Feb 2003
Posts: 19

Original Poster
Rep: Reputation: 0
find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i -r ln -sf ../{} pcmcia
if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.4.18; fi
depmod: *** Unresolved symbols in /lib/modules/2.4.18/pcmcia/ibmtr_cs.o.gz
depmod: init_trdev
depmod: tr_type_trans
depmod: register_trdev
depmod: unregister_trdev
depmod: *** Unresolved symbols in /lib/modules/2.4.18/pcmcia/parport_cs.o.gz
depmod: parport_proc_unregister
depmod: parport_pc_probe_port
depmod: parport_unregister_port
make: *** [_modinst_post] Error 1

theres exactly what its saying, so should I just del the .gz?
 
Old 02-12-2003, 11:10 PM   #5
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
I would. You could check the date/time stamps on the files first if you like. I do not believe they will match your kernel build time for the System.map that is in reference. The files would be remants from the last build. Personally, I am surprised you are even seeing this problem. I would of thought the process would of deleted them.

Is your system date set correctly? I have seen wierd happenings on systems where a kernel is built at one time, and then the clock is changed back in time prior to the kernel build, then a rebuild is attempted. All the files from the prior build will appear newer than the current build. That will mess up most any make system.

When I migrate from a stock kernel after an install to a custom kernel, I trash the entire tree from the kernel version down. Unless I desire to keep it for a legacy reference, in that case I rename it. The modules_install will create the tree if needed for modules when a module enabled kernel is built and then install just the modules that were built.
 
Old 02-13-2003, 12:32 AM   #6
exec
LQ Newbie
 
Registered: Feb 2003
Posts: 19

Original Poster
Rep: Reputation: 0
I finally got it workin, I did make mrproper and installed a brand new kernel from the cd, edited it, and all went smooth...I donno why it was buggin like that. Ahh well, fixed now, thx for the help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable PCMCIA on startup Peanutman Fedora 3 08-12-2005 04:58 AM
Disable PCMCIA at boot, Slackware 10.1 linuxchump Slackware 5 04-21-2005 06:17 PM
What module would I unload to disable pcmcia? elempoimen Linux - Laptop and Netbook 10 12-22-2004 09:51 AM
How do i disable booting of pcmcia? Roitoy Red Hat 5 08-10-2004 07:31 AM
How to Disable PCMCIA in Mandrake 9.2 aktlikeseggs Linux - Newbie 1 04-25-2004 02:53 PM


All times are GMT -5. The time now is 01:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration