LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-24-2013, 07:58 AM   #1
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,170

Rep: Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013
Can't connect to wifi through NetworkManager


This is on a laptop Packard Bell EasyNote tk37

Slackware64-current Thu Oct 24 01:22:57 UTC 2013

Wired connections works through NM, wireless don't.

wep mode set on my ADSL modem (Freebox).

Wireless works with the my ThinkPad (same system).

Code:
bash-4.2# lspci -vnn|grep -A11 Network
04:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8192SE Wireless LAN Controller [10ec:8174] (rev 10)
        Subsystem: Realtek Semiconductor Co., Ltd. Device [10ec:8186]
        Flags: bus master, fast devsel, latency 0, IRQ 17
        I/O ports at 2000 [size=256]
        Memory at d4600000 (32-bit, non-prefetchable) [size=16K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Legacy Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Virtual Channel
        Capabilities: [160] Device Serial Number 88-55-22-fe-ff-4c-e0-00
        Kernel driver in useThu Oct 24 01:22:57 UTC 2013: rtl8aw no report192se
bash-4.2#
Code:
bash-4.2# iwlist scan
eth0      Interface doesn't support scanning.

lo        Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 3E:D8:FB:79:46:C4
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=70/70  Signal level=10 dBm  
                    Encryption key:on
                    ESSID:"Didier"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=000000027d02b62a
                    Extra: Last beacon: 59ms ago
                    IE: Unknown: 0006446964696572
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030101
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1A6E1017FFFF000001000000000000000000000000000000000000
                    IE: Unknown: 3D1601050700000000000000000000000000000000000000
                    IE: Unknown: 3E0100
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: 7F0101
                    IE: Unknown: DD07000C4300000000
                    IE: Unknown: DD1E00904C336E1017FFFF000001000000000000000000000000000000000000
                    IE: Unknown: DD1A00904C3401050700000000000000000000000000000000000000
Nothing wrong found about that chipset on LQ or on the web.

What should I look at to investigate further?
 
Old 10-24-2013, 08:12 AM   #2
mancha
Member
 
Registered: Aug 2012
Posts: 279

Rep: Reputation: Disabled
The debugging strategy I outlined in another thread might be helpful to you.

--mancha
 
Old 10-24-2013, 08:22 AM   #3
schneidz
Senior Member
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 3,917

Rep: Reputation: 600Reputation: 600Reputation: 600Reputation: 600Reputation: 600Reputation: 600
what happens when you try to connect manually:
Code:
sudo iwconfig wlan0 essid Didier
sudo dhclient wlan0 # assuming dhcp
 
Old 10-24-2013, 08:43 AM   #4
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,170

Original Poster
Rep: Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013
Code:
# dbus-send --system --print-reply --dest=fi.w1.wpa_supplicant1 /fi/w1/wpa_supplicant1 org.freedesktop.DBus.Properties.Set string:fi.w1.wpa_supplicant1 string:DebugLevel variant:string:"msgdump"
# dbus-send --system --print-reply --dest=fi.w1.wpa_supplicant1 /fi/ew1/wpa_supplicant1 org.freedesktop.DBus.Properties.Set string:fi.w1.wpa_supplicant1 string:DebugTimestamp variant:boolean:true
Sorry for the dumb question, mancha, but where do I see/write that?
Code:
bash-4.2# cat /etc/wpa_supplicant.conf 
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root
bash-4.2#
 
Old 10-24-2013, 09:04 AM   #5
mancha
Member
 
Registered: Aug 2012
Posts: 279

Rep: Reputation: Disabled
The dbus-send commands are run as root on the command line.
 
Old 10-24-2013, 09:13 AM   #6
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,407

Rep: Reputation: 830Reputation: 830Reputation: 830Reputation: 830Reputation: 830Reputation: 830Reputation: 830
Quote:
wep mode set on my ADSL modem
wpa_supplicant is not applicable.

Why are you running WEP? It is irrecoverably broken from a security standpoint.
 
Old 10-24-2013, 09:18 AM   #7
mancha
Member
 
Registered: Aug 2012
Posts: 279

Rep: Reputation: Disabled
Quote:
Originally Posted by allend View Post
wpa_supplicant is not applicable.
That is inaccurate.
 
Old 10-24-2013, 09:24 AM   #8
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,170

Original Poster
Rep: Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013
Quote:
Originally Posted by allend View Post
wpa_supplicant is not applicable.

Why are you running WEP? It is irrecoverably broken from a security standpoint.
That's in a house in the woods, 300 m from nearest neighbor


And that makes easier for my wife to watch TV on her smartphone (ever tried to type a WPA key on one of those?) Nevertheless thanks for your remark, I will try to use wpa and see if that helps.
 
Old 10-24-2013, 09:29 AM   #9
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,170

Original Poster
Rep: Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013
@ mancha: it took me _some_time_ to realize that you meant commands to type as root...

Is following output expected?
Code:
bash-4.2# dbus-send --system --print-reply --dest=fi.w1.wpa_supplicant1 /fi/w1/wpa_supplicant1 org.freedesktop.DBus.Properties.Set string:fi.w1.wpa_supplicant1 string:DebugLevel variant:string:"msgdump"
method return sender=:1.5 -> dest=:1.49 reply_serial=2
bash-4.2# dbus-send --system --print-reply --dest=fi.w1.wpa_supplicant1 /fi/ew1/wpa_supplicant1 org.freedesktop.DBus.Properties.Set string:fi.w1.wpa_supplicant1 string:DebugTimestamp variant:boolean:true
Error org.freedesktop.DBus.Error.UnknownMethod: Method "Set" with signature "ssv" on interface "org.freedesktop.DBus.Properties" doesn't exist

bash-4.2#
PS Here is the log. I typed the commands, then tried to get a connection.
Code:
bash-4.2# tail --lines 50 /var/log/wpa_supplicant.log 
1382625359.124604: wlan0: Event CHANNEL_LIST_CHANGED (31) received
1382625359.124682: nl80211: Regulatory information - country=00
1382625359.124690: nl80211: 2402-2472 @ 40 MHz
1382625359.124697: nl80211: 2457-2482 @ 20 MHz
1382625359.124703: nl80211: 2474-2494 @ 20 MHz
1382625359.124710: nl80211: 5170-5250 @ 40 MHz
1382625359.124716: nl80211: 5735-5835 @ 40 MHz
1382625359.124728: nl80211: Added 802.11b mode based on 802.11g information
1382625359.124735: P2P: Add operating class 81
1382625359.124742: P2P: Channels - hexdump(len=13): 01 02 03 04 05 06 07 08 09 0a 0b 0c 0d
1382625359.124752: wlan0: P2P: Update channel list
1382625359.204202: wlan0: Disconnected - do not scan
1382625359.204226: wlan0: State: DISCONNECTED -> DISCONNECTED
1382625359.204277: wpa_driver_nl80211_set_operstate: operstate 0->0 (DORMANT)
1382625359.204286: netlink: Operstate: linkmode=-1, operstate=5
1382625359.209376: dbus: flush_object_timeout_handler: Timeout - sending changed properties of object /fi/w1/wpa_supplicant1/Interfaces/7
1382625360.028185: nl80211: Event message available
1382625360.028246: nl80211: New scan results available
1382625360.028262: wlan0: Event SCAN_RESULTS (3) received
1382625360.028307: nl80211: Received scan results (1 BSSes)
1382625360.028342: wlan0: BSS: Start scan result update 23
1382625360.028355: BSS: last_scan_res_used=1/32 last_scan_full=0
1382625360.028364: wlan0: New scan results available
1382625360.028417: wlan0: State: DISCONNECTED -> DISCONNECTED
1382625360.028426: wpa_driver_nl80211_set_operstate: operstate 0->0 (DORMANT)
1382625360.028433: netlink: Operstate: linkmode=-1, operstate=5
1382625360.028446: wlan0: Checking for other virtual interfaces sharing same radio (phy0) in event_scan_results
1382625360.029425: RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
1382625360.029452: RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
1382625360.029480: nl80211: if_removed already cleared - ignore event
1382625362.593935: dbus: fi.w1.wpa_supplicant1.Interface.Scan (/fi/w1/wpa_supplicant1/Interfaces/7)
1382625362.594013: nl80211: Scan SSID - hexdump_ascii(len=0): [NULL]
1382625362.750655: Scan requested (ret=0) - scan timeout 30 seconds
1382625362.751252: nl80211: Event message available
1382625362.751279: nl80211: Scan trigger
1382625363.649890: nl80211: Event message available
1382625363.649945: nl80211: New scan results available
1382625363.649959: wlan0: Event SCAN_RESULTS (3) received
1382625363.650048: nl80211: Received scan results (1 BSSes)
1382625363.650069: wlan0: BSS: Start scan result update 24
1382625363.650082: BSS: last_scan_res_used=1/32 last_scan_full=0
1382625363.650091: wlan0: New scan results available
1382625363.650116: wlan0: State: DISCONNECTED -> DISCONNECTED
1382625363.650125: wpa_driver_nl80211_set_operstate: operstate 0->0 (DORMANT)
1382625363.650131: netlink: Operstate: linkmode=-1, operstate=5
1382625363.650146: wlan0: Checking for other virtual interfaces sharing same radio (phy0) in event_scan_results
1382625363.650568: RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
1382625363.650581: RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
1382625363.650614: nl80211: if_removed already cleared - ignore event
1382625363

Last edited by Didier Spaier; 10-24-2013 at 09:38 AM. Reason: PS added
 
Old 10-24-2013, 09:32 AM   #10
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,407

Rep: Reputation: 830Reputation: 830Reputation: 830Reputation: 830Reputation: 830Reputation: 830Reputation: 830
Quote:
That is inaccurate
How so? From 'man wpa_supplicant'
Quote:
wpa_supplicant is an implementation of the WPA Supplicant component, i.e., the part that runs in the client stations.
Quote:
ever tried to type a WPA key on one of those?
Me, no. My daughter seems to have it memorised.

Last edited by allend; 10-24-2013 at 09:34 AM.
 
Old 10-24-2013, 09:40 AM   #11
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,812

Rep: Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817
Quote:
Originally Posted by Didier Spaier View Post
That's in a house in the woods, 300 m from nearest neighbor
if people using your Wi-Fi really isn't a concern you could just get rid of wep and not bother with WPA. it'll certainly make setup easier.
 
Old 10-24-2013, 09:46 AM   #12
mancha
Member
 
Registered: Aug 2012
Posts: 279

Rep: Reputation: Disabled
Hi Didier.

There was a small typo in the command, use these:
Code:
dbus-send --system --print-reply --dest=fi.w1.wpa_supplicant1 /fi/w1/wpa_supplicant1 org.freedesktop.DBus.Properties.Set string:fi.w1.wpa_supplicant1 string:DebugLevel variant:string:"msgdump"

dbus-send --system --print-reply --dest=fi.w1.wpa_supplicant1 /fi/w1/wpa_supplicant1 org.freedesktop.DBus.Properties.Set string:fi.w1.wpa_supplicant1 string:DebugTimestamp variant:boolean:true
It would be important to see the NM log as well (in /var/log/syslog) as well as a full wpa_supplicant.log for the entire connection process. Since the latter is very verbose, I suggest using a pastebin rather than posting to LQ directly.

Note: the typo was the "e" in /fi/ew1/wpa_supplicant1

Last edited by mancha; 10-24-2013 at 09:55 AM.
 
Old 10-24-2013, 09:56 AM   #13
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,170

Original Poster
Rep: Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013
Quote:
Originally Posted by ruario View Post
if people using your Wi-Fi really isn't a concern you could just get rid of wep and not bother with WPA. it'll certainly make setup easier.
I tried, but no way. I should use a web interface to a setting panel associated with my internet account, and not using a key to secure the connection is not allowed by my provider.
 
Old 10-24-2013, 10:20 AM   #14
Didier Spaier
Senior Member
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slackware{,64}-{14.1,current} on a Lenovo Thinkpad T61 6457-4XG
Posts: 4,170

Original Poster
Rep: Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013Reputation: 1013
Hi Mancha,

here are the logs. See the trace in syslog...
syslog: http://pastebin.com/PVCfxTtb
wpa_supplicant.log: http://pastebin.com/feijBDxK

Last edited by Didier Spaier; 10-24-2013 at 10:25 AM.
 
Old 10-24-2013, 10:50 AM   #15
mancha
Member
 
Registered: Aug 2012
Posts: 279

Rep: Reputation: Disabled
OK. This is helping us get to the problem.

Let's try the low-hanging fruit first. The multiple disconnections could be related to a stale or multiple wpa_supplicant instances. Let's get rid of them all:

Code:
killall wpa_supplicant
Also, in NM-applet, how have you configured your Wifi-security? WEP 40/128-bit key? I suggest you input it as hex.

If these things don't work, let's move to Plan B.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable wifi interface in Fedora 19 (NetworkManager) moo-cow Linux - Software 4 09-24-2013 11:15 AM
WIFI with NetworkManager in Slackware 14 staus Slackware 11 04-15-2013 10:30 PM
[SOLVED] How to get networkmanager to connect wifi in bootup. john.wythe@activant.com Linux - Networking 2 01-02-2011 04:43 AM
[SOLVED] Msi Wind: can't find wifi or networkmanager lilou_b Linux - Newbie 21 05-02-2010 10:30 PM
Networkmanager slow to start Wifi pugsley Linux - Wireless Networking 0 04-27-2007 06:32 PM


All times are GMT -5. The time now is 06:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration