LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-26-2004, 09:44 AM   #1
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Rep: Reputation: 15
Can't connect to internet. (router)


Slackware 9.1 (KDE).

Router - Netgear WGT624.
Modem - Zyxel prestige 600 series.
Realtek RTL8139/810X Family PCI Fast Ethernet NIC.

I've had this problem before so I've tried looking through earlier threads
and some old notes but still can't figure out what to do. I was finally able to
connect to internet the last time but I can't seem to remember what I did

This is what I've done in netconfig:

HOSTNAME: hostname
DOMAIN NAME: domain.net
I choose DHCP but leave it empty.

I also tried Static IP.

In /etc/rc.d/rc.inet1 I typed in my IP-adress (192.168.0.3), netmask and
"yes" at USE_DHCP.

In /etc/resolv.conf I tried adding the line "nameserver #" where # is the
DNS namserver adress for my ISP.

Can anyone help me out? What have I missed?
 
Old 02-26-2004, 09:47 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Have you set the default gateway?
 
Old 02-26-2004, 09:56 AM   #3
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Original Poster
Rep: Reputation: 15
I had left it empty at first and now I tried 192.168.0.1 but still can't connect.
 
Old 02-26-2004, 11:56 AM   #4
tangle
Senior Member
 
Registered: Apr 2002
Location: Smithville, TN
Distribution: Slackware
Posts: 1,744

Rep: Reputation: 70
You might want to try 192.168.1.1. I know Linksys uses that as a default gateway for their routers.
 
Old 02-26-2004, 12:08 PM   #5
NomDeGuerre
Member
 
Registered: Oct 2003
Posts: 136

Original Poster
Rep: Reputation: 15
Tried it but it didn't work.
 
Old 02-26-2004, 01:17 PM   #6
bnice
Member
 
Registered: Feb 2004
Location: Sacramento, CA
Distribution: Slack 9.1, slackware-current
Posts: 284

Rep: Reputation: 30
please post output from

route

ifconfig

nameserver address should point at your router
 
Old 02-27-2004, 05:04 AM   #7
dave bean
Member
 
Registered: Jun 2003
Location: UK
Distribution: Slackware 9.1
Posts: 136

Rep: Reputation: 15
hi
my suggestion would be to forget about DHCP, give yourself a static address and set the router as the default gateway, as bnice said yor nameserver needs to be yor router (if it is configured to pick up the DNS server address from yor ISP).

Do you have html pages to configure yor router ? open a web browser and try
http://192.168.0.1 Once inside set yor router not to assign addresses via DHCP (Disable router as DHCP server).

Then (and this depends on your post back with ifconfig etc) try:
Code:
route add default gw 192.168.0.1
and you should be good to go . .
 
Old 02-27-2004, 06:18 AM   #8
davidsrsb
Member
 
Registered: Oct 2003
Location: Kuala Lumpur, Malaysia
Distribution: Slackware 13.37 current
Posts: 770

Rep: Reputation: 33
If the router is 192.168.1.1 then your own address must be 192.168.1.x
as the default gateway must be inside your netmask.
 
Old 02-27-2004, 10:22 AM   #9
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 293

Rep: Reputation: 31
may be you just need to type
netconfig (as root)
and to do everything step-by-step
 
Old 02-27-2004, 12:55 PM   #10
xHades101x
LQ Newbie
 
Registered: Oct 2003
Location: UT
Distribution: SuSE 8.2 Pro
Posts: 9

Rep: Reputation: 0
Router

Im on SuSE 9.0 Running through a Gigafast router, at first there was a request delay on everything I tried to do online, and I found now information anywhere on how to fix it so all i did was upgrade firmware and set local ip to 10.10.0.X a couple days later it just started working correctly, now I get 3.7Down via comcast with no response delays (a little packet loss in UT2K4 though)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to connect Internet via a router? myouch Linux - Networking 7 10-07-2005 10:59 PM
can't connect to Internet with adsl router buzzgrowl Linux - Newbie 8 10-06-2005 09:49 AM
Connect to Internet via a router Hazzie Red Hat 4 10-27-2004 02:24 AM
Connect to the internet with a belkin router.....What do i have to do?????? PaulBak Linux - Networking 26 09-01-2004 03:57 PM
cannot connect to internet after switching dsl router Skunk_Face Linux - Networking 4 03-03-2004 04:08 AM


All times are GMT -5. The time now is 04:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration