LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 06-15-2009, 04:07 PM   #1
kslen
Member
 
Registered: Nov 2008
Distribution: Slackware & LMDE.
Posts: 74

Rep: Reputation: 19
Can't connect to any servers with any FTP client.


Hello.

I can't connect to any FTP server regardless of which client I am using on my Slackware box. If I go to another computer it works just fine.

Code:
ftp> open ftp.start.no 
ftp: connect: Connection timed out
The only thing I can think of is this:
I am getting an IP from the router with
Code:
dhcpcd -s 192.168.0.10 eth3
and the other machines are getting allocated addresses dynamically.

I can do pretty much anything except connect to FTP servers with the machine which has the issue. Is it possible that my Tilgin Vood 452w_B is the culprit? Glancing over the settings I can't see anything which should create such a block, as this machine is outside the DHCP pool (192.168.0.50-100) it could block "specific" traffic without letting me know about it. I dunno. I've been going over and over my configs and this is about to drive me insane.

/etc/HOSTNAME
Code:
crapola.lan
/etc/resolv.conf
Code:
nameserver 192.168.0.1
/etc/hosts
Code:
127.0.0.1       crapola.lan crapola
Any thoughts about where to start to untangle this?
 
Old 06-15-2009, 04:50 PM   #2
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,028
Blog Entries: 5

Rep: Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791
It sounds like you're blocking the ftp port (port 21) outbound from your machine. The built in firewall for most Linux distros is iptables. You might try to stop iptables and test ftp. If it works then you'd need to restart iptables and add a rule to allow outbound port 21.

Most systems don't block outbound traffic - just inbound but its not impossible someone did block it outbound for some reason.
 
Old 06-16-2009, 09:58 PM   #3
kslen
Member
 
Registered: Nov 2008
Distribution: Slackware & LMDE.
Posts: 74

Original Poster
Rep: Reputation: 19
I'm running Slackware 12.2 and the firewall was the first thing to go when I noticed that I couldn't connect to FTP servers from this machine.
 
Old 06-17-2009, 01:52 AM   #4
jmacloue
LQ Newbie
 
Registered: Apr 2009
Posts: 12

Rep: Reputation: 1
So, it's either DNS or firewall trouble. Try ping ftp.start.no - if it succeeds then your DNS is working. Then, try telnet'ing to FTP port with telnet ftp.start.no 21 - if it timeouts as well or shows "connection refused" then there is a firewall somewhere on the path. It may be your router but also it might be set up by your ISP for some reason.
 
Old 06-17-2009, 10:19 AM   #5
kslen
Member
 
Registered: Nov 2008
Distribution: Slackware & LMDE.
Posts: 74

Original Poster
Rep: Reputation: 19
Yep, I can ping it, but telnet is denied. I think I'll have to poke about in the Tilgin settings some more. Last time I had similar issues, I didn't at all get net when I asked specifically for the 192.168.0.10 IP via dhcpcd, but when I asked for a dynamic IP; full access to the interwebs was granted.

Last edited by kslen; 06-17-2009 at 04:45 PM.
 
Old 06-17-2009, 10:20 AM   #6
kslen
Member
 
Registered: Nov 2008
Distribution: Slackware & LMDE.
Posts: 74

Original Poster
Rep: Reputation: 19
As mentioned, EVERYTHING but ftp is working. I'm currently using the troubled box to write these replies. Makes no frigging sense.
 
Old 06-17-2009, 11:49 AM   #7
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,028
Blog Entries: 5

Rep: Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791
Quote:
Originally Posted by kslen View Post
As mentioned, EVERYTHING but ftp is working. I'm currently using the troubled box to write these replies. Makes no frigging sense.
Which is why it seems extremely likely your issue is the ftp port is being blocked somewhere.

You can test the port by typing "telnet <ftphost> 21". That won't establish an ftp connection but will open port 21 if it isn't being blocked.

Post the command and results here.

By the way it worked for me:
Code:
telnet ftp.start.no 21
Trying 195.159.73.78...
Connected to ftp.start.no (195.159.73.78).
Escape character is '^]'.
220 (vsFTPd 2.0.5)

If it doesn't work for you try running "dig ftp.start.no" (or nslookup ftp.start.no if you don't have dig) and posting results.

Last edited by MensaWater; 06-17-2009 at 11:50 AM.
 
Old 06-17-2009, 03:23 PM   #8
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,630

Rep: Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586
Let's recap - dns is OK, http is OK, ftp is not.

what's your ftp program? when I type
ls /usr/bin/*ftp
I get a few. And let's have the _exact_ error message you see in a terminal

ncftp is nice but it does mess up the odd anonymous login. nacftp or lftp work on ftp.heanet.ie

BTW this can be the server. There is a very conservayive MAXALLOWEDCLIENTS setting.Some servers only allow 5 and if you're number 6, you get the middle digit. Try off peak.
 
Old 06-17-2009, 03:33 PM   #9
kslen
Member
 
Registered: Nov 2008
Distribution: Slackware & LMDE.
Posts: 74

Original Poster
Rep: Reputation: 19
dig ftp.start.no
Code:
; <<>> DiG 9.4.3-P1 <<>> ftp.start.no
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 21820
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 4

;; QUESTION SECTION:
;ftp.start.no.                  IN      A

;; ANSWER SECTION:
ftp.start.no.           900     IN      A       195.159.73.78

;; AUTHORITY SECTION:
start.no.               2476    IN      NS      dns2.powertech.no.
start.no.               2476    IN      NS      dns1.powertech.no.

;; ADDITIONAL SECTION:
dns1.powertech.no.      1895    IN      A       195.159.0.101
dns1.powertech.no.      2612    IN      AAAA    2001:840:101::
dns2.powertech.no.      3434    IN      A       195.159.0.201
dns2.powertech.no.      2612    IN      AAAA    2001:840:201::

;; Query time: 17 msec
;; SERVER: 10.82.16.1#53(10.82.16.1)
;; WHEN: Wed Jun 17 21:34:32 2009
;; MSG SIZE  rcvd: 182
nslookup ftp.start.no
Code:
Server:         192.168.0.1
Address:        192.168.0.1#53

Non-authoritative answer:
Name:   ftp.start.no
Address: 195.159.73.78
ls /usr/bin/*ftp
Code:
/usr/bin/gftp  /usr/bin/ncftp    /usr/bin/rftp  /usr/bin/tftp
/usr/bin/lftp  /usr/bin/obexftp  /usr/bin/sftp
I've tried everything from good old "ftp" to MC's client to the FireFTP addon for Firefox, every single one is denied on this specific machine, same clients elsewhere works just dandy no matter what time of day I try connecting on, so I doubt it is the server.

Thanks for all suggestions so far and keep em coming.

Last edited by kslen; 06-17-2009 at 03:35 PM.
 
Old 06-17-2009, 04:38 PM   #10
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,028
Blog Entries: 5

Rep: Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791
Your dig output shows you're resolving the same IP as I am here,

I don't see where you tried the telnet to port 21. Can you do that and post output?
 
Old 06-17-2009, 04:44 PM   #11
kslen
Member
 
Registered: Nov 2008
Distribution: Slackware & LMDE.
Posts: 74

Original Poster
Rep: Reputation: 19
Quote:
Yep, I can ping it, but telnet is denied. I think I'll have to poke about in the Tilgin settings some more. Last time I had similar issues, I didn't at all get net when I asked specifically for the 192.168.0.10 IP via dhcpcd, but when I asked for a dynamic IP; full access to the interwebs was granted.
No error reply, just a timeout.

Code:
telnet ftp.start.no 21                                                                
Trying 195.159.73.78...
telnet: connect to address 195.159.73.78: Connection timed out

Last edited by kslen; 06-17-2009 at 04:48 PM.
 
Old 06-17-2009, 04:53 PM   #12
MensaWater
Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,028
Blog Entries: 5

Rep: Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791Reputation: 791
Well we know the port on that IP works since I could get to it from here.

That means either something in your route to host is blocking port 21 (since you can ping and do other things) or they are specifically blocking your IP (or the range it is isn) for some reason.

What part of the world are you doing this in? Many people routinely block all IPs from various countries (e.g. China, North Korea, Russia) if they don't have reason to go there all the time. I see they are in Norway.
 
Old 06-17-2009, 05:52 PM   #13
kslen
Member
 
Registered: Nov 2008
Distribution: Slackware & LMDE.
Posts: 74

Original Poster
Rep: Reputation: 19
I can connect from other machines using the same software through the very same local network. It isn't just this specific server, it's all servers. Only thing that differ is the way I get an IP from the DHCP server on my local network. *shrugs*

Last edited by kslen; 06-17-2009 at 05:54 PM.
 
Old 06-17-2009, 06:01 PM   #14
kslen
Member
 
Registered: Nov 2008
Distribution: Slackware & LMDE.
Posts: 74

Original Poster
Rep: Reputation: 19
Yep, didn't bother checking wether or not this was the very same issue I had earlier. Just seemed obvious somehow.

Anyways. I told the dhcp server to give me an IP within the pool specified..

Code:
> dhcpcd -s 192.168.0.65 eth3                                                           
Broadcasting DHCP_INFORM for 192.168.0.65
broadcastAddr option is missing in DHCP server response. Assuming 192.168.0.255
dhcpIPaddrLeaseTime option is missing in DHCP server response. Assuming 4294967295 sec
dhcpT1value is missing in DHCP server response. Assuming 2147483647 sec
dhcpT2value is missing in DHCP server response. Assuming 3758096383 sec
DHCP_ACK received from  (192.168.0.1)
Broadcasting ARPOP_REQUEST for 192.168.0.65

> ftp ftp.start.no                                                                      
Connected to ftp.start.no.
220 (vsFTPd 2.0.5)
Name (ftp.start.no:tilgineatmycrotch):
And then..
Code:
> dhcpcd -s 192.168.0.10 eth3                                                            
Broadcasting DHCP_INFORM for 192.168.0.10
broadcastAddr option is missing in DHCP server response. Assuming 192.168.0.255
dhcpIPaddrLeaseTime option is missing in DHCP server response. Assuming 4294967295 sec
dhcpT1value is missing in DHCP server response. Assuming 2147483647 sec
dhcpT2value is missing in DHCP server response. Assuming 3758096383 sec
DHCP_ACK received from  (192.168.0.1)
Broadcasting ARPOP_REQUEST for 192.168.0.10

> ftp ftp.start.no 
ftp: connect: Connection timed out
It's the bastard Tilgin Vood 452w_B as I first suspected indeed.

Last edited by kslen; 06-17-2009 at 06:05 PM.
 
Old 06-17-2009, 06:07 PM   #15
mRgOBLIN
Slackware Contributor
 
Registered: Jun 2002
Location: New Zealand
Distribution: Slackware
Posts: 999

Rep: Reputation: 227Reputation: 227Reputation: 227
<deleted>

no matter it seems you tried what I was suggesting

Last edited by mRgOBLIN; 06-17-2009 at 06:08 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iptables dropping responses from web, dns, ftp servers I try to connect to? Calab Linux - Security 6 10-16-2007 11:58 AM
can't connect with secure ftp client geomatt Linux - Networking 3 02-03-2006 01:27 AM
ProFTPd ... FTP client fails to connect: timeout after client sends 'LIST' nutnut Linux - Software 2 01-01-2006 08:09 PM
can not connect to my pureftp server from Linux client, but i can from windows client bonito Suse/Novell 5 03-16-2005 10:45 PM


All times are GMT -5. The time now is 03:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration